aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/vlc-devel
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-03-04 01:53:47 +0800
committerdinoex <dinoex@FreeBSD.org>2004-03-04 01:53:47 +0800
commit403afb179afe22eeb30bcf5a4a0ddac431c9e52b (patch)
tree9644543a4854b1aaca82b3b89c444c9cecd22ec2 /multimedia/vlc-devel
parentb7c11bf227ee98316bee7bf355917d555b135e9b (diff)
downloadfreebsd-ports-gnome-403afb179afe22eeb30bcf5a4a0ddac431c9e52b.tar.gz
freebsd-ports-gnome-403afb179afe22eeb30bcf5a4a0ddac431c9e52b.tar.zst
freebsd-ports-gnome-403afb179afe22eeb30bcf5a4a0ddac431c9e52b.zip
- use libmad
- new options: WITH_AUTODETECT WITH_LIBMPEG2 WITH_LIBMATROSKA WITHOUT_LIBID3TAG - clean dependencies from ports/63583 63583 Michael Johnson - install 2 man pages - better gnome support - support for libmatroska - new options: WITH_GNOME WITH_ESOUND WITH_AALIB WITH_CDDB WITH_GGI WITH_LIBTHEORA WITH_LIVEMEDIA WITH_SPEEX WITH_SVGALIB WITH_XOSD WITH_OPTIMIZED_CFLAGS - dropped cause of bad dependency list: WANT_GNOME does not work here linke in mplayer.
Diffstat (limited to 'multimedia/vlc-devel')
-rw-r--r--multimedia/vlc-devel/Makefile215
-rw-r--r--multimedia/vlc-devel/files/patch-modules-demux-mkv.cpp198
-rw-r--r--multimedia/vlc-devel/files/theora.c-patch11
-rw-r--r--multimedia/vlc-devel/pkg-plist3
4 files changed, 402 insertions, 25 deletions
diff --git a/multimedia/vlc-devel/Makefile b/multimedia/vlc-devel/Makefile
index 36ea70891735..0cab765c2e6a 100644
--- a/multimedia/vlc-devel/Makefile
+++ b/multimedia/vlc-devel/Makefile
@@ -4,10 +4,28 @@
#
# $FreeBSD$
#
+# Options to define Features:
+# WITH_AUTODETECT=yes
+# WITH_GNOME=yes
+# WITH_ESOUND=yes
+# WITH_AALIB=yes
+# WITH_CDDB=yes
+# WITH_GGI=yes
+# WITH_LIBDVBPSI=yes
+# WITH_LIBID3TAG=yes
+# WITH_LIBMATROSKA=yes
+# WITH_LIBMPEG2=yes
+# WITH_LIBTHEORA=yes
+# WITH_LIVEMEDIA=yes
+# WITH_SPEEX=yes
+# WITH_SVGALIB=yes
+# WITH_XOSD=yes
+# WITH_OPTIMIZED_CFLAGS=yes
+# WITHOUT_LIBID3TAG=yes
PORTNAME= vlc
PORTVERSION= 0.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/videolan/vlc/${PORTVERSION}/
@@ -16,7 +34,7 @@ COMMENT= An X11 video streaming client/server solution
LIB_DEPENDS= dvdcss.2:${PORTSDIR}/multimedia/libdvdcss \
dvdread.3:${PORTSDIR}/multimedia/libdvdread \
- mad.2:${PORTSDIR}/audio/mad \
+ mad.2:${PORTSDIR}/audio/libmad \
avcodec.0:${PORTSDIR}/multimedia/ffmpeg \
a52.0:${PORTSDIR}/audio/liba52 \
iconv.3:${PORTSDIR}/converters/libiconv \
@@ -25,12 +43,6 @@ LIB_DEPENDS= dvdcss.2:${PORTSDIR}/multimedia/libdvdcss \
faad.0:${PORTSDIR}/audio/faad \
wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2 \
slp.1:${PORTSDIR}/net/openslp
-.if defined(WITH_LIBDVBPSI)
-LIB_DEPENDS+= dvbpsi.3:${PORTSDIR}/multimedia/libdvbpsi
-.endif
-
-# After libmpeg2 release 0.3.2
-# mpeg2.0:${PORTSDIR}/multimedia/libmpeg2 \
USE_GETOPT_LONG=yes
USE_GETTEXT= yes
@@ -53,34 +65,193 @@ CONFIGURE_ARGS+=--with-dvdcss=${LOCALBASE} \
--with-a52=${LOCALBASE} \
--enable-ffmpeg \
--with-ffmpeg=${LOCALBASE} \
- --disable-libmpeg2 \
--disable-libcdio \
- --disable-libcddb \
--program-prefix="" \
--without-libintl-prefix \
- --without-libiconv-prefix \
+ --without-libiconv-prefix
+
+MAN1= vlc.1 \
+ vlc-config.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_AUTODETECT) && !defined(BATCH)
+
+.if ${HAVE_GNOME:Mgnomelibs}!="" && !defined(WITHOUT_GNOME)
+WITH_GNOME= yes
+.endif
+
+.if ${HAVE_GNOME:Mesound}!="" && !defined(WITHOUT_ESOUND)
+WITH_ESOUND= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libaa.so.1) && !defined(WITHOUT_AALIB)
+WITH_AALIB= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libcddb.so.1) && !defined(WITHOUT_CDDB)
+WITH_CDDB= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libggi.so.2) && !defined(WITHOUT_GGI)
+WITH_GGI= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libdvbpsi.so.3) && !defined(WITHOUT_LIBDVBPSI)
+WITH_LIBDVBPSI= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libtheora.so.0) && !defined(WITHOUT_LIBTHEORA)
+WITH_LIBTHEORA= yes
+.endif
+
+.if exists(${LOCALBASE}/live/liveMedia/libliveMedia.a) && !defined(WITHOUT_LIVEMEDIA)
+WITH_LIVEMEDIA= yes
+.endif
-.if defined(WITH_LIBDVBPSI)
-CONFIGURE_ARGS+= --with-dvbpsi=${LOCALBASE}
-PLIST_SUB+= LIBDVBPSI=""
+.if exists(${LOCALBASE}/lib/libspeex.so.2) && !defined(WITHOUT_SPEEX)
+WITH_SPEEX= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/lib/vga.so.1) && !defined(WITHOUT_SVGALIB)
+WITH_SVGALIB= yes
+.endif
+
+.if exists(${LOCALBASE}/libxosd.so.4) && !defined(WITHOUT_XOSD)
+WITH_XOSD= yes
+.endif
+
+.endif
+
+.if defined(WITH_GNOME) && !defined(WITHOUT_GNOME)
+USE_GNOME+= gnomelibs
+CONFIGURE_ARGS+=--enable-gnome
+PKGNAMESUFFIX= -gnome
+PLIST_FILES+= bin/gnome-vlc \
+ lib/vlc/gui/libgnome_plugin.so \
+ lib/vlc/misc/libgnome_main_plugin.so
.else
-CONFIGURE_ARGS+= --disable-dvbpsi
-PLIST_SUB+= LIBDVBPSI="@comment "
+CONFIGURE_ARGS+=--enable-gtk
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's/-lc_r/${PTHREAD_LIBS}/' ${WRKSRC}/configure
+.if defined(WITH_ESOUND) && !defined(WITHOUT_ESOUND)
+USE_GNOME+= esound
+CONFIGURE_ARGS+=--enable-esd
+PLIST_FILES+= lib/vlc/audio_output/libesd_plugin.so
+.if defined(PKGNAMESUFFIX)
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-esound
+.else
+PKGNAMESUFFIX= -esound
+.endif
+.endif
-.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_LIBID3TAG)
+LIB_DEPENDS+= id3tag.2:${PORTSDIR}/audio/libid3tag
+PLIST_FILES+= lib/vlc/demux/libid3tag_plugin.so
+.endif
+
+.if defined(WITH_AALIB) && !defined(WITHOUT_AALIB)
+LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
+CONFIGURE+= --enable-aa
+.endif
+
+.if defined(WITH_CDDB) && !defined(WITHOUT_CDDB)
+LIB_DEPENDS+= cddb.1:${PORTSDIR}/audio/libcddb
+CONFIGURE_ARGS+=--enable-libcddb
+.else
+CONFIGURE_ARGS+=--disable-libcddb
+.endif
+
+.if defined(WITH_GGI) && !defined(WITHOUT_GCI)
+LIB_DEPENDS+= ggi.2:${PORTSDIR}/graphics/libggi
+CONFIGURE_ARGS+=--enable-ggi
+PLIST_FILES+= lib/vlc/video_output/libggi_plugin.so
+.endif
+
+.if defined(WITH_LIBDVBPSI) && !defined(WITHOUT_LIBDVBPSI)
+LIB_DEPENDS+= dvbpsi.3:${PORTSDIR}/multimedia/libdvbpsi
+CONFIGURE_ARGS+=--with-dvbpsi=${LOCALBASE}
+PLIST_FILES+= lib/vlc/demux/libts_dvbpsi_plugin.so \
+ lib/vlc/mux/libmux_ts_dvbpsi_plugin.so
+.else
+CONFIGURE_ARGS+=--disable-dvbpsi
+.endif
+
+.if defined(WITH_LIBMATROSKA) && !defined(WITHOUT_LIBMATROSKA)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libmatroska.a:${PORTSDIR}/multimedia/libmatroska
+PLIST_FILES+= lib/vlc/demux/libmkv_plugin.so
+.endif
+
+# After libmpeg2 release 0.3.2
+.if defined(WITH_LIBMPEG2) && !defined(WITHOUT_LIBMPEG2)
+LIB_DEPENDS+= mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
+CONFIGURE_ARGS+=--enable-libmpeg2
+.else
+CONFIGURE_ARGS+=--disable-libmpeg2
+.endif
+
+.if defined(WITH_LIBTHEORA) && !defined(WITHOUT_LIBTHEORA)
+LIB_DEPENDS+= theora.0:${PORTSDIR}/graphics/libtheora
+EXTRA_PATCHES+= ${PATCHDIR}/theora.c-patch
+CONFIGURE_ARGS+=--enable-theora
+PLIST_FILES+= lib/vlc/libtheora.a
+.endif
+
+.if defined(WITH_LIVEMEDIA) && !defined(WITHOUT_LIVEMEDIA)
+BUILD_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
+CONFIGURE_ARGS+=--enable-livedotcom \
+ --with-livedotcom-tree=${LOCALBASE}/live
+PLIST_FILES+= lib/vlc/liblivedotcom.a
+.endif
+
+.if defined(WITH_SPEEX) && !defined(WITHOUT_SPEEX)
+LIB_DEPENDS+= speex.2:${PORTSDIR}/audio/speex
+CONFIGURE_ARGS+=--enable-speex
+PLIST_FILES+= lib/vlc/codec/libspeex_plugin.so
+.endif
+
+.if defined(WITH_SVGALIB) && !defined(WITHOUT_SVGALIB)
+LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+CONFIGURE_ARGS+=--enable-svgalib
+PLIST_FILES+= lib/vlc/video_output/libsvgalib_plugin.so
+.endif
+
+.if defined(WITH_XOSD) && !defined(WITHOUT_XOSD)
+LIB_DEPENDS+= xosd.4:${PORTSDIR}/misc/xosd
+CONFIGURE_ARGS+=--enable-xosd
+.endif
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
+.else
+CONFIGURE_ARGS+=--disable-optimizations
+.endif
+
+.if defined(WITH_OPTIMIZED_CFLAGS) && (${ARCH} == "i386")
+CONFIGURE_ARGS+=--with-tuning=i686
+.endif
.if ${OSVERSION} < 500000
-CONFIGURE_ENV+= LIBS="-L/usr/lib -lcipher"
+CONFIGURE_ENV+= LIBS="-L/usr/lib -lcipher"
.endif
.if ${ARCH} == "i386"
-PLIST_SUB+= MMX=""
+PLIST_SUB+= MMX=""
.else
-PLIST_SUB+= MMX="@comment "
+PLIST_SUB+= MMX="@comment "
.endif
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Take a careful look into the Makefile in order"
+ @${ECHO_MSG} "to learn how to tune VLC towards you personal preferences!"
+ @${ECHO_MSG} "For example, make WITH_AUTODETECT=yes"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/-lc_r/${PTHREAD_LIBS}/' ${WRKSRC}/configure
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/vlc.1 ${MANPREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/doc/vlc-config.1 ${MANPREFIX}/man/man1/
+
.include <bsd.port.post.mk>
diff --git a/multimedia/vlc-devel/files/patch-modules-demux-mkv.cpp b/multimedia/vlc-devel/files/patch-modules-demux-mkv.cpp
new file mode 100644
index 000000000000..6b46a14a881e
--- /dev/null
+++ b/multimedia/vlc-devel/files/patch-modules-demux-mkv.cpp
@@ -0,0 +1,198 @@
+diff -Nur modules/demux/mkv.cpp.orig modules/demux/mkv.cpp
+--- modules/demux/mkv.cpp.orig 2003-12-22 15:27:37.000000000 +0100
++++ modules/demux/mkv.cpp 2004-01-21 17:02:42.000000000 +0100
+@@ -543,15 +543,15 @@
+ msg_Dbg( p_input, "| | | + Track Type=%s",
+ psz_type );
+ }
+- else if( EbmlId( *el3 ) == KaxTrackFlagEnabled::ClassInfos.GlobalId )
+- {
+- KaxTrackFlagEnabled &fenb = *(KaxTrackFlagEnabled*)el3;
+- fenb.ReadData( p_sys->es->I_O() );
+-
+- tk.b_enabled = uint32( fenb );
+- msg_Dbg( p_input, "| | | + Track Enabled=%u",
+- uint32( fenb ) );
+- }
++// else if( EbmlId( *el3 ) == KaxTrackFlagEnabled::ClassInfos.GlobalId )
++// {
++// KaxTrackFlagEnabled &fenb = *(KaxTrackFlagEnabled*)el3;
++// fenb.ReadData( p_sys->es->I_O() );
++
++// tk.b_enabled = uint32( fenb );
++// msg_Dbg( p_input, "| | | + Track Enabled=%u",
++// uint32( fenb ) );
++// }
+ else if( EbmlId( *el3 ) == KaxTrackFlagDefault::ClassInfos.GlobalId )
+ {
+ KaxTrackFlagDefault &fdef = *(KaxTrackFlagDefault*)el3;
+@@ -651,44 +651,44 @@
+ tk.psz_codec_name = UTF8ToStr( UTFstring( cname ) );
+ msg_Dbg( p_input, "| | | + Track Codec Name=%s", tk.psz_codec_name );
+ }
+- else if( EbmlId( *el3 ) == KaxCodecSettings::ClassInfos.GlobalId )
+- {
+- KaxCodecSettings &cset = *(KaxCodecSettings*)el3;
+- cset.ReadData( p_sys->es->I_O() );
+-
+- tk.psz_codec_settings = UTF8ToStr( UTFstring( cset ) );
+- msg_Dbg( p_input, "| | | + Track Codec Settings=%s", tk.psz_codec_settings );
+- }
+- else if( EbmlId( *el3 ) == KaxCodecInfoURL::ClassInfos.GlobalId )
+- {
+- KaxCodecInfoURL &ciurl = *(KaxCodecInfoURL*)el3;
+- ciurl.ReadData( p_sys->es->I_O() );
+-
+- tk.psz_codec_info_url = strdup( string( ciurl ).c_str() );
+- msg_Dbg( p_input, "| | | + Track Codec Info URL=%s", tk.psz_codec_info_url );
+- }
+- else if( EbmlId( *el3 ) == KaxCodecDownloadURL::ClassInfos.GlobalId )
+- {
+- KaxCodecDownloadURL &cdurl = *(KaxCodecDownloadURL*)el3;
+- cdurl.ReadData( p_sys->es->I_O() );
+-
+- tk.psz_codec_download_url = strdup( string( cdurl ).c_str() );
+- msg_Dbg( p_input, "| | | + Track Codec Info URL=%s", tk.psz_codec_download_url );
+- }
+- else if( EbmlId( *el3 ) == KaxCodecDecodeAll::ClassInfos.GlobalId )
+- {
+- KaxCodecDecodeAll &cdall = *(KaxCodecDecodeAll*)el3;
+- cdall.ReadData( p_sys->es->I_O() );
+-
+- msg_Dbg( p_input, "| | | + Track Codec Decode All=%u <== UNUSED", uint8( cdall ) );
+- }
+- else if( EbmlId( *el3 ) == KaxTrackOverlay::ClassInfos.GlobalId )
+- {
+- KaxTrackOverlay &tovr = *(KaxTrackOverlay*)el3;
+- tovr.ReadData( p_sys->es->I_O() );
++// else if( EbmlId( *el3 ) == KaxCodecSettings::ClassInfos.GlobalId )
++// {
++// KaxCodecSettings &cset = *(KaxCodecSettings*)el3;
++// cset.ReadData( p_sys->es->I_O() );
++
++// tk.psz_codec_settings = UTF8ToStr( UTFstring( cset ) );
++// msg_Dbg( p_input, "| | | + Track Codec Settings=%s", tk.psz_codec_settings );
++// }
++// else if( EbmlId( *el3 ) == KaxCodecInfoURL::ClassInfos.GlobalId )
++// {
++// KaxCodecInfoURL &ciurl = *(KaxCodecInfoURL*)el3;
++// ciurl.ReadData( p_sys->es->I_O() );
++
++// tk.psz_codec_info_url = strdup( string( ciurl ).c_str() );
++// msg_Dbg( p_input, "| | | + Track Codec Info URL=%s", tk.psz_codec_info_url );
++// }
++// else if( EbmlId( *el3 ) == KaxCodecDownloadURL::ClassInfos.GlobalId )
++// {
++// KaxCodecDownloadURL &cdurl = *(KaxCodecDownloadURL*)el3;
++// cdurl.ReadData( p_sys->es->I_O() );
++
++// tk.psz_codec_download_url = strdup( string( cdurl ).c_str() );
++// msg_Dbg( p_input, "| | | + Track Codec Info URL=%s", tk.psz_codec_download_url );
++// }
++// else if( EbmlId( *el3 ) == KaxCodecDecodeAll::ClassInfos.GlobalId )
++// {
++// KaxCodecDecodeAll &cdall = *(KaxCodecDecodeAll*)el3;
++// cdall.ReadData( p_sys->es->I_O() );
++
++// msg_Dbg( p_input, "| | | + Track Codec Decode All=%u <== UNUSED", uint8( cdall ) );
++// }
++// else if( EbmlId( *el3 ) == KaxTrackOverlay::ClassInfos.GlobalId )
++// {
++// KaxTrackOverlay &tovr = *(KaxTrackOverlay*)el3;
++// tovr.ReadData( p_sys->es->I_O() );
+
+- msg_Dbg( p_input, "| | | + Track Overlay=%u <== UNUSED", uint32( tovr ) );
+- }
++// msg_Dbg( p_input, "| | | + Track Overlay=%u <== UNUSED", uint32( tovr ) );
++// }
+ else if( EbmlId( *el3 ) == KaxTrackVideo::ClassInfos.GlobalId )
+ {
+ msg_Dbg( p_input, "| | | + Track Video" );
+@@ -698,21 +698,22 @@
+
+ while( ( el4 = p_sys->ep->Get() ) != NULL )
+ {
+- if( EbmlId( *el4 ) == KaxVideoFlagInterlaced::ClassInfos.GlobalId )
+- {
+- KaxVideoFlagInterlaced &fint = *(KaxVideoFlagInterlaced*)el4;
+- fint.ReadData( p_sys->es->I_O() );
+-
+- msg_Dbg( p_input, "| | | | + Track Video Interlaced=%u", uint8( fint ) );
+- }
+- else if( EbmlId( *el4 ) == KaxVideoStereoMode::ClassInfos.GlobalId )
+- {
+- KaxVideoStereoMode &stereo = *(KaxVideoStereoMode*)el4;
+- stereo.ReadData( p_sys->es->I_O() );
+-
+- msg_Dbg( p_input, "| | | | + Track Video Stereo Mode=%u", uint8( stereo ) );
+- }
+- else if( EbmlId( *el4 ) == KaxVideoPixelWidth::ClassInfos.GlobalId )
++// if( EbmlId( *el4 ) == KaxVideoFlagInterlaced::ClassInfos.GlobalId )
++// {
++// KaxVideoFlagInterlaced &fint = *(KaxVideoFlagInterlaced*)el4;
++// fint.ReadData( p_sys->es->I_O() );
++
++// msg_Dbg( p_input, "| | | | + Track Video Interlaced=%u", uint8( fint ) );
++// }
++// else if( EbmlId( *el4 ) == KaxVideoStereoMode::ClassInfos.GlobalId )
++// {
++// KaxVideoStereoMode &stereo = *(KaxVideoStereoMode*)el4;
++// stereo.ReadData( p_sys->es->I_O() );
++
++// msg_Dbg( p_input, "| | | | + Track Video Stereo Mode=%u", uint8( stereo ) );
++// }
++// else
++ if( EbmlId( *el4 ) == KaxVideoPixelWidth::ClassInfos.GlobalId )
+ {
+ KaxVideoPixelWidth &vwidth = *(KaxVideoPixelWidth*)el4;
+ vwidth.ReadData( p_sys->es->I_O() );
+@@ -752,28 +753,28 @@
+ tk.f_fps = float( vfps );
+ msg_Dbg( p_input, " | | | + fps=%f", float( vfps ) );
+ }
+- else if( EbmlId( *el4 ) == KaxVideoDisplayUnit::ClassInfos.GlobalId )
+- {
+- KaxVideoDisplayUnit &vdmode = *(KaxVideoDisplayUnit*)el4;
+- vdmode.ReadData( p_sys->es->I_O() );
++// else if( EbmlId( *el4 ) == KaxVideoDisplayUnit::ClassInfos.GlobalId )
++// {
++// KaxVideoDisplayUnit &vdmode = *(KaxVideoDisplayUnit*)el4;
++// vdmode.ReadData( p_sys->es->I_O() );
++
++// msg_Dbg( p_input, "| | | | + Track Video Display Unit=%s",
++// uint8( vdmode ) == 0 ? "pixels" : ( uint8( vdmode ) == 1 ? "centimeters": "inches" ) );
++// }
++// else if( EbmlId( *el4 ) == KaxVideoAspectRatio::ClassInfos.GlobalId )
++// {
++// KaxVideoAspectRatio &ratio = *(KaxVideoAspectRatio*)el4;
++// ratio.ReadData( p_sys->es->I_O() );
++
++// msg_Dbg( p_input, " | | | + Track Video Aspect Ratio Type=%u", uint8( ratio ) );
++// }
++// else if( EbmlId( *el4 ) == KaxVideoGamma::ClassInfos.GlobalId )
++// {
++// KaxVideoGamma &gamma = *(KaxVideoGamma*)el4;
++// gamma.ReadData( p_sys->es->I_O() );
+
+- msg_Dbg( p_input, "| | | | + Track Video Display Unit=%s",
+- uint8( vdmode ) == 0 ? "pixels" : ( uint8( vdmode ) == 1 ? "centimeters": "inches" ) );
+- }
+- else if( EbmlId( *el4 ) == KaxVideoAspectRatio::ClassInfos.GlobalId )
+- {
+- KaxVideoAspectRatio &ratio = *(KaxVideoAspectRatio*)el4;
+- ratio.ReadData( p_sys->es->I_O() );
+-
+- msg_Dbg( p_input, " | | | + Track Video Aspect Ratio Type=%u", uint8( ratio ) );
+- }
+- else if( EbmlId( *el4 ) == KaxVideoGamma::ClassInfos.GlobalId )
+- {
+- KaxVideoGamma &gamma = *(KaxVideoGamma*)el4;
+- gamma.ReadData( p_sys->es->I_O() );
+-
+- msg_Dbg( p_input, " | | | + fps=%f", float( gamma ) );
+- }
++// msg_Dbg( p_input, " | | | + fps=%f", float( gamma ) );
++// }
+ else
+ {
+ msg_Dbg( p_input, "| | | | + Unknown (%s)", typeid(*el4).name() );
diff --git a/multimedia/vlc-devel/files/theora.c-patch b/multimedia/vlc-devel/files/theora.c-patch
new file mode 100644
index 000000000000..35919e1f7e92
--- /dev/null
+++ b/multimedia/vlc-devel/files/theora.c-patch
@@ -0,0 +1,11 @@
+--- modules/codec/theora.c.orig Sun Feb 29 22:28:09 2004
++++ modules/codec/theora.c Sun Feb 29 22:28:23 2004
+@@ -31,7 +31,7 @@
+ #include <ogg/ogg.h>
+
+ #include <theora/theora.h>
+-
++extern int theora_encode_tables(theora_state *t, ogg_packet *op);
+ /*****************************************************************************
+ * decoder_sys_t : theora decoder descriptor
+ *****************************************************************************/
diff --git a/multimedia/vlc-devel/pkg-plist b/multimedia/vlc-devel/pkg-plist
index ed8768fc9539..22f8d3f9cfd1 100644
--- a/multimedia/vlc-devel/pkg-plist
+++ b/multimedia/vlc-devel/pkg-plist
@@ -79,7 +79,6 @@ lib/vlc/demux/libdemuxdump_plugin.so
lib/vlc/demux/libdemuxsub_plugin.so
lib/vlc/demux/libdtssys_plugin.so
lib/vlc/demux/libid3_plugin.so
-lib/vlc/demux/libid3tag_plugin.so
lib/vlc/demux/libm3u_plugin.so
lib/vlc/demux/libm4v_plugin.so
lib/vlc/demux/libmp4_plugin.so
@@ -89,7 +88,6 @@ lib/vlc/demux/libmpgv_plugin.so
lib/vlc/demux/libogg_plugin.so
lib/vlc/demux/libps_plugin.so
lib/vlc/demux/librawdv_plugin.so
-%%LIBDVBPSI%%lib/vlc/demux/libts_dvbpsi_plugin.so
lib/vlc/demux/libts_plugin.so
lib/vlc/demux/libwav_plugin.so
lib/vlc/gui/libgtk_plugin.so
@@ -119,7 +117,6 @@ lib/vlc/mux/libmux_dummy_plugin.so
lib/vlc/mux/libmux_mp4_plugin.so
lib/vlc/mux/libmux_ogg_plugin.so
lib/vlc/mux/libmux_ps_plugin.so
-%%LIBDVBPSI%%lib/vlc/mux/libmux_ts_dvbpsi_plugin.so
lib/vlc/mux/libmux_ts_plugin.so
lib/vlc/packetizer/libpacketizer_copy_plugin.so
lib/vlc/packetizer/libpacketizer_mpeg4audio_plugin.so