aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/vlc
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2012-09-02 02:15:25 +0800
committernox <nox@FreeBSD.org>2012-09-02 02:15:25 +0800
commitc226730cfe03057464d68dde3a5097f8d805b4ed (patch)
tree66ac289f77c5afb7a1e19399503c819b05890064 /multimedia/vlc
parent6ca5353440c9800d8427dacd223d693f66254b4a (diff)
downloadfreebsd-ports-gnome-c226730cfe03057464d68dde3a5097f8d805b4ed.tar.gz
freebsd-ports-gnome-c226730cfe03057464d68dde3a5097f8d805b4ed.tar.zst
freebsd-ports-gnome-c226730cfe03057464d68dde3a5097f8d805b4ed.zip
- (Attempt) to fix build on i386.
- Fix plist. - Bump PORTREVISION. Submitted by: QAT
Diffstat (limited to 'multimedia/vlc')
-rw-r--r--multimedia/vlc/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 9416d49804e4..735dd5af4ef1 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vlc
DISTVERSION= 2.0.3
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/p/-pre/}/ \
@@ -193,6 +194,10 @@ IGNORE= base clang version too old, set NO_IGNORE to override
CONFIGURE_ARGS+=--enable-altivec # VLC's config script doesn't know to do this
.endif
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+=--disable-sse # sometimes(?) misdetected causing build failure
+.endif
+
# End OS specific hacks
# User tunables
@@ -765,7 +770,7 @@ pre-install:
cd ${FAKEDIR}/share/locale && ${FIND} -s * -type f -o -type l | \
${SED} -e 's|^|share/locale/|' >> ${PLIST}
.endif
-.for locale in ach cgg ckb co ff fur kk km lg my oc ps tet tl zu kmr
+.for locale in ach cgg ckb co ff fur gd kk km lg my oc ps tet tl zu kmr
${ECHO_CMD} "@dirrmtry share/locale/${locale}/LC_MESSAGES" >> ${PLIST}
${ECHO_CMD} "@dirrmtry share/locale/${locale}" >> ${PLIST}
.endfor