aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/win32-codecs
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-01-07 22:36:04 +0800
committerlioux <lioux@FreeBSD.org>2001-01-07 22:36:04 +0800
commitcde62bf8127bc5dc6768d9639625bea1b9a08829 (patch)
tree938e4e63aa9e0fc900a0803655008e5335c10095 /multimedia/win32-codecs
parent7d2a2d5c945500a8eb651008cb74e115aafa2275 (diff)
downloadfreebsd-ports-gnome-cde62bf8127bc5dc6768d9639625bea1b9a08829.tar.gz
freebsd-ports-gnome-cde62bf8127bc5dc6768d9639625bea1b9a08829.tar.zst
freebsd-ports-gnome-cde62bf8127bc5dc6768d9639625bea1b9a08829.zip
1) Add audio/lame as a LIB_DEPENDS
2) Have this port use the port's system shared version of the lame library instead of building its own static version. Add both some detection code and necessary hooks to avifile's configure system (defensive programming) using some patches 3) Add a simple stale port's tree defensive check. After the library dependency phase, if one gets a lame library but no shared library ... bogus. The avifile depending on the new version of lame port was added after the aforementioned. Warn the user about it. A side effect (of LIB_DEPENDS) is that the new lame dependency is always built even if there is an old version of lame installed. 4) PORTREVISION bump Approved by: maintainer
Diffstat (limited to 'multimedia/win32-codecs')
-rw-r--r--multimedia/win32-codecs/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/multimedia/win32-codecs/Makefile b/multimedia/win32-codecs/Makefile
index 2140e940e232..d4d2eff103e4 100644
--- a/multimedia/win32-codecs/Makefile
+++ b/multimedia/win32-codecs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= avifile
PORTVERSION= 0.53.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://ernie.eit.uni-kl.de/avifile/ \
http://divx.euro.ru/ \
@@ -18,7 +19,8 @@ EXTRACT_ONLY= avifile-${PORTVERSION}.tar.gz
MAINTAINER= holger@eit.uni-kl.de
-LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel
+LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel \
+ mp3lame.1:${PORTSDIR}/audio/lame
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
WRKSRC= ${WRKDIR}/${PORTNAME}-0.53
@@ -41,6 +43,7 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-win32-path=${LOCALBASE}/lib/win32 \
+ --with-mp3-lame \
--enable-release
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
@@ -58,6 +61,18 @@ DIFF?= /usr/bin/diff
.include <bsd.port.pre.mk>
+.if make(lib-depends)
+.if !exists(${LOCALBASE}/lib/libmp3lame.so) && exists(${LOCALBASE}/bin/lame)
+lib-depends:
+ @${ECHO_MSG} ====>
+ @${ECHO_MSG} ====> Error: You have an old version of lame installed.
+ @${ECHO_MSG} ====> You need at least port version 3.70_1!
+ @${ECHO_MSG} ====> Please deinstall lame first, then build avifile.
+ @${ECHO_MSG} ====>
+ @${FALSE}
+.endif
+.endif
+
post-extract:
@${LOCALBASE}/bin/unzip ${DISTDIR}/binaries-${CODEC_VERSION}.zip \
-d ${WRKDIR}/codecs