aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/x264
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-04-21 20:52:56 +0800
committermm <mm@FreeBSD.org>2010-04-21 20:52:56 +0800
commit0248e8afc95e8ac5998744e131a4b88363b050bd (patch)
treea5693d0b1358b3a28d1808af6c36f27780dd01aa /multimedia/x264
parent24a226f306882b19f9400323a0764381b8caee65 (diff)
downloadfreebsd-ports-gnome-0248e8afc95e8ac5998744e131a4b88363b050bd.tar.gz
freebsd-ports-gnome-0248e8afc95e8ac5998744e131a4b88363b050bd.tar.zst
freebsd-ports-gnome-0248e8afc95e8ac5998744e131a4b88363b050bd.zip
- Update to snapshot 20100222 (library version 85)
Diffstat (limited to 'multimedia/x264')
-rw-r--r--multimedia/x264/Makefile24
-rw-r--r--multimedia/x264/distinfo6
-rw-r--r--multimedia/x264/files/patch-Makefile14
-rw-r--r--multimedia/x264/files/patch-common-common.h8
-rw-r--r--multimedia/x264/pkg-plist2
5 files changed, 28 insertions, 26 deletions
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index 76dfbd48ddc4..7df91d891ae2 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -3,11 +3,9 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $Id: Makefile 30 2006-10-30 22:15:26Z buhnux $
PORTNAME= x264
-PORTVERSION= 0.0.20090119
-PORTREVISION= 2
+PORTVERSION= 0.0.20100222
CATEGORIES= multimedia
MASTER_SITES= http://downloads.videolan.org/pub/videolan/x264/snapshots/ \
http://samples.mplayerhq.hu/yuv4mpeg2/:pgo
@@ -19,9 +17,8 @@ EXTRACT_ONLY= ${PORTNAME}-snapshot-${PORTVERSION:S/0.0.//}-2245${EXTRACT_SUFX}
MAINTAINER= mm@FreeBSD.org
COMMENT?= Library and tool for encoding H.264/AVC video streams
-CONFLICTS= x264-2010*
-
-BUILD_DEPENDS= yasm>=0.6.0:${PORTSDIR}/devel/yasm
+BUILD_DEPENDS= yasm>=0.6.0:${PORTSDIR}/devel/yasm \
+ as:${PORTSDIR}/devel/binutils
USE_BZIP2= yes
EXTRACT_AFTER_ARGS?= | ${TAR} -xf - --exclude .svn
@@ -33,6 +30,7 @@ MAKE_JOBS_SAFE= yes
OPTIONS= DEBUG "Enable Debugging" Off \
PGO "Enable Profile-Guided Optimization" Off \
+ GCC44 "Use gcc 4.4+" Off \
GPAC "Enable MPEG-4 Output" On \
X11_OUTPUT "Enable X11 Output" Off
@@ -40,8 +38,15 @@ CONFIGURE_ARGS+= --extra-cflags="${CPPFLAGS} ${CFLAGS} -fPIC -I${LOCALBASE}/incl
--extra-ldflags="${LDFLAGS} -L${LOCALBASE}/lib -L${LOCALBASE}/lib" \
--enable-shared
+CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
+MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
+
.include <bsd.port.pre.mk>
+.if defined(WITH_GCC44)
+USE_GCC?= 4.4+
+.endif
+
# Around the time GCC stack protection (aka Propolice) for userland
# was enabled on src/share/mk/bsd.sys.mk
# SVN rev 180012 on 2008-06-25 21:33:28Z by ru
@@ -75,7 +80,7 @@ RESTRICTED_FILES= ${Y4M_VIDEO_DISTFILE}
.endif
.if !defined(WITHOUT_GPAC)
-BUILD_DEPENDS+= gpac-libgpac>=0.4.2.r2,1:${PORTSDIR}/multimedia/gpac-libgpac
+BUILD_DEPENDS+= gpac-libgpac>=0.4.5,1:${PORTSDIR}/multimedia/gpac-libgpac
LIB_DEPENDS+= gpac.1:${PORTSDIR}/multimedia/gpac-libgpac
CONFIGURE_ARGS+= --enable-mp4-output
.else
@@ -102,6 +107,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|; \
s|$${libdir}/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/Makefile
+.if !defined(WITH_GCC44)
+ @${REINPLACE_CMD} -e 's|$$(CC) -shared -o|COMPILER_PATH= $$(CC) -shared -o|g' \
+ -e 's|$$(CC) -o|COMPILER_PATH= $$(CC) -o|g' \
+ ${WRKSRC}/Makefile
+.endif
.if ${SLAVE_PORT:L}=="no"
.if 0 # BROKEN
diff --git a/multimedia/x264/distinfo b/multimedia/x264/distinfo
index 549f1dab1fc1..5f2428bd15e8 100644
--- a/multimedia/x264/distinfo
+++ b/multimedia/x264/distinfo
@@ -1,6 +1,6 @@
-MD5 (x264/x264-snapshot-20090119-2245.tar.bz2) = 31c6b9aea1aef45003f69880a250609a
-SHA256 (x264/x264-snapshot-20090119-2245.tar.bz2) = db5932675a52dba439b2611c2d4fc96f5a71d1ed2a3b35bac1659aa4928e5ef2
-SIZE (x264/x264-snapshot-20090119-2245.tar.bz2) = 2381449
+MD5 (x264/x264-snapshot-20100222-2245.tar.bz2) = a68827d2e47920ee3ae655f8b8c51013
+SHA256 (x264/x264-snapshot-20100222-2245.tar.bz2) = 6f197d825315f077fabaf6340c324462cdceaf0417500dadea3511b1ad26ac2f
+SIZE (x264/x264-snapshot-20100222-2245.tar.bz2) = 400392
MD5 (x264/example.y4m.bz2) = e0948016cd4a52e75d6a74d998bd6ae6
SHA256 (x264/example.y4m.bz2) = a5bec9d37362bd9d7773fbd0644643f9ec096d654d20823004e88d5df32bbff7
SIZE (x264/example.y4m.bz2) = 4910029
diff --git a/multimedia/x264/files/patch-Makefile b/multimedia/x264/files/patch-Makefile
index 9be78fa7c198..5c743b2b520e 100644
--- a/multimedia/x264/files/patch-Makefile
+++ b/multimedia/x264/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2008-12-18 13:45:07.000000000 -0800
-+++ Makefile 2010-02-27 15:21:32.000000000 -0800
-@@ -26,12 +26,12 @@
+--- Makefile.orig 2010-02-22 22:45:05.000000000 +0100
++++ Makefile 2010-04-18 10:43:06.325179277 +0200
+@@ -53,12 +53,12 @@
cpu-a.asm dct-32.asm
X86SRC = $(X86SRC0:%=common/x86/%)
@@ -15,12 +15,12 @@
ARCH_X86 = yes
ASMSRC = $(X86SRC:-32.asm=-64.asm)
ASFLAGS += -DARCH_X86_64
-@@ -47,7 +47,7 @@
+@@ -74,7 +74,7 @@
endif
# AltiVec optims
-ifeq ($(ARCH),PPC)
+ifeq ($(ARCH),powerpc)
- ALTIVECSRC += common/ppc/mc.c common/ppc/pixel.c common/ppc/dct.c \
- common/ppc/quant.c common/ppc/deblock.c \
- common/ppc/predict.c
+ SRCS += common/ppc/mc.c common/ppc/pixel.c common/ppc/dct.c \
+ common/ppc/quant.c common/ppc/deblock.c \
+ common/ppc/predict.c
diff --git a/multimedia/x264/files/patch-common-common.h b/multimedia/x264/files/patch-common-common.h
deleted file mode 100644
index 14ee0523b5be..000000000000
--- a/multimedia/x264/files/patch-common-common.h
+++ /dev/null
@@ -1,8 +0,0 @@
---- common/common.h.orig 2010-02-03 17:25:48.378388768 +0100
-+++ common/common.h 2010-02-03 17:26:24.401327942 +0100
-@@ -634,3 +634,5 @@
-
- #endif
-
-+#define M_LOG2_E 0.693147180559945309417
-+#define log2f(x) (logf (x) / (float) M_LOG2_E)
diff --git a/multimedia/x264/pkg-plist b/multimedia/x264/pkg-plist
index 812fa439d06c..0a24c478cdf9 100644
--- a/multimedia/x264/pkg-plist
+++ b/multimedia/x264/pkg-plist
@@ -2,5 +2,5 @@ bin/x264
include/x264.h
lib/libx264.a
lib/libx264.so
-lib/libx264.so.65
+lib/libx264.so.85
libdata/pkgconfig/x264.pc
* Update to the 20120428 snapshot of GCC 4.7.1.gerald2012-05-012-3/+3 * - Mark BROKEN: size mismatchpav2012-05-011-0/+2 * Update to 5.3.11 release.ale2012-04-304-44/+10 * - Fix distfile checksumtabthorpe2012-04-281-2/+2 * - Update to 4.192tabthorpe2012-04-273-4/+4 * FreeBSD 8.x and above have added -r that does exactly same as -E for increasedmezz2012-04-271-0/+17 * - Update to 0.16wen2012-04-253-6/+41 * Upgrade to 3.10.4.vanilla2012-04-252-3/+3 * - Update to 20120301 (corresponding to gcc 4.6.3)culot2012-04-249-229/+97 * Remove @dirrmtry commands for directories not created anymorejohans2012-04-241-4/+0 * - Update to 20120301 (corresponding to gcc 4.6.3)culot2012-04-239-232/+100 * update to 1.0.56 and adjust dependent ports; switch to the packagedbf2012-04-2311-239/+80 * Update to the 20120420 snapshot of GCC 4.6.4.gerald2012-04-222-3/+3 * - Update to 4.4.7-2375jgh2012-04-2116-414/+90 * Update to version 1.70.00pawel2012-04-192-3/+4 * - Use USE_XORG instead of USE_XLIBacm2012-04-191-1/+1 * - Bump PORTREVISION (freepascal ports were updated)acm2012-04-191-1/+1 * - Update to 2.6.0acm2012-04-1912-220/+196 * mark MAKE_JOBS_UNSAFEbf2012-04-191-0/+2 * - Mark BROKEN: does not build (broken by recent texinfo update)pav2012-04-191-0/+2 * Actually commit the racket-textual Makefile...olgeni2012-04-171-23/+16 * - Fix building on 10-CURRENT i386ashish2012-04-171-0/+12 * Fix portlint warning (IGNORE message should start from lower-case letter)rm2012-04-171-1/+1 * Remove this slave ports without deprecation period, because they actuallyrm2012-04-173-24/+0 * Update to 1.25.tobez2012-04-173-6/+6 * Cleanup python < 2.6 logic, because there is no documentation for thisrm2012-04-171-5/+1 * Cleanup special check for python 2.6.0rm2012-04-171-4/+0 * Cleanup distinfo entries for python versions we have not in the tree.rm2012-04-171-252/+0 * Document conflict with lang/racket-textual.olgeni2012-04-171-0/+2 * Add the actual racket-textual port after repocopy. It provides aolgeni2012-04-174-15701/+7 * * Disable support for WITHOUT_X11; a separate text-only versionolgeni2012-04-171-19/+23 * Fix runtime error (unable to find libphobos2).cy2012-04-162-0/+9 * Update to 0.9.2.1635.mezz2012-04-162-3/+3 * - Fix copy/paste errorsunpoet2012-04-161-1/+1 * Update to the 20120415 snapshot of GCC 4.8.0.gerald2012-04-162-3/+3 * Update to the 20120414 snapshot of GCC 4.7.1.gerald2012-04-162-3/+3 * - add docs for python 2.6.8, 3.1.5, 3.2.3rm2012-04-161-0/+24 * Update 2.058 --> 2.059cy2012-04-153-8/+6 * Update 1.073 --> 1.074cy2012-04-154-9/+10 * Remove pkg-plist diffs for some ancient python versions that we have notrm2012-04-1510-7279/+1 * - add docs for python 2.7.3rm2012-04-151-0/+8 * Update to the 20120413 snapshot of GCC 4.6.4.gerald2012-04-152-3/+3 * Set the expiration date for all ports which depend upon linux_base-fc4 tonetchild2012-04-151-0/+2 * - Update to 3.0.0 [1]scheidell2012-04-143-242/+395 * Remove useless file.mezz2012-04-141-0/+0 * Opa is an open source, simple and unified platform for writing webmezz2012-04-149-0/+6733 * Update to LLVM and Clang 3.1.r154687, unless specific issues are foundbrooks2012-04-142-22/+25 * Clarify effect of __MAKE_CONF change, and point to Wiki URL (in a comment).mandree2012-04-141-0/+3 * Remove CFLAGS=${CFLAGS} regression from MAKE_ARGS again (leftover frommandree2012-04-131-2/+2 * - Remove TEST_DEPENDS on itselfswills2012-04-121-2/+0 * - Note CONFLICT between net/mosh and lang/mosh, as they both install bin/moshzi2012-04-121-0/+3 * php4 is EOLed, let's deprecate itbapt2012-04-122-0/+6 * Forced commit to mention that ohauer@ has joined lua@.mandree2012-04-121-1/+1 * Add explanatory comment about butchering __MAKE_CONF.mandree2012-04-121-0/+3 * Support builds that set CFLAGS=... in /etc/make.conf (discouraged).mandree2012-04-121-2/+2 * - Update:miwi2012-04-1121-206/+31 * Fix regressions, reinstating io.popen support.mandree2012-04-111-2/+2 * - pass maintainership of this ports to new volunteerrm2012-04-111-1/+1 * Mark as deprecated and set expiration to 2012-05-10 for ports that are mark a...bapt2012-04-101-0/+3 * Remove EXPIRATION_DATE, Mk/bsd.gnustep.mk still relies on this port.gerald2012-04-101-1/+0 * Update to the 20120408 snapshot of GCC 4.8.0.gerald2012-04-092-3/+3 * - Fix suggested by upstream. Revise mutex initializer patch to avoid deadlocksscheidell2012-04-094-24/+44 * - Update to 20120301 (corresponding to gcc 4.6.3)culot2012-04-095-53/+95 * Update to the 20120407 snapshot of GCC 4.7.1.gerald2012-04-082-3/+3 * - Update to 0.2scheidell2012-04-0810-136/+46 * Update to the 20120406 snapshot of GCC 4.6.4.gerald2012-04-072-3/+3 * Bring in additional changes by ohauer to preserve LUA_LDIR/LUA_CDIR.mandree2012-04-072-2/+3 * Update to bug-fix release 5.1.5.mandree2012-04-074-15/+9 * Add New Port lang/urweb: Ur is a programming language in the tradition of ML ...scheidell2012-04-069-0/+196 * Update to the 20120330 snapshot of GCC 4.6.4.gerald2012-04-042-3/+3 * Update to the 20120401 snapshot of GCC 4.8.0.gerald2012-04-042-3/+3 * Update to the 20120324 snapshot of GCC 4.7.1.gerald2012-04-042-3/+3 * - Update to 1.008000sunpoet2012-04-02