aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/x264
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /multimedia/x264
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'multimedia/x264')
-rw-r--r--multimedia/x264/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index e54a6fa64b7c..a5a297430f4e 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -40,7 +40,7 @@ HAS_CONFIGURE= yes
OPTIONS_DEFINE= ASM DEBUG PGO GCC44 GPAC X11_OUTPUT
OPTIONS_DEFAULT= ASM PGO GPAC
ASM_DESC= Assembly optimizations (devel/binutils)
-GCC44_DESC= Use gcc 4.4+ (implies WITH_ASM)
+GCC44_DESC= Use current GCC (implies WITH_ASM)
GPAC_DESC= Enable MPEG-4 Output
X11_OUTPUT_DESC= Enable X11 Output
@@ -53,7 +53,7 @@ PLIST_SUB+= X264_BUILD=${X264_BUILD}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGCC44}
-USE_GCC?= 4.4+
+USE_GCC?= yes
.endif
.include <bsd.port.pre.mk>