aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/x265/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-09-02 23:06:20 +0800
committeradamw <adamw@FreeBSD.org>2014-09-02 23:06:20 +0800
commit1c284fb0b4875ac41ce6981ded732e0d49114a34 (patch)
treec5f75344f7ea8b88354846c185685fcbca0655ea /multimedia/x265/Makefile
parentdab80b2905c14f5d8eec4d771b804d49915e51f7 (diff)
downloadfreebsd-ports-gnome-1c284fb0b4875ac41ce6981ded732e0d49114a34.tar.gz
freebsd-ports-gnome-1c284fb0b4875ac41ce6981ded732e0d49114a34.tar.zst
freebsd-ports-gnome-1c284fb0b4875ac41ce6981ded732e0d49114a34.zip
Add multimedia/x265, the H.265/High Efficiency Video Coding (HEVC) codec.
High Efficiency Video Coding (HEVC) is the latest generation video compression standard. * This standard was developed by the ISO/IEC Moving Picture Experts Group (MPEG) and ITU-T Video Coding Experts Group (VCEG), through their Joint Collaborative Team on Video Coding (JCT-VC) * HEVC is also known as ISO/IEC 23008-2 MPEG-H Part 2 and ITU-T H.265 * HEVC provides superior video quality and up to twice the data compression as the previous standard (H.264/MPEG-4 AVC) * HEVC can support 8K Ultra High Definition video, with a picture size up to 8192x4320 pixels WWW: http://www.x265.org
Diffstat (limited to 'multimedia/x265/Makefile')
-rw-r--r--multimedia/x265/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/multimedia/x265/Makefile b/multimedia/x265/Makefile
new file mode 100644
index 000000000000..e25279748bf0
--- /dev/null
+++ b/multimedia/x265/Makefile
@@ -0,0 +1,28 @@
+# Created by: adamw
+# $FreeBSD$
+
+PORTNAME= x265
+PORTVERSION= 1.3
+CATEGORIES= multimedia
+MASTER_SITES= http://bitbucket.org/multicoreware/${PORTNAME}/get/
+DISTNAME= ${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= H.265/High Efficiency Video Coding (HEVC) format
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
+
+USES= tar:bz2 cmake
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/multicoreware-${PORTNAME}-c1e4fc0162c1/source
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${LIB_INSTALL_DIR}/pkgconfig|libdata/pkgconfig|' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>