aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/xfce4-xmms-plugin/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2007-01-23 00:45:10 +0800
committeroliver <oliver@FreeBSD.org>2007-01-23 00:45:10 +0800
commitece43d49726e1fe13a95dc4f28353faf36dce1d0 (patch)
tree555dc2b1a093e9c80e4daa22b395dfe53aa9b178 /multimedia/xfce4-xmms-plugin/Makefile
parentfd57b294b88da34811c61d674eb0b28a716d2d4f (diff)
downloadfreebsd-ports-gnome-ece43d49726e1fe13a95dc4f28353faf36dce1d0.tar.gz
freebsd-ports-gnome-ece43d49726e1fe13a95dc4f28353faf36dce1d0.tar.zst
freebsd-ports-gnome-ece43d49726e1fe13a95dc4f28353faf36dce1d0.zip
Import xfce 4.4
- remove all obsolete ports or plugins - update all plugins to their latest version to support xfce 4.4 (otherwise they won't compile with 4.4)
Diffstat (limited to 'multimedia/xfce4-xmms-plugin/Makefile')
-rw-r--r--multimedia/xfce4-xmms-plugin/Makefile45
1 files changed, 25 insertions, 20 deletions
diff --git a/multimedia/xfce4-xmms-plugin/Makefile b/multimedia/xfce4-xmms-plugin/Makefile
index b4b29f178815..95a3843109b0 100644
--- a/multimedia/xfce4-xmms-plugin/Makefile
+++ b/multimedia/xfce4-xmms-plugin/Makefile
@@ -6,31 +6,36 @@
#
PORTNAME= xfce4-xmms-plugin
-PORTVERSION= 0.3.1
-PORTREVISION= 1
+PORTVERSION= 0.4.2
CATEGORIES= multimedia audio xfce
-MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
- http://download2.berlios.de/xfce-goodies/
+MASTER_SITES= http://goodies.xfce.org/releases/${PORTNAME}/
DIST_SUBDIR= xfce4
MAINTAINER= jfb@minet.net
COMMENT= XFce 4 xmms control plugin for xfce4-panel
-BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel \
- xmms-config:${PORTSDIR}/multimedia/xmms
-LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
- xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
- startup-notification-1.0:${PORTSDIR}/x11/startup-notification
-RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel \
- xmms:${PORTSDIR}/multimedia/xmms
-
-USE_BZIP2= yes
-USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
- CPPFLAGS=-I${LOCALBASE}/include \
- LIBS=-L${LOCALBASE}/lib
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget gtk20 intltool intlhack pango pkgconfig
+USE_XFCE= configenv libgui libutil panel
+USE_XLIB= yes
+
+OPTIONS= BEEP "Use Beep media player instead of xmms" off
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
+
+.if defined(WITH_BEEP)
+LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player
+CONFIGURE_ARGS+=--with-player=beep
+.else
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+CONFIGURE_ARGS+=--with-player=xmms
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|== x|= x|g' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>