aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/xmms
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>2000-02-11 09:26:05 +0800
committercpiazza <cpiazza@FreeBSD.org>2000-02-11 09:26:05 +0800
commitf598a70dd0b13b91ebc12eada32fa99905f0259e (patch)
tree850a52e4ab53652c33de6ded8f8fb5c7b5e25e68 /multimedia/xmms
parent289e23c31b4623ea14c2d3a78ca10497ad28035f (diff)
downloadfreebsd-ports-gnome-f598a70dd0b13b91ebc12eada32fa99905f0259e.tar.gz
freebsd-ports-gnome-f598a70dd0b13b91ebc12eada32fa99905f0259e.tar.zst
freebsd-ports-gnome-f598a70dd0b13b91ebc12eada32fa99905f0259e.zip
Fix this port on 3.x.
Side note: this is really gross. Can someone explain to me why this won't work if the assembler files are named blah.s instead of blah.S? PR: 16637
Diffstat (limited to 'multimedia/xmms')
-rw-r--r--multimedia/xmms/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/multimedia/xmms/Makefile b/multimedia/xmms/Makefile
index 15792aaed6a1..04dd59718a7a 100644
--- a/multimedia/xmms/Makefile
+++ b/multimedia/xmms/Makefile
@@ -31,6 +31,14 @@ GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
GLIB_CONFIG="${GLIB_CONFIG}"
+post-extract:
+ @(cd ${WRKSRC}/Input/mpg123 && ${MV} decode_i586.s decode_i586.S && \
+ ${MV} getbits.s getbits.S && cd ${WRKSRC}/Visualization/blur_scope && \
+ ${MV} blur_8.s blur_8.S);
+ @${PERL} -pi.bak -e 's:\.s :\.S :g' ${WRKSRC}/Input/mpg123/Makefile.in
+ @${PERL} -pi.bak -e 's:blur_8.s:blur_8.S:g' \
+ ${WRKSRC}/Visualization/blur_scope/Makefile.in
+
post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib