aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2013-11-15 20:51:10 +0800
committermartymac <martymac@FreeBSD.org>2013-11-15 20:51:10 +0800
commit07d27b334bc9f31bb8ab6177b89a29772e6c7e5c (patch)
tree8577f656bbf5615d63907231ce892df3f8b56133 /multimedia
parente24c30a42b1deec7467c3d05c5820c864d41f23f (diff)
downloadfreebsd-ports-gnome-07d27b334bc9f31bb8ab6177b89a29772e6c7e5c.tar.gz
freebsd-ports-gnome-07d27b334bc9f31bb8ab6177b89a29772e6c7e5c.tar.zst
freebsd-ports-gnome-07d27b334bc9f31bb8ab6177b89a29772e6c7e5c.zip
- Enable staging
- Replace USE_GMAKE with proper USES value - Switch to new LIB_DEPENDS format - Switch to new options format
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libdvdread/Makefile20
1 files changed, 5 insertions, 15 deletions
diff --git a/multimedia/libdvdread/Makefile b/multimedia/libdvdread/Makefile
index 86a2e08d02b9..5bdd7ff053a1 100644
--- a/multimedia/libdvdread/Makefile
+++ b/multimedia/libdvdread/Makefile
@@ -25,34 +25,24 @@ CONFIGURE_ARGS= --prefix="${PREFIX}" \
--incdir="${PREFIX}/include/dvdread" \
--disable-opts \
--cc="${CC}"
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
OPTIONS_DEFINE= DVDCSS DEBUG
.if !defined(PACKAGE_BUILDING)
OPTIONS_DEFAULT= DVDCSS
.endif
+DEBUG_CONFIGURE_ON= --enable-debug --disable-strip
+DEBUG_CONFIGURE_OFF= --disable-debug --enable-strip
+DVDCSS_LIB_DEPENDS= libdvdcss.so:${PORTSDIR}/multimedia/libdvdcss
# DVDCSS version hardcoded in src/dvd_input.c (dlopen'ed)
DVDCSS_LIBVERSION= 3
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MDVDCSS}
-LIB_DEPENDS+= dvdcss:${PORTSDIR}/multimedia/libdvdcss
-.endif
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug --disable-strip
-.else
-CONFIGURE_ARGS+= --disable-debug
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldl ||g' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -E -e 's|(libdvdcss.so)\.2|\1.${DVDCSS_LIBVERSION}|' \
${WRKSRC}/src/dvd_input.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>