aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-07-18 02:34:49 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-07-18 02:34:49 +0800
commit0bf82aaccd385b6d7135d142efb57118cd8a52f8 (patch)
treef264eaece52afce133cc22c61ced85526718bdf2 /multimedia
parente472553bcbed059f1eb18f650fdb60f0f4eb6cd4 (diff)
downloadfreebsd-ports-gnome-0bf82aaccd385b6d7135d142efb57118cd8a52f8.tar.gz
freebsd-ports-gnome-0bf82aaccd385b6d7135d142efb57118cd8a52f8.tar.zst
freebsd-ports-gnome-0bf82aaccd385b6d7135d142efb57118cd8a52f8.zip
- Playing FLV videos, e.g. from youtube, results in mplayer segfaulting when the video is finished.
PR: ports/135719 Submitted by: Dennis Schneider <dschneid@informatik.hu-berlin.de> Approved by: maintainer
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/files/patch-libmpcodecs__vd_ffmpeg.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 600e818194ea..8c47ebdc3987 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 13
+PORTREVISION= 14
COMMENT= High performance media player supporting many formats
diff --git a/multimedia/mplayer/files/patch-libmpcodecs__vd_ffmpeg.c b/multimedia/mplayer/files/patch-libmpcodecs__vd_ffmpeg.c
new file mode 100644
index 000000000000..ef5d3f1129f7
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libmpcodecs__vd_ffmpeg.c
@@ -0,0 +1,11 @@
+--- ./libmpcodecs/vd_ffmpeg.c.orig 2007-10-07 15:49:25.000000000 -0400
++++ ./libmpcodecs/vd_ffmpeg.c 2009-07-17 14:28:08.733520971 -0400
+@@ -387,7 +387,7 @@
+ }
+ /* Pass palette to codec */
+ if (sh->bih && (sh->bih->biBitCount <= 8)) {
+- avctx->palctrl = calloc(1,sizeof(AVPaletteControl));
++ avctx->palctrl = av_malloc(sizeof(AVPaletteControl));
+ avctx->palctrl->palette_changed = 1;
+ if (sh->bih->biSize-sizeof(BITMAPINFOHEADER))
+ /* Palette size in biSize */