aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-07-20 00:38:24 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-07-20 00:38:24 +0800
commit3c5ae26d29d089c76204d922e11735b3e316f659 (patch)
tree9e57514696520600283838815953f33aa273f479 /multimedia
parent27b90381f541a38a111703cce80885ce2aa15f12 (diff)
downloadfreebsd-ports-gnome-3c5ae26d29d089c76204d922e11735b3e316f659.tar.gz
freebsd-ports-gnome-3c5ae26d29d089c76204d922e11735b3e316f659.tar.zst
freebsd-ports-gnome-3c5ae26d29d089c76204d922e11735b3e316f659.zip
- Add libzen 0.7.69
MediaInfo is a convenient unified display of the most relevant technical and tag data for video and audio files. Read http://mediaarea.net/en/MediaInfo/Support/Formats for supported formats. WWW: http://mediainfo.sourceforge.net/
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/libzen/Makefile33
-rw-r--r--multimedia/libzen/distinfo2
-rw-r--r--multimedia/libzen/pkg-descr6
-rw-r--r--multimedia/libzen/pkg-plist46
5 files changed, 88 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index d938f04bb460..926ba37e382d 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -192,6 +192,7 @@
SUBDIR += libvpx
SUBDIR += libxine
SUBDIR += libxspf
+ SUBDIR += libzen
SUBDIR += linux-f10-libtheora
SUBDIR += linux-f10-libv4l
SUBDIR += linux-realplayer
diff --git a/multimedia/libzen/Makefile b/multimedia/libzen/Makefile
new file mode 100644
index 000000000000..d4622abcfe97
--- /dev/null
+++ b/multimedia/libzen/Makefile
@@ -0,0 +1,33 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libzen
+PORTVERSION= 0.7.69
+CATEGORIES= multimedia
+MASTER_SITES= http://mediaarea.net/download/binary/mediainfo/${PORTVERSION}/
+DISTNAME= MediaInfo_CLI_${PORTVERSION}_GNU_FromSource
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= ZenLib used by MediaInfo and its library
+
+LICENSE= ZLIB
+
+CONFLICTS_INSTALL= mediainfo-0.[0-6]* mediainfo-0.7.[0-5]*
+
+CONFIGURE_ARGS= --enable-shared
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= libtool pathfix tar:bzip2
+
+WRKSRC= ${WRKDIR}/MediaInfo_CLI_GNU_FromSource/ZenLib/Project/GNU/Library
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^ZenLib_LIBS/ s|$$(pwd)[^ ]*|${LOCALBASE}/lib|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread -lstdc++|-pthread|g' ${WRKSRC}/configure ${WRKSRC}/libzen.pc.in
+ @${REINPLACE_CMD} -e '1 s|bin/bash|bin/sh|' ${WRKSRC}/libzen-config.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/../../../Source/ZenLib/BitStream_Fast.h ${STAGEDIR}${PREFIX}/include/ZenLib/BitStream_Fast.h
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libzen.so.0.0.0
+
+.include <bsd.port.mk>
diff --git a/multimedia/libzen/distinfo b/multimedia/libzen/distinfo
new file mode 100644
index 000000000000..038972cb27d0
--- /dev/null
+++ b/multimedia/libzen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MediaInfo_CLI_0.7.69_GNU_FromSource.tar.bz2) = 145ca8e82334123558e98f973922781c947fcba3aacb1aa6137daaa3cde227d1
+SIZE (MediaInfo_CLI_0.7.69_GNU_FromSource.tar.bz2) = 1744328
diff --git a/multimedia/libzen/pkg-descr b/multimedia/libzen/pkg-descr
new file mode 100644
index 000000000000..2dc95a2502e5
--- /dev/null
+++ b/multimedia/libzen/pkg-descr
@@ -0,0 +1,6 @@
+MediaInfo is a convenient unified display of the most relevant technical and
+tag data for video and audio files.
+
+Read http://mediaarea.net/en/MediaInfo/Support/Formats for supported formats.
+
+WWW: http://mediainfo.sourceforge.net/
diff --git a/multimedia/libzen/pkg-plist b/multimedia/libzen/pkg-plist
new file mode 100644
index 000000000000..6b9e2553917b
--- /dev/null
+++ b/multimedia/libzen/pkg-plist
@@ -0,0 +1,46 @@
+bin/libzen-config
+include/ZenLib/BitStream.h
+include/ZenLib/BitStream_Fast.h
+include/ZenLib/BitStream_LE.h
+include/ZenLib/Conf.h
+include/ZenLib/Conf_Internal.h
+include/ZenLib/CriticalSection.h
+include/ZenLib/Dir.h
+include/ZenLib/File.h
+include/ZenLib/FileName.h
+include/ZenLib/Format/Html/Html_Handler.h
+include/ZenLib/Format/Html/Html_Request.h
+include/ZenLib/Format/Http/Http_Cookies.h
+include/ZenLib/Format/Http/Http_Handler.h
+include/ZenLib/Format/Http/Http_Request.h
+include/ZenLib/Format/Http/Http_Utils.h
+include/ZenLib/HTTP_Client.h
+include/ZenLib/HTTP_Client/HTTPClient.h
+include/ZenLib/HTTP_Client/HTTPClientAuth.h
+include/ZenLib/HTTP_Client/HTTPClientCommon.h
+include/ZenLib/HTTP_Client/HTTPClientString.h
+include/ZenLib/HTTP_Client/HTTPClientWrapper.h
+include/ZenLib/InfoMap.h
+include/ZenLib/MemoryDebug.h
+include/ZenLib/OS_Utils.h
+include/ZenLib/PreComp.h
+include/ZenLib/Thread.h
+include/ZenLib/Trace.h
+include/ZenLib/Translation.h
+include/ZenLib/Utils.h
+include/ZenLib/Ztring.h
+include/ZenLib/ZtringList.h
+include/ZenLib/ZtringListList.h
+include/ZenLib/ZtringListListF.h
+include/ZenLib/int128s.h
+include/ZenLib/int128u.h
+lib/libzen.a
+lib/libzen.so
+lib/libzen.so.0
+lib/libzen.so.0.0.0
+libdata/pkgconfig/libzen.pc
+@dirrm include/ZenLib/HTTP_Client
+@dirrm include/ZenLib/Format/Http
+@dirrm include/ZenLib/Format/Html
+@dirrm include/ZenLib/Format
+@dirrm include/ZenLib