aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-11-16 00:38:24 +0800
committerkwm <kwm@FreeBSD.org>2010-11-16 00:38:24 +0800
commit50cbab7f6e70bddd244845a332226c8178bf4935 (patch)
tree2b2f66e427bbbfe58deca5f3613e33480dd91f0a /multimedia
parent340900b4aacdbdb2ef9d1d2161bb634ad20dd518 (diff)
downloadfreebsd-ports-gnome-50cbab7f6e70bddd244845a332226c8178bf4935.tar.gz
freebsd-ports-gnome-50cbab7f6e70bddd244845a332226c8178bf4935.tar.zst
freebsd-ports-gnome-50cbab7f6e70bddd244845a332226c8178bf4935.zip
Add game music emu (gme) gstreamer plugin.
Submitted by: Raphael Kubo da Costa <kubito@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common8
1 files changed, 7 insertions, 1 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index f88c87120b77..ecfd4896d417 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -308,6 +308,12 @@ gst_gio_PLIST_FILES= ${GST_LIB_DIR}/libgstgio.la \
${GST_LIB_DIR}/libgstgio.so
gst_gio_DIST= base
+# gme
+gst_gme_LIB_DEPENDS+= gme.0:${PORTSDIR}/audio/libgme
+gst_gme_PLIST_FILES= ${GST_LIB_DIR}/libgstgme.la \
+ ${GST_LIB_DIR}/libgstgme.so
+gst_gme_DIST= bad
+
# gnomevfs
gst_gnomevfs_USE_GNOME+= gnomevfs2
gst_gnomevfs_CONFIGURE_ARGS+=--enable-gnome_vfs
@@ -470,7 +476,7 @@ gst_soundtouch_LIB_DEPENDS+= SoundTouch.0:${PORTSDIR}/audio/soundtouch
gst_soundtouch_PLIST_FILES= ${GST_LIB_DIR}/libgstsoundtouch.la \
${GST_LIB_DIR}/libgstsoundtouch.so
gst_soundtouch_DIST= bad
-
+
# souphttpsrc
gst_soup_LIB_DEPENDS+= soup-2.4.1:${PORTSDIR}/devel/libsoup
gst_soup_GST_PLUGIN_DIR=ext/soup