aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-05-19 23:21:37 +0800
committerfeld <feld@FreeBSD.org>2016-05-19 23:21:37 +0800
commit632a3bd86c0818bc99fdf07da169fa54494c5090 (patch)
tree9cee8460a3d6cae4a0e5f757a59c5bd45561b226 /multimedia
parentf326b1a372c4ab6710f9c3329278c5370f3f642d (diff)
downloadfreebsd-ports-gnome-632a3bd86c0818bc99fdf07da169fa54494c5090.tar.gz
freebsd-ports-gnome-632a3bd86c0818bc99fdf07da169fa54494c5090.tar.zst
freebsd-ports-gnome-632a3bd86c0818bc99fdf07da169fa54494c5090.zip
multimedia/plexpy: Warn users if no timezone is set
If you run plexpy in a jail and do not set the timezone the Plexpy process will fail to start. Several users have run into this.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/plexpy/Makefile1
-rw-r--r--multimedia/plexpy/files/plexpy.in10
2 files changed, 11 insertions, 0 deletions
diff --git a/multimedia/plexpy/Makefile b/multimedia/plexpy/Makefile
index b892793c31f1..a0989dfed8fd 100644
--- a/multimedia/plexpy/Makefile
+++ b/multimedia/plexpy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= plexpy
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= multimedia python
DISTVERSIONPREFIX=v
diff --git a/multimedia/plexpy/files/plexpy.in b/multimedia/plexpy/files/plexpy.in
index 4e88185f1b9a..c95c27850eff 100644
--- a/multimedia/plexpy/files/plexpy.in
+++ b/multimedia/plexpy/files/plexpy.in
@@ -25,5 +25,15 @@ pidfile=%%PREFIX%%/plexpy/plexpy.pid
command_interpreter=%%PYTHON_CMD%%
command=%%PREFIX%%/plexpy/PlexPy.py
command_args="-d --nolaunch --pid ${pidfile}"
+start_precmd=plexpy_prestart
+
+plexpy_prestart()
+{
+ if ! [ -e /etc/localtime ] ; then
+ echo "Plexpy needs the system timezone to be set."
+ echo "Please run /usr/sbin/tzsetup"
+ exit 1
+ fi
+}
run_rc_command "$1"