aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-07 20:32:08 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-07 20:32:08 +0800
commit66962150251d43012c6a4bda2b5daf81637ea704 (patch)
tree6ce6071564f9da5cdbf88a75e16040816eb6f3b2 /multimedia
parent449efc2bcc4d685832d3592ae4591341dcc97c56 (diff)
downloadfreebsd-ports-gnome-66962150251d43012c6a4bda2b5daf81637ea704.tar.gz
freebsd-ports-gnome-66962150251d43012c6a4bda2b5daf81637ea704.tar.zst
freebsd-ports-gnome-66962150251d43012c6a4bda2b5daf81637ea704.zip
Remove bogus statement "uses i386-specific code" as a reason to mark the
port as broken. The problem was that endianness check were added twenty years ago, and just don't cover contemporary systems. Drop checks for VAX, RS6000, 680x0, etc., and replace with architectures that FreeBSD runs on today. Users of ARM/MIPS systems are encouraged to review the list and add missing macros accordingly.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpeg_play/Makefile8
-rw-r--r--multimedia/mpeg_play/files/patch-video.h24
2 files changed, 18 insertions, 14 deletions
diff --git a/multimedia/mpeg_play/Makefile b/multimedia/mpeg_play/Makefile
index 9ded04fc7520..dca783dbacc9 100644
--- a/multimedia/mpeg_play/Makefile
+++ b/multimedia/mpeg_play/Makefile
@@ -19,14 +19,8 @@ USE_XORG= x11 xext
PLIST_FILES= bin/mpeg_play \
man/man1/mpeg_play.1.gz
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc"
-BROKEN= Does not compile on ia64 or powerpc: uses i386-specific code
-.endif
-
pre-patch:
${CP} ${WRKSRC}/Imakefile.proto ${WRKSRC}/Imakefile
${CP} ${WRKSRC}/mpeg_play.1 ${WRKSRC}/mpeg_play.man
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/mpeg_play/files/patch-video.h b/multimedia/mpeg_play/files/patch-video.h
index ecdd9861bc4b..c3ce23b3ca9b 100644
--- a/multimedia/mpeg_play/files/patch-video.h
+++ b/multimedia/mpeg_play/files/patch-video.h
@@ -1,20 +1,30 @@
---- video.h.orig Wed Oct 25 22:59:38 1995
-+++ video.h Sat Jan 31 03:25:41 2004
-@@ -431,7 +431,7 @@
+--- video.h.orig 1995-10-25 21:59:38 UTC
++++ video.h
+@@ -431,21 +431,23 @@ extern unsigned int cacheMiss[8][8];
#define __SCO__ 1
#endif
-#if defined(__i386__) || defined(__VAX__) || defined(__MIPSEL__) || defined(__alpha__) || defined(__SCO__)
-+#if defined(__i386__) || defined(__VAX__) || defined(__MIPSEL__) || defined(__alpha__) || defined(__SCO__) || defined(__amd64__)
++/* XXX: conditions below were simplified for FreeBSD */
++
++#if defined(__i386__) || defined(__amd64__)
#undef BIG_ENDIAN_ARCHITECTURE
#define LITTLE_ENDIAN_ARCHITECTURE 1
#endif
-@@ -445,7 +445,7 @@
- Error: Unknown endianism of architecture
+
+-#if defined(__RS6000__) || defined(__SPARC__) || defined(__680x0__) || defined(__HPUX__) || defined(__MIPSEB__) || defined(convex) || defined(__convex__)
++#if defined(__powerpc__) || defined(__sparc__)
+ #undef LITTLE_ENDIAN_ARCHITECTURE
+ #define BIG_ENDIAN_ARCHITECTURE 1
+ #endif
+
+ #if !defined(LITTLE_ENDIAN_ARCHITECTURE) && !defined(BIG_ENDIAN_ARCHITECTURE)
+-Error: Unknown endianism of architecture
++#error Unknown endianness of architecture
#endif
-#ifdef __alpha__
-+#if defined(__alpha__) || defined(__amd64__)
++#if defined(__amd64__) || defined(__powerpc64__) || defined(__sparc64__)
#define SIXTYFOUR_BIT
#endif
#endif /* video.h already included */