aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2011-07-26 11:03:46 +0800
committerlioux <lioux@FreeBSD.org>2011-07-26 11:03:46 +0800
commit6791ae37d10b8c0a39fe6432d55fd792b8798b62 (patch)
tree5d6dcd3fcd81320f8d7ce11b6830a4af7efa769b /multimedia
parentbf8bc9a9c08391b832c5e9d4ffd2c833ef48b039 (diff)
downloadfreebsd-ports-gnome-6791ae37d10b8c0a39fe6432d55fd792b8798b62.tar.gz
freebsd-ports-gnome-6791ae37d10b8c0a39fe6432d55fd792b8798b62.tar.zst
freebsd-ports-gnome-6791ae37d10b8c0a39fe6432d55fd792b8798b62.zip
New port py-periscope version 0.2.4: Subtitles searching module
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/py-periscope/Makefile40
-rw-r--r--multimedia/py-periscope/distinfo4
-rw-r--r--multimedia/py-periscope/pkg-descr19
-rw-r--r--multimedia/py-periscope/pkg-plist5
5 files changed, 69 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index a9e790ab1e8f..427cf24e4f88 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -272,6 +272,7 @@
SUBDIR += py-kaa-metadata
SUBDIR += py-mlt
SUBDIR += py-openlp
+ SUBDIR += py-periscope
SUBDIR += py-pybmp
SUBDIR += py-qt4-multimedia
SUBDIR += py-qt4-phonon
diff --git a/multimedia/py-periscope/Makefile b/multimedia/py-periscope/Makefile
new file mode 100644
index 000000000000..1aaa5a12eb08
--- /dev/null
+++ b/multimedia/py-periscope/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: periscope
+# Date created: Sun Jul 24 20:23:58 UTC 2011
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= periscope
+PORTVERSION= 0.2.4
+CATEGORIES= multimedia python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= python-${PORTNAME}_${PORTVERSION}.orig${EXTRACT_SUFX} \
+ periscope.desktop
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= python-${PORTNAME}_${PORTVERSION}.orig${EXTRACT_SUFX}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Subtitles searching module
+
+LICENSE= LGPL3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=3.2.0:${PORTSDIR}/www/py-beautifulsoup
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USE_GNOME= desktopfileutils
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+NO_WRKSUBDIR= yes
+
+PLIST_SUB= DESKTOPDIR=${DESKTOPDIR_WITHOUT_PREFIX:Q}
+
+DESKTOPDIR_WITHOUT_PREFIX= ${DESKTOPDIR:S,^${PREFIX}/,,}
+
+post-install:
+ @${MKDIR} ${DESKTOPDIR}
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/periscope.desktop \
+ ${DESKTOPDIR}
+ @-${LOCALBASE}/bin/update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/multimedia/py-periscope/distinfo b/multimedia/py-periscope/distinfo
new file mode 100644
index 000000000000..fea37fa96afe
--- /dev/null
+++ b/multimedia/py-periscope/distinfo
@@ -0,0 +1,4 @@
+SHA256 (periscope/python-periscope_0.2.4.orig.tar.gz) = f5426ea136d329511c2d533750339c9871d5f89d59e083a2b3c1aa94d769d646
+SIZE (periscope/python-periscope_0.2.4.orig.tar.gz) = 27510
+SHA256 (periscope/periscope.desktop) = a69b20961bc9d87b7dbdc41377eabfdb4ebc7c28a0b208fe46ebc672525b4e85
+SIZE (periscope/periscope.desktop) = 217
diff --git a/multimedia/py-periscope/pkg-descr b/multimedia/py-periscope/pkg-descr
new file mode 100644
index 000000000000..0508a91d540d
--- /dev/null
+++ b/multimedia/py-periscope/pkg-descr
@@ -0,0 +1,19 @@
+periscope is a subtitles searching module written in python that
+tries to find a correct match for a given video file. The goal
+behind periscope is that it will only return only correct subtitles
+so that you can simply relax and enjoy your video without having
+to double-check that the subtitles match your video before watching
+it. This is done by using as much info as available from your file
+and on the websites. Some websites allow you to use hash of the
+files, the size/length of the video or the exact file name.
+
+As a python module, periscope should be easily integrated in many
+projects that allow plugins to be written in python. The fact that
+the plugin is shared between all the applications means that separate
+application and their plugin (file browser, video player, media
+center application, ...) don't have to maintain the code to search,
+parse and download subtitles and the user preference about languages.
+
+The subtitles websites are handled as plugins.
+
+WWW: http://code.google.com/p/periscope/
diff --git a/multimedia/py-periscope/pkg-plist b/multimedia/py-periscope/pkg-plist
new file mode 100644
index 000000000000..700a17b9de27
--- /dev/null
+++ b/multimedia/py-periscope/pkg-plist
@@ -0,0 +1,5 @@
+bin/periscope
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%DESKTOPDIR%%/periscope.desktop
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true