aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2013-07-07 03:30:04 +0800
committernox <nox@FreeBSD.org>2013-07-07 03:30:04 +0800
commit79078e05cd9853cbdf671c95784936ddcdfbee63 (patch)
tree7ffff171b6737ad242b93841df401084d04b5333 /multimedia
parent2f3994a87f8673dab2f4a07f963e8f5e7e36cdab (diff)
downloadfreebsd-ports-gnome-79078e05cd9853cbdf671c95784936ddcdfbee63.tar.gz
freebsd-ports-gnome-79078e05cd9853cbdf671c95784936ddcdfbee63.tar.zst
freebsd-ports-gnome-79078e05cd9853cbdf671c95784936ddcdfbee63.zip
Fix build of multimedia/avidemux2 and multimedia/avidemux2-plugins
in a world WITH_CLANG_IS_CC and WITHOUT_GCC. PR: ports/180087 Submitted by: r4721@tormail.org
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/avidemux2/Makefile.common3
1 files changed, 3 insertions, 0 deletions
diff --git a/multimedia/avidemux2/Makefile.common b/multimedia/avidemux2/Makefile.common
index 014bec982cd5..c6433187a9d1 100644
--- a/multimedia/avidemux2/Makefile.common
+++ b/multimedia/avidemux2/Makefile.common
@@ -27,6 +27,7 @@ WANT_SDL= yes
USES= cmake:outsource pkgconfig iconv
CMAKE_USE_PTHREAD=yes
CMAKE_ARGS+= -DTHREADS_HAVE_PTHREAD_ARG:STRING="${PTHREAD_LIBS}"
+CFLAGS+= -Wno-return-type
MAKE_JOBS_UNSAFE= yes
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
@@ -223,6 +224,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/*/*/Makefile
+ @${REINPLACE_CMD} '/--enable-shared/s,,& --cc=${CC},' ${WRKSRC}/cmake/admFFmpegBuild.cmake
+ @${REINPLACE_CMD} '/sub $$1/s,sub,subl,' ${WRKSRC}/plugins/ADM_videoFilters/FluxSmooth/ADM_vidFlux.cpp
@${CP} ${FILESDIR}/execinfo.cpp ${WRKSRC}/cmake_compile_check/
@${CP} ${FILESDIR}/*.patch ${WRKSRC}/cmake/patches/
@${MKDIR} ${CONFIGURE_WRKSRC}/config