aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-10-31 10:03:01 +0800
committerhrs <hrs@FreeBSD.org>2013-10-31 10:03:01 +0800
commit7d80212ae8cf99791d836201ba6c10e5856af7ce (patch)
tree5aa7f3b50cea9e6b2e6e60ea4c6160dc95c1c662 /multimedia
parentd33d938cb7cc63d53c3edb6f611c9a264aed2202 (diff)
downloadfreebsd-ports-gnome-7d80212ae8cf99791d836201ba6c10e5856af7ce.tar.gz
freebsd-ports-gnome-7d80212ae8cf99791d836201ba6c10e5856af7ce.tar.zst
freebsd-ports-gnome-7d80212ae8cf99791d836201ba6c10e5856af7ce.zip
- Split the library part of multimedia/rtmpdump into multimedia/librtmp.
- Update ports depending on librtmp. - Add instruction to avoid a build error in multimedia/rtmpdump under a specific condition.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/ffmpeg/Makefile2
-rw-r--r--multimedia/ffmpeg0/Makefile2
-rw-r--r--multimedia/libav/Makefile2
-rw-r--r--multimedia/librtmp/Makefile21
-rw-r--r--multimedia/librtmp/distinfo2
-rw-r--r--multimedia/librtmp/files/patch-librtmp-Makefile (renamed from multimedia/rtmpdump/files/patch-librtmp-Makefile)0
-rw-r--r--multimedia/librtmp/files/patch-librtmp-librtmp.pc.in (renamed from multimedia/rtmpdump/files/patch-librtmp-librtmp.pc.in)0
-rw-r--r--multimedia/librtmp/pkg-descr3
-rw-r--r--multimedia/librtmp/pkg-plist11
-rw-r--r--multimedia/rtmpdump/Makefile9
-rw-r--r--multimedia/rtmpdump/files/patch-Makefile34
-rw-r--r--multimedia/rtmpdump/pkg-plist10
-rw-r--r--multimedia/xbmc-pvr/Makefile2
14 files changed, 79 insertions, 20 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 8ea9717c2c6b..8a89359e7eda 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -178,6 +178,7 @@
SUBDIR += libquicktime-lame
SUBDIR += libquvi
SUBDIR += libquvi-scripts
+ SUBDIR += librtmp
SUBDIR += libsmacker
SUBDIR += libtheora
SUBDIR += libtuner
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index ffe7f7964982..4ea6734ace00 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -143,7 +143,7 @@ PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE= libpulse
# rtmp
-RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/rtmpdump
+RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/librtmp
RTMP_CONFIGURE_ENABLE= librtmp
# schroedinger
diff --git a/multimedia/ffmpeg0/Makefile b/multimedia/ffmpeg0/Makefile
index efee0cc3e219..c17f2c2c3149 100644
--- a/multimedia/ffmpeg0/Makefile
+++ b/multimedia/ffmpeg0/Makefile
@@ -274,7 +274,7 @@ CONFIGURE_ARGS+= --disable-libopenjpeg
# rtmp
.if ${PORT_OPTIONS:MRTMP}
-LIB_DEPENDS+= librtmp.so:${PORTSDIR}/multimedia/rtmpdump
+LIB_DEPENDS+= librtmp.so:${PORTSDIR}/multimedia/librtmp
CONFIGURE_ARGS+= --enable-librtmp
. if ${OPENSSLBASE} != "/usr"
FFMPEG_CFLAGS+= -I${OPENSSLINC}
diff --git a/multimedia/libav/Makefile b/multimedia/libav/Makefile
index 4e01244b06bc..dd160939e4c2 100644
--- a/multimedia/libav/Makefile
+++ b/multimedia/libav/Makefile
@@ -101,7 +101,7 @@ OPUS_CONFIGURE_ENABLE= libopus
PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE= libpulse
-RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/rtmpdump
+RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/librtmp
RTMP_CONFIGURE_ENABLE= librtmp
SCHROEDINGER_LIB_DEPENDS= libschroedinger-1.0.so:${PORTSDIR}/multimedia/schroedinger
diff --git a/multimedia/librtmp/Makefile b/multimedia/librtmp/Makefile
new file mode 100644
index 000000000000..8709b92b1133
--- /dev/null
+++ b/multimedia/librtmp/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= librtmp
+PORTVERSION= 2.4.20130923
+CATEGORIES= multimedia net
+MASTER_SITES= LOCAL/hrs
+DISTNAME= rtmpdump-${PORTVERSION}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= RTMP stream library
+
+LICENSE= GPLv2
+
+USES= pkgconfig
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+CFLAGS+= ${PTHREAD_CFLAGS} -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+WRKSRC= ${WRKDIR}/${DISTNAME}/librtmp
+
+.include <bsd.port.mk>
diff --git a/multimedia/librtmp/distinfo b/multimedia/librtmp/distinfo
new file mode 100644
index 000000000000..543024b5446e
--- /dev/null
+++ b/multimedia/librtmp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rtmpdump-2.4.20130923.tar.gz) = 220259e3ac6b9f17d4f8643ec019fbf88780b5033bf7781fe69f1f86eff759f6
+SIZE (rtmpdump-2.4.20130923.tar.gz) = 143065
diff --git a/multimedia/rtmpdump/files/patch-librtmp-Makefile b/multimedia/librtmp/files/patch-librtmp-Makefile
index 7a28f53efe31..7a28f53efe31 100644
--- a/multimedia/rtmpdump/files/patch-librtmp-Makefile
+++ b/multimedia/librtmp/files/patch-librtmp-Makefile
diff --git a/multimedia/rtmpdump/files/patch-librtmp-librtmp.pc.in b/multimedia/librtmp/files/patch-librtmp-librtmp.pc.in
index ce58268b4367..ce58268b4367 100644
--- a/multimedia/rtmpdump/files/patch-librtmp-librtmp.pc.in
+++ b/multimedia/librtmp/files/patch-librtmp-librtmp.pc.in
diff --git a/multimedia/librtmp/pkg-descr b/multimedia/librtmp/pkg-descr
new file mode 100644
index 000000000000..0798091d561e
--- /dev/null
+++ b/multimedia/librtmp/pkg-descr
@@ -0,0 +1,3 @@
+librtmp is the library part of rtmpdump.
+
+WWW: http://rtmpdump.mplayerhq.hu/
diff --git a/multimedia/librtmp/pkg-plist b/multimedia/librtmp/pkg-plist
new file mode 100644
index 000000000000..8574b8f63989
--- /dev/null
+++ b/multimedia/librtmp/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+include/librtmp/amf.h
+include/librtmp/http.h
+include/librtmp/log.h
+include/librtmp/rtmp.h
+@dirrm include/librtmp
+lib/librtmp.a
+lib/librtmp.so
+lib/librtmp.so.0
+libdata/pkgconfig/librtmp.pc
+man/man3/librtmp.3.gz
diff --git a/multimedia/rtmpdump/Makefile b/multimedia/rtmpdump/Makefile
index d20b9eb9d101..6611521aa16b 100644
--- a/multimedia/rtmpdump/Makefile
+++ b/multimedia/rtmpdump/Makefile
@@ -2,21 +2,22 @@
PORTNAME= rtmpdump
PORTVERSION= 2.4.20130923
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia net
MASTER_SITES= LOCAL/hrs
MAINTAINER= hrs@FreeBSD.org
-COMMENT= A tool to download RTMP streams
+COMMENT= RTMP streams download utility
LICENSE= GPLv2
+LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/librtmp
+
USES= pkgconfig
-USE_LDCONFIG= yes
USE_OPENSSL= yes
MAKE_ENV= THREADLIB="${PTHREAD_LIBS}"
CFLAGS+= ${PTHREAD_CFLAGS} -I${OPENSSLINC}
-LDFLAGS+= -L${OPENSSLLIB}
+LDFLAGS+= -L${LOCALBASE}/lib -L${OPENSSLLIB}
PORTDOCS= ChangeLog README
OPTIONS_DEFINE= DOCS
diff --git a/multimedia/rtmpdump/files/patch-Makefile b/multimedia/rtmpdump/files/patch-Makefile
index 84cc3b5a940e..ea86a39d0fbc 100644
--- a/multimedia/rtmpdump/files/patch-Makefile
+++ b/multimedia/rtmpdump/files/patch-Makefile
@@ -1,5 +1,5 @@
--- Makefile.orig 2013-10-07 03:52:05.000000000 +0900
-+++ Makefile 2013-10-20 14:37:46.000000000 +0900
++++ Makefile 2013-10-30 15:30:57.000000000 +0900
@@ -1,9 +1,9 @@
VERSION=v2.4
@@ -25,7 +25,14 @@
bindir=$(prefix)/bin
sbindir=$(prefix)/sbin
-@@ -41,7 +42,7 @@
+@@ -35,13 +36,13 @@
+ LIBS_posix=
+ LIBS_darwin=
+ LIBS_mingw=-lws2_32 -lwinmm -lgdi32
+-LIB_RTMP=-Llibrtmp -lrtmp
++LIB_RTMP=-lrtmp
+ LIBS=$(LIB_RTMP) $(CRYPTO_LIB) $(LIBS_$(SYS)) $(XLIBS)
+
THREADLIB_posix=-lpthread
THREADLIB_darwin=-lpthread
THREADLIB_mingw=
@@ -34,3 +41,26 @@
SLIBS=$(THREADLIB) $(LIBS)
LIBRTMP=librtmp/librtmp.a
+@@ -54,9 +55,7 @@
+
+ PROGS=rtmpdump rtmpgw rtmpsrv rtmpsuck
+
+-all: $(LIBRTMP) $(PROGS)
+-
+-$(PROGS): $(LIBRTMP)
++all: $(PROGS)
+
+ install: $(PROGS)
+ -mkdir -p $(BINDIR) $(SBINDIR) $(MANDIR)/man1 $(MANDIR)/man8
+@@ -64,11 +63,9 @@
+ cp rtmpgw$(EXT) rtmpsrv$(EXT) rtmpsuck$(EXT) $(SBINDIR)
+ cp rtmpdump.1 $(MANDIR)/man1
+ cp rtmpgw.8 $(MANDIR)/man8
+- @cd librtmp; $(MAKE) install
+
+ clean:
+ rm -f *.o rtmpdump$(EXT) rtmpgw$(EXT) rtmpsrv$(EXT) rtmpsuck$(EXT)
+- @cd librtmp; $(MAKE) clean
+
+ FORCE:
+
diff --git a/multimedia/rtmpdump/pkg-plist b/multimedia/rtmpdump/pkg-plist
index 60c1247a31db..db1c2ad6b22b 100644
--- a/multimedia/rtmpdump/pkg-plist
+++ b/multimedia/rtmpdump/pkg-plist
@@ -3,15 +3,5 @@ bin/rtmpdump
sbin/rtmpgw
sbin/rtmpsrv
sbin/rtmpsuck
-include/librtmp/amf.h
-include/librtmp/http.h
-include/librtmp/log.h
-include/librtmp/rtmp.h
-@dirrm include/librtmp
-lib/librtmp.a
-lib/librtmp.so
-lib/librtmp.so.0
-libdata/pkgconfig/librtmp.pc
man/man1/rtmpdump.1.gz
-man/man3/librtmp.3.gz
man/man8/rtmpgw.8.gz
diff --git a/multimedia/xbmc-pvr/Makefile b/multimedia/xbmc-pvr/Makefile
index bb90b4fe3095..3c56bca703a1 100644
--- a/multimedia/xbmc-pvr/Makefile
+++ b/multimedia/xbmc-pvr/Makefile
@@ -175,7 +175,7 @@ CONFIGURE_ARGS+= --disable-pulse
.if ${PORT_OPTIONS:MRTMP}
CONFIGURE_ARGS+= --enable-rtmp
-LIB_DEPENDS+= rtmp:${PORTSDIR}/multimedia/rtmpdump
+LIB_DEPENDS+= rtmp:${PORTSDIR}/multimedia/librtmp
.else
CONFIGURE_ARGS+= --disable-rtmp
.endif