aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjsa <jsa@FreeBSD.org>2010-12-31 03:19:14 +0800
committerjsa <jsa@FreeBSD.org>2010-12-31 03:19:14 +0800
commit7e3c5aaa1e66819074aa720249f7e6cfe36167a8 (patch)
treeae82a18fe5989e4a621134dcdc3b7c5e3abea299 /multimedia
parentf53ad4bc922bd43a23a7a4ad46e93110359cf6c3 (diff)
downloadfreebsd-ports-gnome-7e3c5aaa1e66819074aa720249f7e6cfe36167a8.tar.gz
freebsd-ports-gnome-7e3c5aaa1e66819074aa720249f7e6cfe36167a8.tar.zst
freebsd-ports-gnome-7e3c5aaa1e66819074aa720249f7e6cfe36167a8.zip
Reenable the Mozilla PLUGIN option. Seems it was not removed after all.
Submitted by: thierry Approved by: kwm (mentor), wxs (mentor)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 77c9ad52bebc..6393fe51917e 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -55,6 +55,7 @@ OPTIONS= A52 "A52 DVD audio decoder" On \
OCFLAGS "Optimized CFLAGS" Off \
OGG "Ogg audio decoder support" On \
OPENGL "OpenGL acceleration support" Off \
+ PLUGIN "VLC Mozilla Plugin" Off \
PNG "PNG graphics format support" On \
PORTAUDIO "Portaudio library support" Off \
PULSE "Pulse Audio support" Off \
@@ -444,6 +445,17 @@ CONFIGURE_ARGS+=--enable-opengl
CONFIGURE_ARGS+=--disable-opengl
.endif
+.if defined(WITH_PLUGIN)
+USE_GECKO= libxul
+USE_WEBPLUGINS= gecko*
+WEBPLUGINS_FILES=libvlcplugin.so
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+CONFIGURE_ARGS+=--enable-mozilla \
+ --with-mozilla-pkg=${LOCALBASE}/libdata/pkgconfig/mozilla-plugin.pc
+.else
+CONFIGURE_ARGS+=--disable-mozilla
+.endif
+
.if defined(WITHOUT_PNG)
CONFIGURE_ARGS+=--disable-png
.else
@@ -658,6 +670,13 @@ post-patch:
${REINPLACE_CMD} -e 's|portaudio\.h|portaudio2/&|g' \
${WRKSRC}/modules/audio_output/portaudio.c
+pre-configure:
+.if defined(WITH_PLUGIN)
+ ${REINPLACE_CMD} -e 's|npvlcdir = $$(libdir)/mozilla/plugins|npvlcdir = ${WEBPLUGINS_DIR}|g' \
+ ${WRKSRC}/projects/mozilla/Makefile.am \
+ ${WRKSRC}/projects/mozilla/Makefile.in
+.endif
+
pre-install:
${RM} -rf ${PLIST} ${FAKEDIR}
${MKDIR} ${FAKEDIR}
@@ -678,6 +697,14 @@ pre-install:
${RM} -f ${FAKEDIR}/lib/vlc/plugins/services_discovery/libsap_plugin.la
${RM} -f ${FAKEDIR}/lib/vlc/plugins/services_discovery/libsap_plugin.so
.endif
+.if defined(WITH_PLUGIN)
+. for ext in so la
+ ${ECHO_CMD} "${WEBPLUGINS_DIR}/libvlcplugin.${ext}" | \
+ ${SED} -e 's|${PREFIX}/||' >> ${PLIST}
+. endfor
+ ${ECHO_CMD} "@dirrmtry ${WEBPLUGINS_DIR}" | \
+ ${SED} -e 's|${PREFIX}/||' >> ${PLIST}
+.endif
${MKDIR} ${FAKEDIR}/libdata
${MV} ${FAKEDIR}/lib/pkgconfig ${FAKEDIR}/libdata/pkgconfig
cd ${FAKEDIR}/lib && ${FIND} -s * -type f -o -type l| \