aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2017-01-08 23:29:22 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2017-01-08 23:29:22 +0800
commit8568f2fa88573dcee25b63598ee0a8f42be8441a (patch)
treeb73362434364d3a5fa76d4a0f2335170dc7b0836 /multimedia
parentd0301877d6cca2ca32e86796de1847b2b7db8bcb (diff)
downloadfreebsd-ports-gnome-8568f2fa88573dcee25b63598ee0a8f42be8441a.tar.gz
freebsd-ports-gnome-8568f2fa88573dcee25b63598ee0a8f42be8441a.tar.zst
freebsd-ports-gnome-8568f2fa88573dcee25b63598ee0a8f42be8441a.zip
multimedia/plexhometheater: Pet portlint (no-op)
- Re-generate patches with makepatch (pet portlint) - Remove blank lines between BUILD/LIB/RUN_DEPENDS (pet portlint) - Add LICENSE_FILE
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/plexhometheater/Makefile3
-rw-r--r--multimedia/plexhometheater/files/patch-clang66
-rw-r--r--multimedia/plexhometheater/files/patch-plex_CMakeModules_PlatformConfigFREEBSD.cmake (renamed from multimedia/plexhometheater/files/patch-plex__CMakeModules__PlatformConfigFREEBSD.cmake)4
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc__freebsd__CMakeLists.txt6
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc_cores_AudioEngine_Engines_SoftAE_SoftAE.cpp (renamed from multimedia/plexhometheater/files/patch-xbmc__cores__AudioEngine__Engines__SoftAE__SoftAE.cpp)6
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc_cores_dvdplayer_DVDCodecs_Video_VAAPI.cpp (renamed from multimedia/plexhometheater/files/patch-xbmc__cores__dvdplayer__DVDCodecs__Video__VAAPI.cpp)6
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc_freebsd_CMakeLists.txt6
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc_threads_platform_pthreads_ThreadImpl.cpp (renamed from multimedia/plexhometheater/files/patch-xbmc__threads__platform__pthreads__ThreadImpl.cpp)6
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc_visualizations_XBMCProjectM_libprojectM_PresetLoader.hpp (renamed from multimedia/plexhometheater/files/patch-xbmc__visualizations__XBMCProjectM__libprojectM__PresetLoader.hpp)6
9 files changed, 48 insertions, 61 deletions
diff --git a/multimedia/plexhometheater/Makefile b/multimedia/plexhometheater/Makefile
index 0a5ab4bba203..40abc1718c91 100644
--- a/multimedia/plexhometheater/Makefile
+++ b/multimedia/plexhometheater/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= woodsb02@FreeBSD.org
COMMENT= Media center frontend to multimedia/plexmediaserver
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.GPL
BUILD_DEPENDS= enca:converters/enca \
gawk:lang/gawk \
@@ -21,7 +22,6 @@ BUILD_DEPENDS= enca:converters/enca \
nasm:devel/nasm \
gtk-update-icon-cache:x11-toolkits/gtk20 \
swig2.0:devel/swig20
-
LIB_DEPENDS= libass.so:multimedia/libass \
libavahi-client.so:net/avahi-app \
libboost_thread.so:devel/boost-libs \
@@ -55,7 +55,6 @@ LIB_DEPENDS= libass.so:multimedia/libass \
libvorbis.so:audio/libvorbis \
libxslt.so:textproc/libxslt \
libyajl.so:devel/yajl
-
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
glxinfo:graphics/mesa-demos \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
diff --git a/multimedia/plexhometheater/files/patch-clang b/multimedia/plexhometheater/files/patch-clang
index 88eda0557eb1..0769943e613b 100644
--- a/multimedia/plexhometheater/files/patch-clang
+++ b/multimedia/plexhometheater/files/patch-clang
@@ -1,26 +1,6 @@
-diff --git xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h
-index e045a72..ff4f575 100644
---- xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h
-+++ xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h
-@@ -198,8 +198,12 @@ extern int __argp_fmtstream_ensure (argp_fmtstream_t __fs, size_t __amount);
- #endif
-
- #ifndef ARGP_FS_EI
-+#ifdef __clang__
-+#define ARGP_FS_EI extern inline __attribute__ ((__gnu_inline__))
-+#else
- #define ARGP_FS_EI extern inline
- #endif
-+#endif
-
- ARGP_FS_EI size_t
- __argp_fmtstream_write (argp_fmtstream_t __fs,
-
-diff --git lib/cpluff/libcpluff/cpluff.c lib/cpluff/libcpluff/cpluff.c
-index a7e8725..0f5bb90 100644
---- lib/cpluff/libcpluff/cpluff.c
+--- lib/cpluff/libcpluff/cpluff.c.orig 2015-05-11 07:54:22 UTC
+++ lib/cpluff/libcpluff/cpluff.c
-@@ -77,6 +77,7 @@ CP_C_API const char *cp_get_host_type(void) {
+@@ -77,6 +77,7 @@ CP_C_API const char *cp_get_host_type(vo
return CP_HOST;
}
@@ -28,7 +8,7 @@ index a7e8725..0f5bb90 100644
CP_HIDDEN void cpi_lock_framework(void) {
#if defined(CP_THREADS)
cpi_lock_mutex(framework_mutex);
-@@ -93,6 +94,7 @@ CP_HIDDEN void cpi_unlock_framework(void) {
+@@ -93,6 +94,7 @@ CP_HIDDEN void cpi_unlock_framework(void
framework_locked--;
#endif
}
@@ -36,11 +16,9 @@ index a7e8725..0f5bb90 100644
static void reset(void) {
#ifdef CP_THREADS
-diff --git lib/cpluff/libcpluff/logging.c lib/cpluff/libcpluff/logging.c
-index 928f0b4..f0f873d 100644
---- lib/cpluff/libcpluff/logging.c
+--- lib/cpluff/libcpluff/logging.c.orig 2015-05-11 07:54:22 UTC
+++ lib/cpluff/libcpluff/logging.c
-@@ -129,10 +129,12 @@ CP_C_API cp_status_t cp_register_logger(cp_context_t *context, cp_logger_func_t
+@@ -129,10 +129,12 @@ CP_C_API cp_status_t cp_register_logger(
// Report error
if (status == CP_ERR_RESOURCE) {
cpi_error(context, N_("Logger could not be registered due to insufficient memory."));
@@ -53,7 +31,7 @@ index 928f0b4..f0f873d 100644
}
cpi_unlock_context(context);
-@@ -166,11 +168,13 @@ CP_C_API void cp_unregister_logger(cp_context_t *context, cp_logger_func_t logge
+@@ -166,11 +168,13 @@ CP_C_API void cp_unregister_logger(cp_co
free(lh);
update_logging_limits(context);
}
@@ -67,11 +45,9 @@ index 928f0b4..f0f873d 100644
cpi_unlock_context(context);
}
-diff --git lib/cpluff/libcpluff/pinfo.c lib/cpluff/libcpluff/pinfo.c
-index cfbf049..f7b4a4b 100644
---- lib/cpluff/libcpluff/pinfo.c
+--- lib/cpluff/libcpluff/pinfo.c.orig 2015-05-11 07:54:22 UTC
+++ lib/cpluff/libcpluff/pinfo.c
-@@ -569,10 +569,12 @@ CP_C_API cp_status_t cp_register_plistener(cp_context_t *context, cp_plugin_list
+@@ -569,10 +569,12 @@ CP_C_API cp_status_t cp_register_plisten
// Report error or success
if (status != CP_OK) {
cpi_error(context, _("A plug-in listener could not be registered due to insufficient memory."));
@@ -84,7 +60,7 @@ index cfbf049..f7b4a4b 100644
}
cpi_unlock_context(context);
-@@ -591,10 +593,12 @@ CP_C_API void cp_unregister_plistener(cp_context_t *context, cp_plugin_listener_
+@@ -591,11 +593,13 @@ CP_C_API void cp_unregister_plistener(cp
if (node != NULL) {
process_unregister_plistener(context->env->plugin_listeners, node, NULL);
}
@@ -97,11 +73,10 @@ index cfbf049..f7b4a4b 100644
+#endif
cpi_unlock_context(context);
}
-diff --git lib/cpluff/libcpluff/psymbol.c lib/cpluff/libcpluff/psymbol.c
-index 632b087..fdc15af 100644
---- lib/cpluff/libcpluff/psymbol.c
+
+--- lib/cpluff/libcpluff/psymbol.c.orig 2015-05-11 07:54:22 UTC
+++ lib/cpluff/libcpluff/psymbol.c
-@@ -248,11 +248,13 @@ CP_C_API void * cp_resolve_symbol(cp_context_t *context, const char *id, const c
+@@ -248,11 +248,13 @@ CP_C_API void * cp_resolve_symbol(cp_con
symbol_info->usage_count++;
provider_info->usage_count++;
@@ -115,7 +90,7 @@ index 632b087..fdc15af 100644
} while (0);
// Clean up
-@@ -314,11 +316,13 @@ CP_C_API void cp_release_symbol(cp_context_t *context, const void *ptr) {
+@@ -314,11 +316,13 @@ CP_C_API void cp_release_symbol(cp_conte
if (symbol_info->usage_count == 0) {
hash_delete_free(context->resolved_symbols, node);
free(symbol_info);
@@ -129,3 +104,18 @@ index 632b087..fdc15af 100644
}
// Check if the symbol providing plug-in is not being used anymore
+--- xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h.orig 2015-05-11 07:54:22 UTC
++++ xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h
+@@ -198,8 +198,12 @@ extern int __argp_fmtstream_ensure (argp
+ #endif
+
+ #ifndef ARGP_FS_EI
++#ifdef __clang__
++#define ARGP_FS_EI extern inline __attribute__ ((__gnu_inline__))
++#else
+ #define ARGP_FS_EI extern inline
+ #endif
++#endif
+
+ ARGP_FS_EI size_t
+ __argp_fmtstream_write (argp_fmtstream_t __fs,
diff --git a/multimedia/plexhometheater/files/patch-plex__CMakeModules__PlatformConfigFREEBSD.cmake b/multimedia/plexhometheater/files/patch-plex_CMakeModules_PlatformConfigFREEBSD.cmake
index f40c0c15a5e5..673ef239983e 100644
--- a/multimedia/plexhometheater/files/patch-plex__CMakeModules__PlatformConfigFREEBSD.cmake
+++ b/multimedia/plexhometheater/files/patch-plex_CMakeModules_PlatformConfigFREEBSD.cmake
@@ -1,5 +1,5 @@
---- plex/CMakeModules/PlatformConfigFREEBSD.cmake.orig 2014-06-18 10:24:35.922455079 +0000
-+++ plex/CMakeModules/PlatformConfigFREEBSD.cmake 2014-06-18 13:58:08.739586540 +0000
+--- plex/CMakeModules/PlatformConfigFREEBSD.cmake.orig 2017-01-08 15:03:09 UTC
++++ plex/CMakeModules/PlatformConfigFREEBSD.cmake
@@ -0,0 +1,144 @@
+# vim: setlocal syntax=cmake:
+
diff --git a/multimedia/plexhometheater/files/patch-xbmc__freebsd__CMakeLists.txt b/multimedia/plexhometheater/files/patch-xbmc__freebsd__CMakeLists.txt
deleted file mode 100644
index af59985a1997..000000000000
--- a/multimedia/plexhometheater/files/patch-xbmc__freebsd__CMakeLists.txt
+++ /dev/null
@@ -1,6 +0,0 @@
---- xbmc/freebsd/CMakeLists.txt.orig 2014-08-05 20:18:02.009525912 +0800
-+++ xbmc/freebsd/CMakeLists.txt 2014-08-05 20:18:40.357527987 +0800
-@@ -0,0 +1,3 @@
-+find_all_sources(. freebsd_SRCS)
-+
-+add_sources(${freebsd_SRCS})
diff --git a/multimedia/plexhometheater/files/patch-xbmc__cores__AudioEngine__Engines__SoftAE__SoftAE.cpp b/multimedia/plexhometheater/files/patch-xbmc_cores_AudioEngine_Engines_SoftAE_SoftAE.cpp
index b44f37d871d3..e4012193cbe5 100644
--- a/multimedia/plexhometheater/files/patch-xbmc__cores__AudioEngine__Engines__SoftAE__SoftAE.cpp
+++ b/multimedia/plexhometheater/files/patch-xbmc_cores_AudioEngine_Engines_SoftAE_SoftAE.cpp
@@ -1,8 +1,6 @@
-diff --git xbmc/cores/AudioEngine/Engines/SoftAE/SoftAE.cpp xbmc/cores/AudioEngine/Engines/SoftAE/SoftAE.cpp
-index bd01a67..49edfee 100644
---- xbmc/cores/AudioEngine/Engines/SoftAE/SoftAE.cpp
+--- xbmc/cores/AudioEngine/Engines/SoftAE/SoftAE.cpp.orig 2015-05-11 07:54:22 UTC
+++ xbmc/cores/AudioEngine/Engines/SoftAE/SoftAE.cpp
-@@ -303,7 +303,7 @@ void CSoftAE::InternalOpenSink()
+@@ -328,7 +328,7 @@ void CSoftAE::InternalOpenSink()
/* perform basic sanity checks on the format returned by the sink */
ASSERT(newFormat.m_channelLayout.Count() > 0);
diff --git a/multimedia/plexhometheater/files/patch-xbmc__cores__dvdplayer__DVDCodecs__Video__VAAPI.cpp b/multimedia/plexhometheater/files/patch-xbmc_cores_dvdplayer_DVDCodecs_Video_VAAPI.cpp
index 27ce4d4a531c..1e1bb343acb2 100644
--- a/multimedia/plexhometheater/files/patch-xbmc__cores__dvdplayer__DVDCodecs__Video__VAAPI.cpp
+++ b/multimedia/plexhometheater/files/patch-xbmc_cores_dvdplayer_DVDCodecs_Video_VAAPI.cpp
@@ -1,6 +1,6 @@
---- xbmc/cores/dvdplayer/DVDCodecs/Video/VAAPI.cpp.orig 2013-10-19 23:07:02.530131780 +0200
-+++ xbmc/cores/dvdplayer/DVDCodecs/Video/VAAPI.cpp 2013-10-19 23:06:38.499626784 +0200
-@@ -74,7 +74,7 @@
+--- xbmc/cores/dvdplayer/DVDCodecs/Video/VAAPI.cpp.orig 2015-05-11 07:54:22 UTC
++++ xbmc/cores/dvdplayer/DVDCodecs/Video/VAAPI.cpp
+@@ -74,7 +74,7 @@ static inline VASurfaceID GetSurfaceID(A
static CDisplayPtr GetGlobalDisplay()
{
diff --git a/multimedia/plexhometheater/files/patch-xbmc_freebsd_CMakeLists.txt b/multimedia/plexhometheater/files/patch-xbmc_freebsd_CMakeLists.txt
new file mode 100644
index 000000000000..25da9746831c
--- /dev/null
+++ b/multimedia/plexhometheater/files/patch-xbmc_freebsd_CMakeLists.txt
@@ -0,0 +1,6 @@
+--- xbmc/freebsd/CMakeLists.txt.orig 2017-01-08 15:03:09 UTC
++++ xbmc/freebsd/CMakeLists.txt
+@@ -0,0 +1,3 @@
++find_all_sources(. freebsd_SRCS)
++
++add_sources(${freebsd_SRCS})
diff --git a/multimedia/plexhometheater/files/patch-xbmc__threads__platform__pthreads__ThreadImpl.cpp b/multimedia/plexhometheater/files/patch-xbmc_threads_platform_pthreads_ThreadImpl.cpp
index 94efd0acdfb4..87b5d4194d04 100644
--- a/multimedia/plexhometheater/files/patch-xbmc__threads__platform__pthreads__ThreadImpl.cpp
+++ b/multimedia/plexhometheater/files/patch-xbmc_threads_platform_pthreads_ThreadImpl.cpp
@@ -1,5 +1,5 @@
---- xbmc/threads/platform/pthreads/ThreadImpl.cpp.orig 2013-05-13 11:32:04.000000000 +0200
-+++ xbmc/threads/platform/pthreads/ThreadImpl.cpp 2013-05-13 11:47:27.000000000 +0200
+--- xbmc/threads/platform/pthreads/ThreadImpl.cpp.orig 2015-05-11 07:54:22 UTC
++++ xbmc/threads/platform/pthreads/ThreadImpl.cpp
@@ -29,12 +29,8 @@
#include <string.h>
#ifdef __FreeBSD__
@@ -13,7 +13,7 @@
#include <signal.h>
-@@ -59,11 +55,7 @@
+@@ -59,11 +55,7 @@ void CThread::TermHandler() { }
void CThread::SetThreadInfo()
{
#ifdef __FreeBSD__
diff --git a/multimedia/plexhometheater/files/patch-xbmc__visualizations__XBMCProjectM__libprojectM__PresetLoader.hpp b/multimedia/plexhometheater/files/patch-xbmc_visualizations_XBMCProjectM_libprojectM_PresetLoader.hpp
index 25a24ce66e80..19660ad9b638 100644
--- a/multimedia/plexhometheater/files/patch-xbmc__visualizations__XBMCProjectM__libprojectM__PresetLoader.hpp
+++ b/multimedia/plexhometheater/files/patch-xbmc_visualizations_XBMCProjectM_libprojectM_PresetLoader.hpp
@@ -1,6 +1,6 @@
---- xbmc/visualizations/XBMCProjectM/libprojectM/PresetLoader.hpp.orig 2013-07-04 15:52:54.000000000 +0200
-+++ xbmc/visualizations/XBMCProjectM/libprojectM/PresetLoader.hpp 2013-07-04 15:53:28.000000000 +0200
-@@ -29,7 +29,7 @@
+--- xbmc/visualizations/XBMCProjectM/libprojectM/PresetLoader.hpp.orig 2015-05-11 07:54:22 UTC
++++ xbmc/visualizations/XBMCProjectM/libprojectM/PresetLoader.hpp
+@@ -29,7 +29,7 @@ class PresetLoader {
static const std::string MILKDROP_FILE_EXTENSION;
/** Initializes the preset loader with the target directory specified */