aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-10-20 16:12:20 +0800
committermarino <marino@FreeBSD.org>2014-10-20 16:12:20 +0800
commit90869355c500df46e3b6017d8e0b1a2db48a1ce8 (patch)
tree6661e7ce62892409aaddb9d650570241a1b6af3c /multimedia
parentb8ee2cf998a8f43df9486683be50e802f6f40bfa (diff)
downloadfreebsd-ports-gnome-90869355c500df46e3b6017d8e0b1a2db48a1ce8.tar.gz
freebsd-ports-gnome-90869355c500df46e3b6017d8e0b1a2db48a1ce8.tar.zst
freebsd-ports-gnome-90869355c500df46e3b6017d8e0b1a2db48a1ce8.zip
Add USES=alias to several ports
Alias is a new USES tool that allows DragonFly to masquerade as FreeBSD by setting CFLAGS+= -D__FreeBSD__. For some ports, this fixes the build without the need for additional patches. Approved by: portmgr (bapt, blanket)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gavl/Makefile2
-rw-r--r--multimedia/libmpeg3/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/gavl/Makefile b/multimedia/gavl/Makefile
index 4302ad2a6fd8..71280aa91067 100644
--- a/multimedia/gavl/Makefile
+++ b/multimedia/gavl/Makefile
@@ -13,7 +13,7 @@ COMMENT= Library for handling uncompressed video and audio data
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pathfix pkgconfig libtool
+USES= alias libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/multimedia/libmpeg3/Makefile b/multimedia/libmpeg3/Makefile
index 08a943e24cb5..87fc28dc308c 100644
--- a/multimedia/libmpeg3/Makefile
+++ b/multimedia/libmpeg3/Makefile
@@ -17,7 +17,7 @@ OPTIONS_DEFINE_i386= MMX
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= gmake tar:bzip2
+USES= alias gmake tar:bzip2
MAKE_ARGS= CC="${CC}" USE_CSS=0 OBJDIR="obj" \
CFLAGS="${CFLAGS} ${CPPFLAGS}" LIBS="${LIBS}"