aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /multimedia
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/assimp/Makefile2
-rw-r--r--multimedia/mkvtoolnix/Makefile2
-rw-r--r--multimedia/mplayer/Makefile.options2
-rw-r--r--multimedia/vlc/Makefile2
-rw-r--r--multimedia/x264/Makefile4
5 files changed, 6 insertions, 6 deletions
diff --git a/multimedia/assimp/Makefile b/multimedia/assimp/Makefile
index 27d9b993e8f6..36b831cc648e 100644
--- a/multimedia/assimp/Makefile
+++ b/multimedia/assimp/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs
USE_ZIP= yes
USES= cmake pkgconfig
-USE_GCC= 4.6+ # 4.2+ causes compiler warnings
+USE_GCC= yes # GCC 4.2 causes compiler warnings
USE_LDCONFIG= yes
# CMAKE_ARGS instructs cmake to skip runtime path removal during install
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index 9576b7ef229d..eebd8abc5b61 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
USES= pkgconfig gettext iconv
USE_XZ= yes
-USE_GCC= 4.6+
+USE_GCC= yes
GNU_CONFIGURE= yes
USE_RAKE= yes
USE_RUBY= yes
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 59dd4beeae83..f4ec25cc37c7 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -71,7 +71,7 @@ CPP= clang-cpp
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang-version
.else
.if ${PORT_OPTIONS:MOTCHAIN}
-USE_GCC?= 4.6+
+USE_GCC?= yes
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.else
CONFIGURE_ARGS+=--disable-ssse3 --disable-sse4 --disable-sse42 \
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index bac67d18e3ed..6fb57d4886c2 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -694,7 +694,7 @@ CXX= clang++
CPP= clang-cpp
.else
.if ${ARCH} == "i386"
-USE_GCC?= 4.6+ # sse/3dnow detection on i386 needs newer gcc
+USE_GCC?= yes # sse/3dnow detection on i386 needs newer GCC
.endif
.endif
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index e54a6fa64b7c..a5a297430f4e 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -40,7 +40,7 @@ HAS_CONFIGURE= yes
OPTIONS_DEFINE= ASM DEBUG PGO GCC44 GPAC X11_OUTPUT
OPTIONS_DEFAULT= ASM PGO GPAC
ASM_DESC= Assembly optimizations (devel/binutils)
-GCC44_DESC= Use gcc 4.4+ (implies WITH_ASM)
+GCC44_DESC= Use current GCC (implies WITH_ASM)
GPAC_DESC= Enable MPEG-4 Output
X11_OUTPUT_DESC= Enable X11 Output
@@ -53,7 +53,7 @@ PLIST_SUB+= X264_BUILD=${X264_BUILD}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGCC44}
-USE_GCC?= 4.4+
+USE_GCC?= yes
.endif
.include <bsd.port.pre.mk>