aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-09-28 06:16:17 +0800
committerkwm <kwm@FreeBSD.org>2015-09-28 06:16:17 +0800
commit93b94fdb6f2dff1418da2db902685db0c3ab07fe (patch)
treec29d7fd43d57fc621815cef0bd8493d920373013 /multimedia
parentb070ad6b2641955671fb527fd209dd6a076b8122 (diff)
downloadfreebsd-ports-gnome-93b94fdb6f2dff1418da2db902685db0c3ab07fe.tar.gz
freebsd-ports-gnome-93b94fdb6f2dff1418da2db902685db0c3ab07fe.tar.zst
freebsd-ports-gnome-93b94fdb6f2dff1418da2db902685db0c3ab07fe.zip
Update gstreamer1-vaapi to 0.6.0.
Also fix plist issues after GStreamer update to 1.6. [1] Reported by: antoine@ [1]
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer1-vaapi/Makefile7
-rw-r--r--multimedia/gstreamer1-vaapi/distinfo4
-rw-r--r--multimedia/gstreamer1-vaapi/pkg-descr2
-rw-r--r--multimedia/gstreamer1-vaapi/pkg-plist11
4 files changed, 16 insertions, 8 deletions
diff --git a/multimedia/gstreamer1-vaapi/Makefile b/multimedia/gstreamer1-vaapi/Makefile
index c5447a0b9222..1707129ece44 100644
--- a/multimedia/gstreamer1-vaapi/Makefile
+++ b/multimedia/gstreamer1-vaapi/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gstreamer1-vaapi
-PORTVERSION= 0.5.10
-PORTREVISION= 1
+PORTVERSION= 0.6.0
CATEGORIES= multimedia
MASTER_SITES= http://www.freedesktop.org/software/vaapi/releases/gstreamer-vaapi/
DISTNAME= gstreamer-vaapi-${PORTVERSION}
@@ -16,7 +15,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libva.so:${PORTSDIR}/multimedia/libva
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-wayland --with-gstreamer-api=1.4 \
+CONFIGURE_ARGS= --disable-wayland \
--disable-builtin-libvpx --disable-silent-rules
INSTALL_TARGET= install-strip
USES= compiler:c11 gmake libtool pkgconfig tar:bzip2
@@ -25,7 +24,7 @@ USE_GSTREAMER1= yes
USE_GL= gl
USE_XORG= x11 xrandr xrender xproto:build
-PLIST_SUB= VERSION=1.0 LIBVER=1.4
+PLIST_SUB= VERSION=1.0 LIBVER=1.6
# manual since pathfix doesn't work.
post-patch:
diff --git a/multimedia/gstreamer1-vaapi/distinfo b/multimedia/gstreamer1-vaapi/distinfo
index da59862fd227..1497f6ed2229 100644
--- a/multimedia/gstreamer1-vaapi/distinfo
+++ b/multimedia/gstreamer1-vaapi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gstreamer-vaapi-0.5.10.tar.bz2) = 0dd236c7bf225322b8934fdba99a7a9e4542566a2acbe7564cdc3ec2c8b73c9d
-SIZE (gstreamer-vaapi-0.5.10.tar.bz2) = 1333822
+SHA256 (gstreamer-vaapi-0.6.0.tar.bz2) = f6a4c657606849fb09ee2db778c80278cfa4546e9103862f273c910e208872b8
+SIZE (gstreamer-vaapi-0.6.0.tar.bz2) = 1406631
diff --git a/multimedia/gstreamer1-vaapi/pkg-descr b/multimedia/gstreamer1-vaapi/pkg-descr
index 15685edb6cbb..68313619e8b8 100644
--- a/multimedia/gstreamer1-vaapi/pkg-descr
+++ b/multimedia/gstreamer1-vaapi/pkg-descr
@@ -5,4 +5,4 @@ decoders are supported: JPEG, MPEG-2, MPEG-4:2, H.264 and VC-1.
Renderers are available for X11, GLX, Wayland and raw DRM for headless
pipelines.
-WWW: https://gitorious.org/vaapi/gstreamer-vaapi
+WWW: https://github.com/01org/gstreamer-vaapi
diff --git a/multimedia/gstreamer1-vaapi/pkg-plist b/multimedia/gstreamer1-vaapi/pkg-plist
index df76dd9641f0..23237669aa7e 100644
--- a/multimedia/gstreamer1-vaapi/pkg-plist
+++ b/multimedia/gstreamer1-vaapi/pkg-plist
@@ -4,6 +4,7 @@ include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapicodedbufferpool.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapicodedbufferproxy.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_h264.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_h265.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_jpeg.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_mpeg2.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_mpeg4.h
@@ -11,12 +12,16 @@ include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_vc1.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidecoder_vp8.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay_drm.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay_egl.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay_glx.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay_wayland.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapidisplay_x11.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiencoder.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiencoder_h264.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiencoder_h265.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiencoder_jpeg.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiencoder_mpeg2.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiencoder_vp8.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapifilter.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiimage.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiimagepool.h
@@ -27,23 +32,27 @@ include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiprofile.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisubpicture.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisurface.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisurface_drm.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisurface_egl.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisurfacepool.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapisurfaceproxy.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapitexture.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapitexture_egl.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapitexture_glx.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapitypes.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiutils_h264.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiutils_h265.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiutils_mpeg2.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapivalue.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapivideopool.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow_drm.h
+include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow_egl.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow_glx.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow_wayland.h
include/gstreamer-%%VERSION%%/gst/vaapi/gstvaapiwindow_x11.h
include/gstreamer-%%VERSION%%/gst/vaapi/video-format.h
+lib/gstreamer-%%VERSION%%/libgstvaapi.so
lib/gstreamer-%%VERSION%%/libgstvaapi_parse.so
-lib/gstreamer-1.0/libgstvaapi.so
lib/libgstvaapi-%%LIBVER%%.a
lib/libgstvaapi-%%LIBVER%%.so
lib/libgstvaapi-%%LIBVER%%.so.1