aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-03-12 01:03:15 +0800
committermandree <mandree@FreeBSD.org>2013-03-12 01:03:15 +0800
commit94ab5ea0a5abde5f9d9abb44dfe7eb537e32098c (patch)
tree011f55e1dc4812a5e6825eeaebfa5e5c682fcc9a /multimedia
parent0d4a9930829a841c38d47ceb391fc535e7479d87 (diff)
downloadfreebsd-ports-gnome-94ab5ea0a5abde5f9d9abb44dfe7eb537e32098c.tar.gz
freebsd-ports-gnome-94ab5ea0a5abde5f9d9abb44dfe7eb537e32098c.tar.zst
freebsd-ports-gnome-94ab5ea0a5abde5f9d9abb44dfe7eb537e32098c.zip
Fix an issue with bktr.
PR: ports/173750 Submitted by: c.petrik.sosa@gmail.com (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/motion/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index 819af7128f22..bd017c4232b7 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -3,6 +3,7 @@
PORTNAME= motion
PORTVERSION= 3.2.12
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20-%20${PORTVERSION:R}/${PORTVERSION}
@@ -13,10 +14,10 @@ LICENSE= GPLv2
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
-OPTIONS_DEFINE= VIDEO LTHREAD FFMPEG MYSQL PGSQL DOCS EXAMPLES
+OPTIONS_DEFINE= LTHREAD FFMPEG MYSQL PGSQL DOCS EXAMPLES
OPTIONS_SINGLE= VIDEO
OPTIONS_SINGLE_VIDEO= BKTR PWCBSD
-OPTIONS_DEFAULT= VIDEO BKTR FFMPEG
+OPTIONS_DEFAULT= BKTR FFMPEG
VIDEO_DESC= Video capture driver. Choose one of BKTR or PWCBSD
BKTR_DESC= BKTR based TV capture cards
PWCBSD_DESC= PWCBSD based Webcams
@@ -39,6 +40,7 @@ PORTEXAMPLES= motion-dist.conf thread1.conf thread2.conf \
.if ${PORT_OPTIONS:MBKTR}
CONFIGURE_ARGS+=--with-bktr
+CFLAGS+= -DWITHOUT_V4L
.else
CONFIGURE_ARGS+=--without-bktr
.endif
@@ -47,9 +49,9 @@ CONFIGURE_ARGS+=--without-bktr
BUILD_DEPENDS+= v4l_compat>=1.0.20060801:${PORTSDIR}/multimedia/v4l_compat
RUN_DEPENDS+= /boot/modules/pwc.ko:${PORTSDIR}/multimedia/pwcbsd
CONFIGURE_ARGS+=--with-pwcbsd
+CFLAGS+= -DWITHOUT_V4L
.else
CONFIGURE_ARGS+=--without-pwcbsd
-CFLAGS+= -DWITHOUT_V4L
.endif
.if ${PORT_OPTIONS:MLTHREAD}