aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorrea <rea@FreeBSD.org>2011-01-09 21:23:18 +0800
committerrea <rea@FreeBSD.org>2011-01-09 21:23:18 +0800
commitac9f99e39eafb4886cfd7bb2dc74414f8a86bb81 (patch)
tree74fe5bf4ab87e3de9f7f4d84ffed18111d330c05 /multimedia
parentd4f95e831035c53290fb77f9a334934c646ff108 (diff)
downloadfreebsd-ports-gnome-ac9f99e39eafb4886cfd7bb2dc74414f8a86bb81.tar.gz
freebsd-ports-gnome-ac9f99e39eafb4886cfd7bb2dc74414f8a86bb81.tar.zst
freebsd-ports-gnome-ac9f99e39eafb4886cfd7bb2dc74414f8a86bb81.zip
multimedia/mencoder: add fontconfig dependency
Adding the fontconfig knob as per discussion in http://lists.freebsd.org/pipermail/freebsd-ports/2010-December/065147.html PR: 153755 Approved by: Thomas Zander <riggs@rrr.de> (maintainer), erwin (mentor)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mencoder/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index f9ba989e0e69..8876a6c286b8 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -13,6 +13,7 @@ RESTRICTED= Port has restricted dependencies
.include "${.CURDIR}/../mplayer/Makefile.shared"
OPTIONS= DEBUG "Include debug symbols in mencoder's binary" off
+OPTIONS+= FONTCONFIG "Enable fontconfig support" off
OPTIONS+= RTCPU "Allow runtime CPU detection" on
OPTIONS+= OCFLAGS "Use optimized compiler flags" on
OPTIONS+= IPV6 "Include inet6 network support" on
@@ -67,7 +68,6 @@ CONFIGURE_ARGS+= --disable-mplayer \
--disable-libdca \
--disable-x11 \
--disable-vdpau \
- --disable-fontconfig \
--disable-rtc \
--disable-arts \
--disable-esd \
@@ -86,6 +86,12 @@ ALL_TARGET= mencoder
.include "${.CURDIR}/../mplayer/Makefile.options"
+.if defined(WITH_FONTCONFIG)
+LIB_DEPENDS+= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+.else
+CONFIGURE_ARGS+= --disable-fontconfig
+.endif
+
.if defined(WITH_TWOLAME)
LIB_DEPENDS+= twolame.0:${PORTSDIR}/audio/twolame
.else