aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2013-07-07 20:28:43 +0800
committergblach <gblach@FreeBSD.org>2013-07-07 20:28:43 +0800
commitb394390d021fc2675caeaa780ea51a5fb05e0bd9 (patch)
tree5cb02cb705d991de1e74b52d0d9ba9cbb30e8c4f /multimedia
parent652e044471b8151c176425b52cbd1d4f3e122c94 (diff)
downloadfreebsd-ports-gnome-b394390d021fc2675caeaa780ea51a5fb05e0bd9.tar.gz
freebsd-ports-gnome-b394390d021fc2675caeaa780ea51a5fb05e0bd9.tar.zst
freebsd-ports-gnome-b394390d021fc2675caeaa780ea51a5fb05e0bd9.zip
- Remove USE_PYTHON knob and add python3 to BUILD_DEPENDS.
This change allows to build mplayer2 under poudriere. - Change USE_GMAKE=yes to USES=gmake Approved by: crees, tabthorpe (mentors, implicit)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer2/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/multimedia/mplayer2/Makefile b/multimedia/mplayer2/Makefile
index aa7f61821b17..f0c88830a2c3 100644
--- a/multimedia/mplayer2/Makefile
+++ b/multimedia/mplayer2/Makefile
@@ -15,13 +15,12 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
dvdread:${PORTSDIR}/multimedia/libdvdread
BUILD_DEPENDS= ffmpeg1:${PORTSDIR}/multimedia/ffmpeg1 \
+ python3:${PORTSDIR}/lang/python33 \
rst2man:${PORTSDIR}/textproc/py-docutils
RUN_DEPENDS= ffmpeg1:${PORTSDIR}/multimedia/ffmpeg1
USE_XZ= yes
-USE_GMAKE= yes
-USE_PYTHON= 3.1+
-USES= iconv ncurses
+USES= gmake iconv ncurses
HAS_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
@@ -317,9 +316,6 @@ post-patch:
-e 's|[[:space:]]gcc| ${CC}|' \
-e 's|\$$\(CC\)|${CC}|' \
-e 's|/usr/X11R6|${LOCALBASE}|'
- @${FIND} -E ${WRKSRC}/TOOLS -type f -name '*.py' -print0 | \
- ${XARGS} -0 ${REINPLACE_CMD} \
- -e 's|#!/usr/bin/env python3|#!${PYTHON_CMD}|'
@${FIND} ${WRKSRC}/DOCS/man -name "mplayer.1" | ${XARGS} ${REINPLACE_CMD} -E -e \
's|/usr/\\:local/\\:etc/\\:mplayer|${DATADIR:S/\//\/\\\:/g}|g ; \
s|/dev/\\:(dvd[[:alnum:]]*[[:>:]])|${WITH_CDROM_DEVICE:S/dev\//dev\/\\\:/}|g ; \