aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-09-05 11:50:02 +0800
committerijliao <ijliao@FreeBSD.org>2006-09-05 11:50:02 +0800
commitca7f05da01ce221c3c1ee2bdb97b25a513bb6abf (patch)
tree2e0150f461acdbcb8f3a261775cb64d68e1b11a8 /multimedia
parent0706cb641370c3ca0011995d7feb17720817a72c (diff)
downloadfreebsd-ports-gnome-ca7f05da01ce221c3c1ee2bdb97b25a513bb6abf.tar.gz
freebsd-ports-gnome-ca7f05da01ce221c3c1ee2bdb97b25a513bb6abf.tar.zst
freebsd-ports-gnome-ca7f05da01ce221c3c1ee2bdb97b25a513bb6abf.zip
add podcatcher 1.3.5
Podcast client for the command line
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/podcatcher/Makefile27
-rw-r--r--multimedia/podcatcher/distinfo3
-rw-r--r--multimedia/podcatcher/pkg-descr10
4 files changed, 41 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 60756e1bbfe5..abe7d32a756a 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -173,6 +173,7 @@
SUBDIR += p5-Video-Info
SUBDIR += p5-Video-OpenQuicktime
SUBDIR += pitivi
+ SUBDIR += podcatcher
SUBDIR += ppm2fli
SUBDIR += projectx
SUBDIR += pvr250
diff --git a/multimedia/podcatcher/Makefile b/multimedia/podcatcher/Makefile
new file mode 100644
index 000000000000..ba63d8351899
--- /dev/null
+++ b/multimedia/podcatcher/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: podcatcher
+# Date created: Sep 5, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= podcatcher
+PORTVERSION= 1.3.5
+CATEGORIES= multimedia ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Podcast client for the command line
+
+USE_RUBY= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+PLIST_FILES= bin/podcatcher
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/multimedia/podcatcher/distinfo b/multimedia/podcatcher/distinfo
new file mode 100644
index 000000000000..4d865a87af54
--- /dev/null
+++ b/multimedia/podcatcher/distinfo
@@ -0,0 +1,3 @@
+MD5 (podcatcher-1.3.5.tar.gz) = 5c3385e67da410e00bd89b879f2c408d
+SHA256 (podcatcher-1.3.5.tar.gz) = 471d1ca5862400be78c8c8d9de30969af992dde544f6c9c230a746de52d7591e
+SIZE (podcatcher-1.3.5.tar.gz) = 13198
diff --git a/multimedia/podcatcher/pkg-descr b/multimedia/podcatcher/pkg-descr
new file mode 100644
index 000000000000..948e954041fe
--- /dev/null
+++ b/multimedia/podcatcher/pkg-descr
@@ -0,0 +1,10 @@
+Armangil's podcatcher is a podcast client for the command line. It provides
+several download strategies (new shows only, back-catalog allowed, etc),
+supports BitTorrent, offers cache management, and generates playlists for MP3
+player applications.
+
+This application accepts one or more feeds (RSS or Atom) or subscription lists
+(OPML or iTunes PCAST) as argument, in the form of URLs or filenames.
+Alternatively, it tries to read one such document from the standard input.
+
+WWW: http://podcatcher.rubyforge.org/