aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-12-30 05:41:36 +0800
committermm <mm@FreeBSD.org>2010-12-30 05:41:36 +0800
commitca85b4b9640db9e455224706f0860dc746472008 (patch)
treedf68a3031b2754a527124e55632c8e34d9e0d23b /multimedia
parent77e0f0ecc9582ad0f7143dc1e2648a2580ce6476 (diff)
downloadfreebsd-ports-gnome-ca85b4b9640db9e455224706f0860dc746472008.tar.gz
freebsd-ports-gnome-ca85b4b9640db9e455224706f0860dc746472008.tar.zst
freebsd-ports-gnome-ca85b4b9640db9e455224706f0860dc746472008.zip
- Add libvdpau support to OPTIONS
PR: ports/153491 Submitted by: Bernhard Froehlich <decke@FreeBSD.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index e8c68666da4a..f76975cec9c1 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -43,6 +43,7 @@ OPTIONS= ALSA "Enable alsa input/output device" off \
SPEEX "Speex audio decoder" off \
SSSE3 "Enable ssse3 support" on \
THEORA "Theora encoder (implies OGG)" on \
+ VDPAU "Nvidia vdpau support" off \
VORBIS "Vorbis encoder via libvorbis (implies OGG)" on \
VP8 "VP8 codec via libvpx" on \
X264 "H.264 encoder" on \
@@ -271,6 +272,14 @@ CONFIGURE_ARGS+= --enable-libtheora
CONFIGURE_ARGS+= --disable-libtheora
.endif
+# vdpau
+.ifndef(WITHOUT_VDPAU)
+LIB_DEPENDS+= vdpau.1:${PORTSDIR}/multimedia/libvdpau
+CONFIGURE_ARGS+= --enable-vdpau
+.else
+CONFIGURE_ARGS+= --disable-vdpau
+.endif
+
# vorbis
.ifndef(WITHOUT_VORBIS)
LIB_DEPENDS+= vorbisenc.2:${PORTSDIR}/audio/libvorbis