aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-12-02 21:06:55 +0800
committerpav <pav@FreeBSD.org>2006-12-02 21:06:55 +0800
commitce708ddf1ce28bce0c1a8f7d3e8409e91067a6d6 (patch)
tree27ae0e917fe33eee9a9e5237975599115c3b23c5 /multimedia
parent41f7344b110013d2893645a3e1b6cf43f396ae48 (diff)
downloadfreebsd-ports-gnome-ce708ddf1ce28bce0c1a8f7d3e8409e91067a6d6.tar.gz
freebsd-ports-gnome-ce708ddf1ce28bce0c1a8f7d3e8409e91067a6d6.tar.zst
freebsd-ports-gnome-ce708ddf1ce28bce0c1a8f7d3e8409e91067a6d6.zip
- Fix runtime crash in machine readable output
PR: ports/105847 Submitted by: Ulrich Spoerlein <uspoerlein@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/lsdvd/Makefile1
-rw-r--r--multimedia/lsdvd/files/patch-ocode.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/multimedia/lsdvd/Makefile b/multimedia/lsdvd/Makefile
index bf55a4874977..a0b393553012 100644
--- a/multimedia/lsdvd/Makefile
+++ b/multimedia/lsdvd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lsdvd
PORTVERSION= 0.16
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= acidrip
diff --git a/multimedia/lsdvd/files/patch-ocode.c b/multimedia/lsdvd/files/patch-ocode.c
new file mode 100644
index 000000000000..dde616c067ce
--- /dev/null
+++ b/multimedia/lsdvd/files/patch-ocode.c
@@ -0,0 +1,12 @@
+--- ocode.c.orig Sat Nov 25 19:46:18 2006
++++ ocode.c Sat Nov 25 19:45:59 2006
+@@ -114,8 +114,7 @@
+ INDENT;
+ if (_lvl) {
+ printf(syntax->array_inner, name);
+- printf(_lvl_return[_lvl]);
+- //sprintf(_lvl_return[_lvl], syntax->return_array_inner, name);
++ _lvl_return[_lvl] = syntax->return_array_inner;
+ } else {
+ printf(syntax->array_outer, name);
+ _lvl_return[_lvl] = syntax->return_array_outer;