aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2004-03-14 12:14:20 +0800
committerlioux <lioux@FreeBSD.org>2004-03-14 12:14:20 +0800
commitde313f2fd4e45630dfef3badb8ce11fdd8f68b6e (patch)
treee3750516fdad5c0dc4002de54f3e465ff96ca45b /multimedia
parent34158b2304f79d4b947e83939fa90b381d82be1b (diff)
downloadfreebsd-ports-gnome-de313f2fd4e45630dfef3badb8ce11fdd8f68b6e.tar.gz
freebsd-ports-gnome-de313f2fd4e45630dfef3badb8ce11fdd8f68b6e.tar.zst
freebsd-ports-gnome-de313f2fd4e45630dfef3badb8ce11fdd8f68b6e.zip
o Work around compiler BUG
- Optimizations -O{1,s,2,3} work - However, lack of -O{1,s,2,3} or -O0 BREAK the build - Therefore, make sure we have AT LEAST -O and avoid -O0 PR: 52024 Submitted by: Heiner Eichmann <h.eichmann@gmx.de>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libdv/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/multimedia/libdv/Makefile b/multimedia/libdv/Makefile
index e98fbca106dc..d5b8d605f309 100644
--- a/multimedia/libdv/Makefile
+++ b/multimedia/libdv/Makefile
@@ -34,6 +34,12 @@ PORTDOCS= AUTHORS COPYING COPYRIGHT ChangeLog NEWS README \
.include <bsd.port.pre.mk>
+# XXX - work around compiler bug
+# Optimizations -O{1,s,2,3} work
+# However, lack of -O{1,s,2,3} or -O0 BREAK the build
+# Therefore, make sure we have AT LEAST -O and avoid -O0
+CONFIGURE_ENV+= CFLAGS="-O ${CFLAGS:N-O0}"
+
.ifndef(WITHOUT_SDL)
USE_SDL= sdl
CONFIGURE_ARGS+= --enable-sdl