aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-08-09 23:20:43 +0800
committerahze <ahze@FreeBSD.org>2006-08-09 23:20:43 +0800
commite06d7d2303b2726fc581ec46779c773f901d0794 (patch)
tree0738a501a3e8467ddca8bb7412ca9d52ba9e7a29 /multimedia
parentc7af2ea2216d2f3a7f050a5f8dd6431de115dc89 (diff)
downloadfreebsd-ports-gnome-e06d7d2303b2726fc581ec46779c773f901d0794.tar.gz
freebsd-ports-gnome-e06d7d2303b2726fc581ec46779c773f901d0794.tar.zst
freebsd-ports-gnome-e06d7d2303b2726fc581ec46779c773f901d0794.zip
- Chase libver bump in x264
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-plugins-x26480/Makefile2
-rw-r--r--multimedia/gstreamer-plugins80/Makefile7
-rw-r--r--multimedia/gstreamer-plugins80/Makefile.common4
3 files changed, 8 insertions, 5 deletions
diff --git a/multimedia/gstreamer-plugins-x26480/Makefile b/multimedia/gstreamer-plugins-x26480/Makefile
index c044813490f2..18490092d138 100644
--- a/multimedia/gstreamer-plugins-x26480/Makefile
+++ b/multimedia/gstreamer-plugins-x26480/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports/multimedia/gstreamer-plugins-x26480/Makefile,v 1.1 2006/01/20 02:56:07 ahze Exp $
#
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
COMMENT= Gstreamer x264 plugin
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index d9077e5ab4ee..f1cc39e0b6bc 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -3,12 +3,13 @@
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/multimedia/gstreamer-plugins80/Makefile,v 1.60 2006/04/23 22:55:30 mezz Exp $
+# $MCom: ports/multimedia/gstreamer-plugins80/Makefile,v 1.62 2006/07/17 05:15:45 ahze Exp $
#
PORTNAME= gstreamer
PORTVERSION= 0.8.12
PORTREVISION?= 2
+PORTEPOCH= 1
CATEGORIES?= multimedia audio
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://gstreamer.freedesktop.org/src/gst-plugins/
@@ -27,7 +28,7 @@ SHLIB_VERSION= 1
VERSION= 0.8
WANT_GSTREAMER= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
@@ -158,7 +159,7 @@ post-install:
. endfor
.endif
# register plugins
- -@${X11BASE}/bin/gst-register-${VERSION} \
+ -@${LOCALBASE}/bin/gst-register-${VERSION} \
--gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null
.include <bsd.port.post.mk>
diff --git a/multimedia/gstreamer-plugins80/Makefile.common b/multimedia/gstreamer-plugins80/Makefile.common
index f95a185e2718..f6371032f29b 100644
--- a/multimedia/gstreamer-plugins80/Makefile.common
+++ b/multimedia/gstreamer-plugins80/Makefile.common
@@ -1,3 +1,5 @@
+# $FreeBSD$
+# $MCom: ports/multimedia/gstreamer-plugins80/Makefile.common,v 1.33 2006/07/17 05:15:45 ahze Exp $
GST_ALL_PLUGINS= \
a52dec \
aalib \
@@ -509,7 +511,7 @@ LIB_DEPENDS+= wavpack.0:${PORTSDIR}/audio/wavpack
# x264
.if ${GST_PLUGIN}=="x264"
-LIB_DEPENDS+= x264.47:${PORTSDIR}/multimedia/x264
+LIB_DEPENDS+= x264.49:${PORTSDIR}/multimedia/x264
PLIST_FILES= ${GST_LIB_DIR}/libx264.so \
${GST_LIB_DIR}/libx264.a \
${GST_LIB_DIR}/libx264.la