aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-07-04 01:03:31 +0800
committerdanfe <danfe@FreeBSD.org>2007-07-04 01:03:31 +0800
commitedc5cac0e027b9beee807a5cf4360936484514e2 (patch)
treea8790813a7b2fb3064404e2fc0f85cc40869202f /multimedia
parentddba6f97750b7e18f109633e0189e8d000253bf3 (diff)
downloadfreebsd-ports-gnome-edc5cac0e027b9beee807a5cf4360936484514e2.tar.gz
freebsd-ports-gnome-edc5cac0e027b9beee807a5cf4360936484514e2.tar.zst
freebsd-ports-gnome-edc5cac0e027b9beee807a5cf4360936484514e2.zip
- Fix the build with GCC 4.2 [1]
- Try to pacify portlint(1) - Usual minor Makefile cleanups Reported by: pointyhat (logs) [1]
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/xmps/Makefile13
-rw-r--r--multimedia/xmps/files/patch-aa2
-rw-r--r--multimedia/xmps/files/patch-codecs::video::flx::flx_codec.h11
3 files changed, 21 insertions, 5 deletions
diff --git a/multimedia/xmps/Makefile b/multimedia/xmps/Makefile
index 564df6b7a9d7..0b3642caf7e4 100644
--- a/multimedia/xmps/Makefile
+++ b/multimedia/xmps/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: xmps
+# New ports collection makefile for: XMPS
# Date created: 15 June 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
@@ -14,8 +14,8 @@ MASTER_SITES= http://ftp.vin.bg.ac.yu/linux/mmedia/xmps/
MAINTAINER= ports@FreeBSD.org
COMMENT= X MPEG Player System - a media player with a very nice GUI
+USE_GETTEXT= yes
USE_SDL= sdl
-USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs gdkpixbuf
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+BROKEN= Does not compile on !i386
.endif
.if ${OSVERSION} >= 700042
@@ -37,6 +37,11 @@ post-patch:
s|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g'
+ 's|-lpthread|${PTHREAD_LIBS}|g'
+# Fixes for GCC 4.2
+ @${REINPLACE_CMD} -e 's|X" (mem)|m" (mem)|' \
+ ${WRKSRC}/codecs/video/mpeg3/mmx.h
+ @${REINPLACE_CMD} -e '42,44s|^static ||' \
+ ${WRKSRC}/codecs/video/mpeg3/slice.c
.include <bsd.port.post.mk>
diff --git a/multimedia/xmps/files/patch-aa b/multimedia/xmps/files/patch-aa
index baaab7875043..afe3d5cbcc1f 100644
--- a/multimedia/xmps/files/patch-aa
+++ b/multimedia/xmps/files/patch-aa
@@ -38,7 +38,7 @@ $FreeBSD$
-CFLAGS="$CFLAGS `gtk-config --cflags` -Wall -Werror"
-+CFLAGS="$CFLAGS `$GTK_CONFIG --cflags` -Wall -Werror"
++CFLAGS="$CFLAGS `$GTK_CONFIG --cflags` -Wall"
VIDEO_ADDON_PLUGIN_DIR=addons/video
diff --git a/multimedia/xmps/files/patch-codecs::video::flx::flx_codec.h b/multimedia/xmps/files/patch-codecs::video::flx::flx_codec.h
index bedd02f21154..26d3a0411e58 100644
--- a/multimedia/xmps/files/patch-codecs::video::flx::flx_codec.h
+++ b/multimedia/xmps/files/patch-codecs::video::flx::flx_codec.h
@@ -3,6 +3,17 @@ $FreeBSD$
--- codecs/video/flx/flx_codec.h.orig Wed Nov 1 20:46:14 2000
+++ codecs/video/flx/flx_codec.h Sun Feb 4 22:55:34 2001
+@@ -33,8 +33,8 @@
+ #include "config.h"
+ #endif
+
+-#define ReadU16(tmp1, tmp2) (Uint16)*(tmp1) = ((Uint8)*(tmp2+1)<<8)+(Uint8)*(tmp2);
+-#define ReadU32(tmp1, tmp2) (Uint32)*(tmp1) = (((((((Uint8)*(tmp2+3)<<8)+((Uint8)*(tmp2+2)))<<8)+((Uint8)*(tmp2+1)))<<8)+(Uint8)*(tmp2));
++#define ReadU16(tmp1, tmp2) *(tmp1) = (Uint16)((Uint8)*(tmp2+1)<<8)+(Uint8)*(tmp2)
++#define ReadU32(tmp1, tmp2) *(tmp1) = (Uint32)(((((((Uint8)*(tmp2+3)<<8)+((Uint8)*(tmp2+2)))<<8)+((Uint8)*(tmp2+1)))<<8)+(Uint8)*(tmp2))
+
+ /*
+ * includes : local
@@ -52,7 +52,7 @@
#include <stdlib.h>
#include <string.h>