aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2004-03-20 10:32:21 +0800
committerlioux <lioux@FreeBSD.org>2004-03-20 10:32:21 +0800
commitf578c3b5a8adc4f0f859ac5706d696b0c144427c (patch)
treee6cc63f0a4b1d4c69c0f7f67cb6169fcbc83f7f4 /multimedia
parent6293e1a35216b04d8206cef6209ce4b45ee97419 (diff)
downloadfreebsd-ports-gnome-f578c3b5a8adc4f0f859ac5706d696b0c144427c.tar.gz
freebsd-ports-gnome-f578c3b5a8adc4f0f859ac5706d696b0c144427c.tar.zst
freebsd-ports-gnome-f578c3b5a8adc4f0f859ac5706d696b0c144427c.zip
Add WITHOUT_ARTS knob. Furthermore, it takes precedence over WITH_ARTS
if defined at the same time PR: 62363 Submitted by: Piotr Smyrak <piotr.smyrak@heron.pl>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-plugins/Makefile15
-rw-r--r--multimedia/gstreamer-plugins80/Makefile15
2 files changed, 18 insertions, 12 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index f7f3999f2537..3bd77295be8b 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -131,8 +131,8 @@ WITH_GNOMEVFS= yes
WITH_AALIB=yes
.endif
-# arts
-.if exists(${LOCALBASE}/lib/libartsc.so.0)
+# aRts
+.if exists(${LOCALBASE}/lib/libartsc.so.0) && !defined(WITHOUT_ARTS)
WITH_ARTS=yes
.endif
@@ -294,8 +294,8 @@ CONFIGURE_ARGS+= --with-aalib-prefix=${LOCALBASE} \
PLIST_SUB+= AALIB=""
.endif
-# arts
-.ifndef(WITH_ARTS)
+# aRts
+.if (!defined(WITH_ARTS) || defined(WITHOUT_ARTS))
CONFIGURE_ARGS+= --disable-arts \
--disable-artsc \
--disable-artstest
@@ -631,9 +631,12 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_AALIB to enable aalib Video plugin'
.endif
-.ifndef(WITH_ARTS)
+.ifdef(WITH_ARTS)
@${ECHO_MSG} '===>'
- @${ECHO_MSG} '===> Define WITH_ARTS to enable arts Audio plugin'
+ @${ECHO_MSG} '===> Define WITHOUT_ARTS to disable aRts Audio plugin'
+.else
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_ARTS to enable aRts Audio plugin'
.endif
.ifndef(WITH_AVIFILE)
@${ECHO_MSG} '===>'
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index f7f3999f2537..3bd77295be8b 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -131,8 +131,8 @@ WITH_GNOMEVFS= yes
WITH_AALIB=yes
.endif
-# arts
-.if exists(${LOCALBASE}/lib/libartsc.so.0)
+# aRts
+.if exists(${LOCALBASE}/lib/libartsc.so.0) && !defined(WITHOUT_ARTS)
WITH_ARTS=yes
.endif
@@ -294,8 +294,8 @@ CONFIGURE_ARGS+= --with-aalib-prefix=${LOCALBASE} \
PLIST_SUB+= AALIB=""
.endif
-# arts
-.ifndef(WITH_ARTS)
+# aRts
+.if (!defined(WITH_ARTS) || defined(WITHOUT_ARTS))
CONFIGURE_ARGS+= --disable-arts \
--disable-artsc \
--disable-artstest
@@ -631,9 +631,12 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_AALIB to enable aalib Video plugin'
.endif
-.ifndef(WITH_ARTS)
+.ifdef(WITH_ARTS)
@${ECHO_MSG} '===>'
- @${ECHO_MSG} '===> Define WITH_ARTS to enable arts Audio plugin'
+ @${ECHO_MSG} '===> Define WITHOUT_ARTS to disable aRts Audio plugin'
+.else
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_ARTS to enable aRts Audio plugin'
.endif
.ifndef(WITH_AVIFILE)
@${ECHO_MSG} '===>'