aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-02-13 18:39:13 +0800
committerak <ak@FreeBSD.org>2013-02-13 18:39:13 +0800
commitfe19760d77db8d7803f5ee5f394bad61353d9d3d (patch)
tree066e79d17da6078ddb3d8ba1beeb7d41dbe7a10d /multimedia
parent36285e37c755b4a28476a7e21719da49d9687b03 (diff)
downloadfreebsd-ports-gnome-fe19760d77db8d7803f5ee5f394bad61353d9d3d.tar.gz
freebsd-ports-gnome-fe19760d77db8d7803f5ee5f394bad61353d9d3d.tar.zst
freebsd-ports-gnome-fe19760d77db8d7803f5ee5f394bad61353d9d3d.zip
- Fix build with clang [1]
- Convert Makefile headers to new style PR: ports/171707 [1] Submitted by: anonymous <anonymous@gmail.com> Approved by: Thomas Zander <thomas.e.zander@googlemail.com> (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile8
-rw-r--r--multimedia/mplayer/Makefile.options2
-rw-r--r--multimedia/mplayer/Makefile.shared1
3 files changed, 4 insertions, 7 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index de99af218241..2404bea326cc 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mplayer
-# Date created: 10 August 2001
-# Whom: Thomas E. Zander
-# with lots of help from Vladimir Kushnir
+# Created by: Thomas E. Zander with help from Vladimir Kushnir
# $FreeBSD$
-#
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
@@ -96,7 +92,7 @@ CONFIGURE_ARGS+= --disable-directfb \
# Fix a problem with unknown assembly opcodes in embedded ffmpeg
.if ${ARCH} == "ppc"
-CONFIGURE_ARGS+= --disable-asm
+CONFIGURE_ARGS+= --disable-asm
.endif
.include "${.CURDIR}/Makefile.options"
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index b6f249be0fe7..a20030df1bf0 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -52,7 +52,7 @@ CFLAGS+= -O3 -fomit-frame-pointer -ffast-math
.endif #WITH_DEBUG
#Supported architectures for clang
-.if ${ARCH} == "amd64"
+.if ${ARCH} == "i386" || ${ARCH} == "amd64"
MPLAYER_CLANG_SUPPORTED_ARCH= yes
.endif
diff --git a/multimedia/mplayer/Makefile.shared b/multimedia/mplayer/Makefile.shared
index 0db41a13700a..4e6d5ab418c2 100644
--- a/multimedia/mplayer/Makefile.shared
+++ b/multimedia/mplayer/Makefile.shared
@@ -39,6 +39,7 @@ CONFIGURE_ARGS= --cc="${CC}" \
--disable-liba52 \
--disable-alsa \
--disable-libbs2b \
+ --disable-mp3lib \
--enable-ass-internal
WANT_GNOME= yes