aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2005-12-25 00:44:07 +0800
committeradamw <adamw@FreeBSD.org>2005-12-25 00:44:07 +0800
commit43cfa9ab66a4b093d32b4a3f3dab6479176264ca (patch)
tree451a325692612bf2fe80bc264ea0479bc911d995 /multimedia
parent54b390b9a2e8485639dfeeffb2857720a3230a15 (diff)
downloadfreebsd-ports-gnome-43cfa9ab66a4b093d32b4a3f3dab6479176264ca.tar.gz
freebsd-ports-gnome-43cfa9ab66a4b093d32b4a3f3dab6479176264ca.tar.zst
freebsd-ports-gnome-43cfa9ab66a4b093d32b4a3f3dab6479176264ca.zip
Step on kwm's toes and add PTHREAD_CFLAGS/LIBS to the
CONFIGURE_ENV to fix the build with the new libtool. There may be a better fix, but in the meantime this will allow the port to build. Please feel free to back this out and kick me if you want to, kwm.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer/Makefile4
-rw-r--r--multimedia/gstreamer80/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index 688d212f83eb..ba7d1bf9994e 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -33,8 +33,8 @@ CONFIGURE_ARGS= --disable-tests \
--disable-examples \
--disable-docs-build \
--disable-failing-tests
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
PLIST_SUB= \
VERSION="${GST_VERSION}" \
SHLIB_VERSION="${SHLIB_VERSION}" \
diff --git a/multimedia/gstreamer80/Makefile b/multimedia/gstreamer80/Makefile
index 688d212f83eb..ba7d1bf9994e 100644
--- a/multimedia/gstreamer80/Makefile
+++ b/multimedia/gstreamer80/Makefile
@@ -33,8 +33,8 @@ CONFIGURE_ARGS= --disable-tests \
--disable-examples \
--disable-docs-build \
--disable-failing-tests
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
PLIST_SUB= \
VERSION="${GST_VERSION}" \
SHLIB_VERSION="${SHLIB_VERSION}" \