aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-11-01 21:02:13 +0800
committerjylefort <jylefort@FreeBSD.org>2005-11-01 21:02:13 +0800
commit4c1dcd3d243a5f22be528ece98d41a85d0b536cf (patch)
treed90455301cab343a2013838f0a3fe0c635700818 /multimedia
parent88671b62d5b331c50f8b3de942dac52369548133 (diff)
downloadfreebsd-ports-gnome-4c1dcd3d243a5f22be528ece98d41a85d0b536cf.tar.gz
freebsd-ports-gnome-4c1dcd3d243a5f22be528ece98d41a85d0b536cf.tar.zst
freebsd-ports-gnome-4c1dcd3d243a5f22be528ece98d41a85d0b536cf.zip
Add streamanalyze.
StreamAnalyze is a little helper for people using StreamDVD to backup movies. Giving the video/audio/subpicture tracks you want to save, StreamAnalyze will calculate if the backup would fit on a dvd-r and, if not, print a shrink factor to reduce the video size. Before using StreamAnalyze you should call 'lsdvd' or 'tcprobe' to get an overview of what is available on the video DVD you want to backup. WWW: http://www.badabum.de/streamdvd.html PR: ports/88248 Submitted by: Heiner Eichmann <h.eichmann@gmx.de>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/streamanalyze/Makefile35
-rw-r--r--multimedia/streamanalyze/distinfo2
-rw-r--r--multimedia/streamanalyze/pkg-descr9
4 files changed, 47 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 11241105be67..f0b5cbaba604 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -153,6 +153,7 @@
SUBDIR += smpeg-xmms
SUBDIR += spigot
SUBDIR += splitmpg
+ SUBDIR += streamanalyze
SUBDIR += streamdvd
SUBDIR += subconv
SUBDIR += subtitleripper
diff --git a/multimedia/streamanalyze/Makefile b/multimedia/streamanalyze/Makefile
new file mode 100644
index 000000000000..3fe9556909f3
--- /dev/null
+++ b/multimedia/streamanalyze/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: streamanalyze
+# Date created: 2005-10-30
+# Whom: Heiner Eichmann
+#
+# $FreeBSD$
+#
+
+PORTNAME= streamanalyze
+PORTVERSION= 0.4
+CATEGORIES= multimedia
+MASTER_SITES= http://www.badabum.de/down/
+
+MAINTAINER= h.eichmann@gmx.de
+COMMENT= Shrink-factor calculator for StreamDVD
+
+LIB_DEPENDS= dvdread:${PORTSDIR}/multimedia/libdvdread
+
+WRKSRC= ${WRKDIR}/StreamAnalyze
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/streamanalyze
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc -g -Wall|${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/#include <getopt\.h>/ d' ${WRKSRC}/streamanalyze.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/streamanalyze ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/streamanalyze/distinfo b/multimedia/streamanalyze/distinfo
new file mode 100644
index 000000000000..5d625993e76c
--- /dev/null
+++ b/multimedia/streamanalyze/distinfo
@@ -0,0 +1,2 @@
+MD5 (streamanalyze-0.4.tar.gz) = c17b27f0b92c0478e63e067d8f8e359c
+SIZE (streamanalyze-0.4.tar.gz) = 13287
diff --git a/multimedia/streamanalyze/pkg-descr b/multimedia/streamanalyze/pkg-descr
new file mode 100644
index 000000000000..5eacf4e640e6
--- /dev/null
+++ b/multimedia/streamanalyze/pkg-descr
@@ -0,0 +1,9 @@
+StreamAnalyze is a little helper for people using StreamDVD to backup movies.
+Giving the video/audio/subpicture tracks you want to save, StreamAnalyze will
+calculate if the backup would fit on a dvd-r and, if not, print a shrink
+factor to reduce the video size.
+
+Before using StreamAnalyze you should call 'lsdvd' or 'tcprobe' to get an
+overview of what is available on the video DVD you want to backup.
+
+WWW: http://www.badabum.de/streamdvd.html