aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-12-19 18:47:01 +0800
committerlawrance <lawrance@FreeBSD.org>2005-12-19 18:47:01 +0800
commitc78f516598771eb12c3c311459969c9ba33f0de6 (patch)
tree836b9d700005986b6b236bd122a12000b38da2fd /multimedia
parent8367d494c8a0611cd86543833ce560439045b358 (diff)
downloadfreebsd-ports-gnome-c78f516598771eb12c3c311459969c9ba33f0de6.tar.gz
freebsd-ports-gnome-c78f516598771eb12c3c311459969c9ba33f0de6.tar.zst
freebsd-ports-gnome-c78f516598771eb12c3c311459969c9ba33f0de6.zip
Only enable the plugins that are actually going to be built.
Tweak for artsd and gnomevfs, since their plugin knobs are different to the name specified by the ports. PR: ports/79386 Submitted by: NIIMI Satoshi <sa2c@sa2c.net> Approved by: kwm (maintainer, timeout 2 months) Tested by: successful tinderbox run on */gstreamer-plugins*
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common4
-rw-r--r--multimedia/gstreamer-plugins80/Makefile.common4
2 files changed, 6 insertions, 2 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 1545f5680755..b88204070b2f 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -123,7 +123,7 @@ COMMENT= Gstreamer ${GST_PLUGIN} plugin
# Enable the right plugin
-CONFIGURE_ARGS:=${CONFIGURE_ARGS:S|--disable-${p}|--enable-${p}|}
+CONFIGURE_ARGS:=${CONFIGURE_ARGS:S|--disable-${GST_PLUGIN}|--enable-${GST_PLUGIN}|}
# Build/Install directory. defaults to ext/${GST_PLUGIN}
# few plugins are in sys/
@@ -146,6 +146,7 @@ PLIST_FILES= ${GST_LIB_DIR}/libgstaasink.so
.if ${GST_PLUGIN}=="artsd"
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
GST_PLIST_SUFFIX= sink
+CONFIGURE_ARGS+=--enable-artsc
.endif
# cairo
@@ -218,6 +219,7 @@ GST_PLUGIN_DIR= ext/gdk_pixbuf
# gnomevfs
.if ${GST_PLUGIN}=="gnomevfs"
USE_GNOME+= gnomevfs2
+CONFIGURE_ARGS+=--enable-gnome_vfs
.endif
# gsm
diff --git a/multimedia/gstreamer-plugins80/Makefile.common b/multimedia/gstreamer-plugins80/Makefile.common
index 1545f5680755..b88204070b2f 100644
--- a/multimedia/gstreamer-plugins80/Makefile.common
+++ b/multimedia/gstreamer-plugins80/Makefile.common
@@ -123,7 +123,7 @@ COMMENT= Gstreamer ${GST_PLUGIN} plugin
# Enable the right plugin
-CONFIGURE_ARGS:=${CONFIGURE_ARGS:S|--disable-${p}|--enable-${p}|}
+CONFIGURE_ARGS:=${CONFIGURE_ARGS:S|--disable-${GST_PLUGIN}|--enable-${GST_PLUGIN}|}
# Build/Install directory. defaults to ext/${GST_PLUGIN}
# few plugins are in sys/
@@ -146,6 +146,7 @@ PLIST_FILES= ${GST_LIB_DIR}/libgstaasink.so
.if ${GST_PLUGIN}=="artsd"
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
GST_PLIST_SUFFIX= sink
+CONFIGURE_ARGS+=--enable-artsc
.endif
# cairo
@@ -218,6 +219,7 @@ GST_PLUGIN_DIR= ext/gdk_pixbuf
# gnomevfs
.if ${GST_PLUGIN}=="gnomevfs"
USE_GNOME+= gnomevfs2
+CONFIGURE_ARGS+=--enable-gnome_vfs
.endif
# gsm