aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-09 23:55:12 +0800
committermiwi <miwi@FreeBSD.org>2007-03-09 23:55:12 +0800
commit027ae64e9987e53823075f677aafbe44ecde3c62 (patch)
treeb7a2dc79896259ff9c203d020ce51e19a2bc2898 /multimedia
parent91d97cb5538aae86a4107c07e17e7c810fdae41b (diff)
downloadfreebsd-ports-gnome-027ae64e9987e53823075f677aafbe44ecde3c62.tar.gz
freebsd-ports-gnome-027ae64e9987e53823075f677aafbe44ecde3c62.tar.zst
freebsd-ports-gnome-027ae64e9987e53823075f677aafbe44ecde3c62.zip
- Fix Buffer overflow vulnerability
- Bump PORTREVISION Approved by: simon (secteam) Obtained from: mplayer svn Security: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1246
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/files/patch-DMO_VideoDecoder.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 3c1897309f9d..2d291744027a 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -84,7 +84,7 @@
PORTNAME= mplayer
PORTVERSION= 0.99.10
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia audio
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
diff --git a/multimedia/mplayer/files/patch-DMO_VideoDecoder.c b/multimedia/mplayer/files/patch-DMO_VideoDecoder.c
new file mode 100644
index 000000000000..94878a0ce528
--- /dev/null
+++ b/multimedia/mplayer/files/patch-DMO_VideoDecoder.c
@@ -0,0 +1,10 @@
+--- loader/dmo/DMO_VideoDecoder.c 2007/01/26 09:21:22 22019
++++ loader/dmo/DMO_VideoDecoder.c 2007/02/11 17:55:49 22204
+@@ -119,6 +119,7 @@
+
+ this->iv.m_bh = malloc(bihs);
+ memcpy(this->iv.m_bh, format, bihs);
++ this->iv.m_bh->biSize = bihs;
+
+ this->iv.m_State = STOP;
+ //this->iv.m_pFrame = 0;