aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-03-27 03:17:59 +0800
committernox <nox@FreeBSD.org>2011-03-27 03:17:59 +0800
commit27011e60c60efdcae8e2eb00963c810270aaa1e5 (patch)
treeaf52535a32652c6d8d6cc470b2e4330e90b6ea2d /multimedia
parent677cc92aebdaaa4f85e33b1711ea8ead63acf7d3 (diff)
downloadfreebsd-ports-gnome-27011e60c60efdcae8e2eb00963c810270aaa1e5.tar.gz
freebsd-ports-gnome-27011e60c60efdcae8e2eb00963c810270aaa1e5.tar.zst
freebsd-ports-gnome-27011e60c60efdcae8e2eb00963c810270aaa1e5.zip
http://www.linuxtv.org/vdrwiki/index.php/Femon-plugin
DVB Frontend Status Monitor is a VDR plugin that displays some signal information parameters of the current tuned channel on OSD. You can zap through all your channels and the plugin should be monitoring always the right frontend. The transponder and stream information are also available in advanced display modes. WWW: http://www.saunalahti.fi/~rahrenbe/vdr/femon/
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/vdr-plugin-femon/Makefile35
-rw-r--r--multimedia/vdr-plugin-femon/distinfo2
-rw-r--r--multimedia/vdr-plugin-femon/files/patch-Makefile9
-rw-r--r--multimedia/vdr-plugin-femon/files/patch-femon-1.7.7.patch16
-rw-r--r--multimedia/vdr-plugin-femon/pkg-descr9
-rw-r--r--multimedia/vdr-plugin-femon/pkg-plist11
7 files changed, 83 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 0fb8ccc7941b..8ced98e27aca 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -337,6 +337,7 @@
SUBDIR += vdr
SUBDIR += vdr-plugin-control
SUBDIR += vdr-plugin-epgsearch
+ SUBDIR += vdr-plugin-femon
SUBDIR += vic
SUBDIR += vlc
SUBDIR += vodcatcher
diff --git a/multimedia/vdr-plugin-femon/Makefile b/multimedia/vdr-plugin-femon/Makefile
new file mode 100644
index 000000000000..4a9674e2e0de
--- /dev/null
+++ b/multimedia/vdr-plugin-femon/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: vdr-plugin-femon
+# Date created: Wed Apr 14 18:11:42 CEST 2010
+# Whom: Juergen Lock <nox@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdr-plugin-femon
+PORTVERSION= 1.7.7
+PORTREVISION= 6
+CATEGORIES= multimedia
+MASTER_SITES= http://www.saunalahti.fi/~rahrenbe/vdr/femon/files/
+DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video Disk Recorder - frontend monitor plugin
+
+PATCH_STRIP= -p1
+HAVE_CONFIGURE= yes
+PORTDOCS= COPYING README
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION}
+
+.include "${.CURDIR}/../vdr/Makefile.plugins"
+
+post-patch: post-patch-plugin
+
+post-install: post-install-pluginlocales
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-femon/distinfo b/multimedia/vdr-plugin-femon/distinfo
new file mode 100644
index 000000000000..2e7e9b9a1aec
--- /dev/null
+++ b/multimedia/vdr-plugin-femon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vdr/vdr-femon-1.7.7.tgz) = 737a62d735da404e6063b26bbaea598c1a615542e4fc85afa7db84fd2b4286da
+SIZE (vdr/vdr-femon-1.7.7.tgz) = 71864
diff --git a/multimedia/vdr-plugin-femon/files/patch-Makefile b/multimedia/vdr-plugin-femon/files/patch-Makefile
new file mode 100644
index 000000000000..d7e349515791
--- /dev/null
+++ b/multimedia/vdr-plugin-femon/files/patch-Makefile
@@ -0,0 +1,9 @@
+--- femon-1.7.7/Makefile.orig
++++ femon-1.7.7/Makefile
+@@ -131,3 +134,6 @@ dist: clean
+
+ clean:
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot
++
++install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
diff --git a/multimedia/vdr-plugin-femon/files/patch-femon-1.7.7.patch b/multimedia/vdr-plugin-femon/files/patch-femon-1.7.7.patch
new file mode 100644
index 000000000000..ee2f24d244ed
--- /dev/null
+++ b/multimedia/vdr-plugin-femon/files/patch-femon-1.7.7.patch
@@ -0,0 +1,16 @@
+diff -ur orig/femon-1.7.7/Makefile femon-1.7.7/Makefile
+--- orig/femon-1.7.7/Makefile 2010-03-05 03:20:00.000000000 +0100
++++ femon-1.7.7/Makefile 2010-03-05 17:55:59.000000000 +0100
+@@ -115,7 +115,11 @@
+ ifndef FEMON_DEBUG
+ @$(STRIP) $@
+ endif
++ifdef FREEBSD
++ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
++else
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
++endif
+
+ dist: clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+Only in femon-1.7.7: Makefile.orig
diff --git a/multimedia/vdr-plugin-femon/pkg-descr b/multimedia/vdr-plugin-femon/pkg-descr
new file mode 100644
index 000000000000..63aacddd78ba
--- /dev/null
+++ b/multimedia/vdr-plugin-femon/pkg-descr
@@ -0,0 +1,9 @@
+http://www.linuxtv.org/vdrwiki/index.php/Femon-plugin
+
+DVB Frontend Status Monitor is a VDR plugin that displays some signal
+information parameters of the current tuned channel on OSD. You can zap
+through all your channels and the plugin should be monitoring always the
+right frontend. The transponder and stream information are also available
+in advanced display modes.
+
+WWW: http://www.saunalahti.fi/~rahrenbe/vdr/femon/
diff --git a/multimedia/vdr-plugin-femon/pkg-plist b/multimedia/vdr-plugin-femon/pkg-plist
new file mode 100644
index 000000000000..3e66a6b0b213
--- /dev/null
+++ b/multimedia/vdr-plugin-femon/pkg-plist
@@ -0,0 +1,11 @@
+lib/vdr/libvdr-femon.so.1.7.17
+%%NLS%%share/locale/de_DE/LC_MESSAGES/vdr-femon.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/vdr-femon.mo
+%%NLS%%share/locale/et_EE/LC_MESSAGES/vdr-femon.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/vdr-femon.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/vdr-femon.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/vdr-femon.mo
+%%NLS%%share/locale/lt_LT/LC_MESSAGES/vdr-femon.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/vdr-femon.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/vdr-femon.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/vdr-femon.mo