aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-26 20:35:50 +0800
committerbapt <bapt@FreeBSD.org>2013-04-26 20:35:50 +0800
commit3b719f87a14768433dc0cd06f301eeaf9c02fa43 (patch)
tree94d53c5c905021f480b1c80529f6919181c4c73b /multimedia
parent6ed47115f3cf9c141188528e8863513cfade4cd8 (diff)
downloadfreebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.tar.gz
freebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.tar.zst
freebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.zip
Remove USE_CDRTOOLS from bsd.port.mk
This macros has been useless since cdrtools-cjk port has gone. This macros also lead to badly handled dependencies assuming that the dependency on cdrtools was most BUILD and RUN dependency. While most of the time it is simply a RUN dependency and sometime a build one. While here: - Trim some headers - Convert some ports to optionsng - Convert some ports to USES= gettext
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/2mandvd/Makefile4
-rw-r--r--multimedia/devede/Makefile43
-rw-r--r--multimedia/dvd-slideshow/Makefile47
-rw-r--r--multimedia/dvdrip/Makefile4
-rw-r--r--multimedia/dvdstyler/Makefile4
-rw-r--r--multimedia/kdenlive/Makefile9
-rw-r--r--multimedia/lives/Makefile4
-rw-r--r--multimedia/qdvdauthor/Makefile73
-rw-r--r--multimedia/tovid/Makefile8
9 files changed, 70 insertions, 126 deletions
diff --git a/multimedia/2mandvd/Makefile b/multimedia/2mandvd/Makefile
index 82c1ccf4cb83..8c8149d842a8 100644
--- a/multimedia/2mandvd/Makefile
+++ b/multimedia/2mandvd/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= sox:${PORTSDIR}/audio/sox \
tcprobe:${PORTSDIR}/multimedia/transcode \
xine:${PORTSDIR}/multimedia/xine \
bash:${PORTSDIR}/shells/bash \
- growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
+ growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -34,7 +35,6 @@ USE_QT4= corelib gui opengl \
USE_GL= glu
USE_SDL= sdl
USE_PERL5_RUN= yes
-USE_CDRTOOLS= yes
USE_GMAKE= yes
MAKE_ENV= QTDIR="${QT_PREFIX}"
MAKE_JOBS_SAFE= yes
diff --git a/multimedia/devede/Makefile b/multimedia/devede/Makefile
index 95faa1d3e744..af9e30e89033 100644
--- a/multimedia/devede/Makefile
+++ b/multimedia/devede/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devede
-# Date created: 2007-06-20
-# Whom: Lars Engels <lars.engels@0x20.net>
-#
+# Created by: Lars Engels <lars.engels@0x20.net>
# $FreeBSD$
-#
PORTNAME= devede
DISTVERSION= 3.23.0
@@ -17,43 +13,40 @@ COMMENT= Create video DVDs, VCDs, sVCDs, or CVDs from any number of video files
RUN_DEPENDS= ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
mencoder:${PORTSDIR}/multimedia/mencoder \
spumux:${PORTSDIR}/multimedia/dvdauthor \
- vcdimager:${PORTSDIR}/multimedia/vcdimager
+ vcdimager:${PORTSDIR}/multimedia/vcdimager \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
USE_BZIP2= yes
USE_GNOME= pygtk2
USE_ICONV= yes
USE_PYTHON= yes
-USE_CDRTOOLS= yes
NO_BUILD= yes
-OPTIONS= IBUS "Enable iBus support" on \
- PSYCO "Enable devel/py-psyco optimization support" off
+OPTIONS_DEFINE= IBUS NLS
+OPTIONS_DEFINE_i386= PSYCO
+OPTIONS_DEFAULT= IBUS
+IBUS_DESC= iBus support
+PSYCO_DESC= devel/py-psyco optimization support
DEJAVU_FONTSDIR= ${LOCALBASE}/lib/X11/fonts/dejavu
DEJAVU_FONTFILE= ${DEJAVU_FONTSDIR}/DejaVuSans.ttf
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${ARCH} != "i386"
-.undef WITH_PSYCO
-
-WITHOUT_PSYCO= yes
-.endif
-
-.if !defined(WITHOUT_IBUS)
+.if ${PORT_OPTIONS:MIBUS}
RUN_DEPENDS+= ibus-daemon:${PORTSDIR}/textproc/ibus
.endif
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
.endif
PORTDOCS= *
-.if defined(WITH_PSYCO)
+.if ${PORT_OPTIONS:MPSYCO}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
EXTRA_PATCHES+= ${FILESDIR}/extra-psyco-patch-devede.py
.endif
@@ -100,7 +93,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/devede.svg ${PREFIX}/share/pixmaps
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
@${INSTALL_DATA} ${WRKSRC}/po/ca.mo ${PREFIX}/share/locale/ca/LC_MESSAGES/devede.mo
@${INSTALL_DATA} ${WRKSRC}/po/cs_CZ.mo ${PREFIX}/share/locale/cs/LC_MESSAGES/devede.mo
@${INSTALL_DATA} ${WRKSRC}/po/da.mo ${PREFIX}/share/locale/da/LC_MESSAGES/devede.mo
@@ -124,9 +117,9 @@ do-install:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/html
@${INSTALL_DATA} ${WRKSRC}/docs/html/* ${DOCSDIR}/html
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/dvd-slideshow/Makefile b/multimedia/dvd-slideshow/Makefile
index 9d7a08103fb9..808482a9e522 100644
--- a/multimedia/dvd-slideshow/Makefile
+++ b/multimedia/dvd-slideshow/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dvd-slideshow
-# Date created: 2005-02-16
-# Whom: Phil Oleson <oz@nixil.net>
-#
+# Created by: Phil Oleson <oz@nixil.net>
# $FreeBSD$
-#
PORTNAME= dvd-slideshow
PORTVERSION= 0.8.2
@@ -25,18 +21,17 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
jhead:${PORTSDIR}/graphics/jhead \
flvtool2:${PORTSDIR}/multimedia/ruby-flvtool2 \
- ${LOCALBASE}/lib/X11/fonts/urwfonts-ttf/README:${PORTSDIR}/x11-fonts/urwfonts-ttf
+ ${LOCALBASE}/lib/X11/fonts/urwfonts-ttf/README:${PORTSDIR}/x11-fonts/urwfonts-ttf \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-2
NO_BUILD= yes
-USE_CDRTOOLS= yes
DATADIR= ${PREFIX}/share/apps/${PORTNAME}
-OPTIONS= LAME "Optional mp3 audio support" off \
- THEMES "Optional themes" off \
- TOOLAME "Faster Optional mp3 audio support" off \
- VORBISTOOLS "Optional ogg vorbis audio support" off
+OPTIONS_DEFINE= LAME THEMES TOOLAME VORBIS
+THEMES_DESC= Optional themes
+TOOLAME_DESC= Faster Optional mp3 audio support
MAN1= dvd-slideshow.1 \
dvd-menu.1 \
@@ -44,35 +39,25 @@ MAN1= dvd-slideshow.1 \
gallery1-to-slideshow.1 \
jigl2slideshow.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if exists(${LOCALBASE}/bin/lame)
-WITH_LAME=yes
-.endif
-.if exists(${LOCALBASE}/bin/oggdec)
-WITH_VORBISTOOLS=yes
-.endif
-.if exists(${LOCALBASE}/bin/toolame)
-WITH_TOOLAME=yes
-.endif
-
-.if defined(WITH_LAME)
+.if ${PORT_OPTIONS:MLAME}
RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
.endif
-.if defined(WITH_VORBISTOOLS)
+.if ${PORT_OPTIONS:MVORBISTOOLS}
RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
.endif
-.if defined(WITH_TOOLAME)
+.if ${PORT_OPTIONS:MTOOLAME}
RUN_DEPENDS+= toolame:${PORTSDIR}/audio/toolame
.endif
-.if defined(WITH_THEMES)
+.if ${PORT_OPTIONS:MTHEMES}
DISTFILES+= ${PORTNAME}-themes-${THEMEVERSION}-1${EXTRACT_SUFX}:themes
WRKSRC2= ${WRKDIR}/${PORTNAME}-themes-${THEMEVERSION}-1
PLIST_SUB+= NOTHEMES=""
.else
PLIST_SUB+= NOTHEMES="@comment "
.endif
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PLIST_SUB+= NOPORTDOCS="@comment "
.else
PLIST_SUB+= NOPORTDOCS=""
@@ -84,7 +69,7 @@ post-patch:
s|/usr/share/fonts/|${LOCALBASE}/lib/X11/fonts/|g ; \
s|seq |seq2 |g' \
${WRKSRC}/${FILE}
-.ifdef(WITH_THEMES)
+.if ${PORT_OPTIONS:MTHEMES}
@${REINPLACE_CMD} -e 's|/opt/dvd-slideshow/themes|${DATADIR}/themes|g' \
${WRKSRC}/${FILE}
.endif
@@ -99,7 +84,7 @@ do-install:
.for FILE in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/man/${FILE} ${PREFIX}/man/man1
.endfor
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} "Installing doc files."
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/dvd-slideshowrc ${DOCSDIR}
@@ -107,10 +92,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
.endfor
.endif
-.ifdef(WITH_THEMES)
+.if ${PORT_OPTIONS:MTHEMES}
@${ECHO_MSG} "Installing theme files."
${MKDIR} ${DATADIR}/themes
cd ${WRKSRC2} && ${FIND} * | ${CPIO} -dpmu -R ${BINOWN}:${BINGRP} --quiet ${DATADIR}/themes
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/dvdrip/Makefile b/multimedia/dvdrip/Makefile
index abf8d26e5e91..af7dffd87cf3 100644
--- a/multimedia/dvdrip/Makefile
+++ b/multimedia/dvdrip/Makefile
@@ -26,7 +26,8 @@ RUN_DEPENDS+= cdrdao:${PORTSDIR}/sysutils/cdrdao \
transcode:${PORTSDIR}/multimedia/transcode \
vcdimager:${PORTSDIR}/multimedia/vcdimager \
rar:${PORTSDIR}/archivers/rar \
- ${LOCALBASE}/sbin/fping:${PORTSDIR}/net/fping
+ ${LOCALBASE}/sbin/fping:${PORTSDIR}/net/fping \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
OPTIONS_DEFINE= VORBIS SUBTITLE
OPTIONS_DEFAULT= VORBIS SUBTITLE
@@ -34,7 +35,6 @@ SUBTITLE_DESC= Enable support for getting subtitles
PERL_CONFIGURE= yes
CONFIGURE_ENV= SKIP_UNPACK_REQUIRED_MODULES=1
-USE_CDRTOOLS= yes
USES= gettext
MAKE_JOBS_UNSAFE= yes
diff --git a/multimedia/dvdstyler/Makefile b/multimedia/dvdstyler/Makefile
index 6f4fafa5d9b3..cb481a832a9e 100644
--- a/multimedia/dvdstyler/Makefile
+++ b/multimedia/dvdstyler/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= wxsvg>=1.1.13:${PORTSDIR}/graphics/wxsvg \
dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
mplex:${PORTSDIR}/multimedia/mjpegtools \
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
- zip:${PORTSDIR}/archivers/zip
+ zip:${PORTSDIR}/archivers/zip \
+ mkisofs:${PORTSDIR}/sysutils/cdrtools
OPTIONS_DEFINE= GNOME DOCS
@@ -35,7 +36,6 @@ USE_WX= 2.8
WX_COMPS= wx svg
WX_CONF_ARGS= absolute
USE_GNOME= desktopfileutils
-USE_CDRTOOLS= yes # dvdstyler needs mkisofs
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBAV_CFLAGS="${LIBAV_CFLAGS}" LIBAV_LIBS="${LIBAV_LIBS}" \
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index 9de097d665ca..9c8e635b2054 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: kdenlive
-# Date created: 15 October 2008
-# Whom: Alberto Villa <villa.alberto@gmail.com>
-#
+# Created by: Alberto Villa <villa.alberto@gmail.com>
# $FreeBSD$
PORTNAME= kdenlive
@@ -41,8 +38,8 @@ OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDVDWIZARD}
-RUN_DEPENDS+= dvdauthor:${PORTSDIR}/multimedia/dvdauthor
-USE_CDRTOOLS= yes
+RUN_DEPENDS+= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
.endif
.if ${PORT_OPTIONS:MFREI0R}
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index c0cdc5cb8a66..cd75c6c63933 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -38,7 +38,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/analyseplugin:${PORTSDIR}/audio/ladspa \
ogmmerge:${PORTSDIR}/multimedia/ogmtools \
transcode:${PORTSDIR}/multimedia/transcode \
x264:${PORTSDIR}/multimedia/x264 \
- xmms:${PORTSDIR}/multimedia/xmms
+ xmms:${PORTSDIR}/multimedia/xmms \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
WRKSRC= ${WRKDIR}/${DISTNAME:L}
@@ -48,7 +49,6 @@ GNU_CONFIGURE= yes
USE_CSTD= gnu89
USE_PYTHON= yes
USE_PERL5= yes
-USE_CDRTOOLS= yes
USE_GHOSTSCRIPT_RUN= yes
USE_GNOME= gtk20
USE_LDCONFIG= yes
diff --git a/multimedia/qdvdauthor/Makefile b/multimedia/qdvdauthor/Makefile
index b4e3d62ff858..27d28e2672f5 100644
--- a/multimedia/qdvdauthor/Makefile
+++ b/multimedia/qdvdauthor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qdvdauthor
-# Date created: 05/07/04
-# Whom: oz@nixil.net
-#
+# Created by: oz@nixil.net
# $FreeBSD$
-#
PORTNAME= qdvdauthor
PORTVERSION= 1.1.0
@@ -57,69 +53,46 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --qt-dir=${LOCALBASE} --with-qt-lib=qt-mt \
--build-qslideshow --build-qplayer
NO_BUILD= yes
-OPTIONS= NETPBM "Create mpeg2 streams for movie menus" on \
- MJPEGTOOLS "Convert background images into mpeg2 movie" on \
- CDRTOOLS "Create iso images of DVD on the Hard Drive" on \
- TRANSCODE "Support for movie format conversion" on \
- DVDRWTOOLS "Optional DVD recording/burning prog" off \
- MPLAYER "Optional support for mplayer playback" off \
- TOOLAME "Optional support for audio conversion" off \
- MCTOOLAME "Optional support for audio conversion" off
+OPTIONS_DEFINE= NETPBM MJPEGTOOLS CDRTOOLS TRANSCODE DVDRWTOOLS MPLAYER TOOLAME MCTOOLAME
+OPTIONS_DEFAULT= NETPBM MJPEGTOOLS CDRTOOLS TRANSCODE
+NETPBM_DESC= Create mpeg2 streams for movie menus
+MJPEGTOOLS_DESC= Convert background images into mpeg2 movie
+CDRTOOLS_DESC= Create iso images of DVD on the Hard Drive
+TRANSCODE_DESC= Support for movie format conversion
+DVDRWTOOLS_DESC= Optional DVD recording/burning prog
+MPLAYER_DESC= Optional support for mplayer playback
+TOOLAME_DESC= Optional support for audio conversion
+MCTOOLAME_DESC= Optional support for audio conversion
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if exists(${LOCALBASE}/bin/pngtopnm)
-WITH_NETPBM=yes
-.endif
-.if exists(${LOCALBASE}/bin/mpeg2enc)
-WITH_MJPEGTOOLS=yes
-.endif
-.if exists(${LOCALBASE}/bin/mkisofs)
-WITH_CDRTOOLS=yes
-.endif
-.if exists(${LOCALBASE}/bin/growisofs)
-WITH_DVDRWTOOLS=yes
-.endif
-.if exists(${LOCALBASE}/bin/mplayer)
-WITH_MPLAYER=yes
-.endif
-.if exists(${LOCALBASE}/bin/transcode)
-WITH_TRANSCODE=yes
-.endif
-.if exists(${LOCALBASE}/bin/toolame)
-WITH_TOOLAME=yes
-.endif
-.if exists(${LOCALBASE}/bin/mctoolame)
-WITH_MCTOOLAME=yes
-.endif
-
-.if !defined(WITHOUT_NETPBM)
+.if ${PORT_OPTIONS:MNETPBM}
RUN_DEPENDS+= pngtopnm:${PORTSDIR}/graphics/netpbm
.endif
-.if !defined(WITHOUT_MJPEGTOOLS)
+.if ${PROT_OPTIONS:MMJPEGTOOLS}
RUN_DEPENDS+= mpeg2enc:${PORTSDIR}/multimedia/mjpegtools
.endif
-.if !defined(WITHOUT_CDRTOOLS)
-USE_CDRTOOLS= yes
+.if ${PORT_OPTIONS:MCDRTOOLS}
+RUN_DEPENDS+= cdrecord:${PORTSDIR}/sysutils/cdrtools
.endif
-.if defined(WITH_DVDRWTOOLS)
+.if ${PORT_OPTIONS:MDVDRWTOOLS}
RUN_DEPENDS+= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
.endif
-.if !defined(WITHOUT_LIBXINE)
+.if ${PORT_OPTIONS:MLIBXINE}
LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+=--with-xine-support
.endif
-.if defined(WITH_MPLAYER)
+.if ${PORT_OPTIONS:MMPLAYER}
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
CONFIGURE_ARGS+=--with-mplayer-support
.endif
-.if !defined(WITHOUT_TRANSCODE)
+.if ${PORT_OPTIONS:MTRANSCODE}
RUN_DEPENDS+= transcode:${PORTSDIR}/multimedia/transcode
.endif
-.if defined(WITH_TOOLAME)
+.if ${PORT_OPTIONS:MTOOLAME}
RUN_DEPENDS+= toolame:${PORTSDIR}/audio/toolame
.endif
-.if defined(WITH_MCTOOLAME)
+.if ${PORT_OPTIONS:MMCTOOLAME}
RUN_DEPENDS+= mctoolame:${PORTSDIR}/audio/mctoolame-encoder
.endif
@@ -150,4 +123,4 @@ do-install:
.for locale in ca de es
${INSTALL_DATA} ${WRKSRC}/qdvdauthor/i18n/qrender_${locale}.qm ${DATADIR}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/tovid/Makefile b/multimedia/tovid/Makefile
index cfeb23b473a3..ba0e7395bb42 100644
--- a/multimedia/tovid/Makefile
+++ b/multimedia/tovid/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tovid
-# Date created: Mon Dec 26 20:00:42 UTC 2005
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tovid
PORTVERSION= 0.30
@@ -29,6 +25,7 @@ RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
vcdxbuild:${PORTSDIR}/multimedia/vcdimager \
cdrdao:${PORTSDIR}/sysutils/cdrdao \
tcprobe:${PORTSDIR}/multimedia/transcode \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools \
sox:${PORTSDIR}/audio/sox \
normalize:${PORTSDIR}/audio/normalize \
bash:${PORTSDIR}/shells/bash \
@@ -40,7 +37,6 @@ WX_COMPS= python
NO_BUILD= yes
USE_GMAKE= yes
USE_PYTHON= yes
-USE_CDRTOOLS= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes