aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-06 06:17:15 +0800
committerpawel <pawel@FreeBSD.org>2012-11-06 06:17:15 +0800
commit59e3a3cf87e50bd67905950e884835dbfebcdafb (patch)
tree82db3f9df9bb69483386114378fc480b5bc06132 /multimedia
parent8b69abeae4cec7fa0305736ed2b583cd07df8926 (diff)
downloadfreebsd-ports-gnome-59e3a3cf87e50bd67905950e884835dbfebcdafb.tar.gz
freebsd-ports-gnome-59e3a3cf87e50bd67905950e884835dbfebcdafb.tar.zst
freebsd-ports-gnome-59e3a3cf87e50bd67905950e884835dbfebcdafb.zip
- Update to version 1.6.4
- Remove ABI versions from LIB_DEPENDS - Use common description for FREI0R option - Silent REINPLACE_CMD command - Trim Makefile header Feature safe: yes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/lives/Makefile40
-rw-r--r--multimedia/lives/distinfo4
-rw-r--r--multimedia/lives/pkg-plist8
3 files changed, 33 insertions, 19 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 57ee0c4f41d8..f1f2e26b5174 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: lives
-# Date created: 3 November 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= lives
-PORTVERSION= 1.6.3
+PORTVERSION= 1.6.4
CATEGORIES= multimedia
MASTER_SITES= http://salsaman.home.xs4all.nl/lives/current/
DISTNAME= LiVES-${PORTVERSION}
@@ -16,32 +12,42 @@ COMMENT= Video editing system
LICENSE= GPLv3
-BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:${PORTSDIR}/multimedia/v4l_compat
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:${PORTSDIR}/multimedia/v4l_compat \
+ ${LOCALBASE}/bin/analyseplugin:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= asound:${PORTSDIR}/audio/alsa-lib \
+ FLAC:${PORTSDIR}/audio/flac \
jack:${PORTSDIR}/audio/jack \
ogg:${PORTSDIR}/audio/libogg \
+ sndfile:${PORTSDIR}/audio/libsndfile \
vorbis:${PORTSDIR}/audio/libvorbis \
pulse:${PORTSDIR}/audio/pulseaudio \
- oil-0.3.0:${PORTSDIR}/devel/liboil \
+ gdbm:${PORTSDIR}/databases/gdbm \
+ dbus-1:${PORTSDIR}/devel/dbus \
+ execinfo:${PORTSDIR}/devel/libexecinfo \
+ oil:${PORTSDIR}/devel/liboil \
pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- orc-0.4:${PORTSDIR}/devel/orc \
+ orc:${PORTSDIR}/devel/orc \
pcre:${PORTSDIR}/devel/pcre \
aa:${PORTSDIR}/graphics/aalib \
cairo:${PORTSDIR}/graphics/cairo \
- visual-0.4.0:${PORTSDIR}/graphics/libvisual04 \
+ visual-0.4:${PORTSDIR}/graphics/libvisual04 \
+ opencv_calib3d:${PORTSDIR}/graphics/opencv \
png15:${PORTSDIR}/graphics/png \
+ fftw3:${PORTSDIR}/math/fftw3 \
+ fftw3f:${PORTSDIR}/math/fftw3-float \
avcodec:${PORTSDIR}/multimedia/ffmpeg \
dv:${PORTSDIR}/multimedia/libdv \
theora:${PORTSDIR}/multimedia/libtheora \
vpx:${PORTSDIR}/multimedia/libvpx \
- mjpegutils-2.0.0:${PORTSDIR}/multimedia/mjpegtools \
- schroedinger-1.0:${PORTSDIR}/multimedia/schroedinger \
+ mjpegutils:${PORTSDIR}/multimedia/mjpegtools \
+ schroedinger:${PORTSDIR}/multimedia/schroedinger \
xvidcore:${PORTSDIR}/multimedia/xvid \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
xcb:${PORTSDIR}/x11/libxcb
-RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123 \
+RUN_DEPENDS= ${LOCALBASE}/bin/analyseplugin:${PORTSDIR}/audio/ladspa \
+ mpg123:${PORTSDIR}/audio/mpg123 \
sox:${PORTSDIR}/audio/sox \
ogg123:${PORTSDIR}/audio/vorbis-tools \
convert:${PORTSDIR}/graphics/ImageMagick \
@@ -59,6 +65,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:L}
USE_BZIP2= yes
USE_LDCONFIG= yes
USE_ICONV= yes
+USE_NCURSES= yes
USE_GNOME= gtk20 gnomehack gdkpixbuf2
USE_SDL= sdl
USE_PYTHON= yes
@@ -67,8 +74,8 @@ USE_CDRTOOLS= yes
USE_GHOSTSCRIPT_RUN= yes
GNU_CONFIGURE= yes
USE_PKGCONFIG= build
-USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
- xi xinerama xrandr xrender
+USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
+ xfixes xi xinerama xrandr xrender xtst
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --disable-ldvgrab
@@ -86,7 +93,6 @@ DOC_FILES= AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED README \
PORT_VERBS= lives LiVES _encoder.py midistart midistop smogrify sendOSC
OPTIONS_DEFINE= DOXYGEN FREI0R
-FREI0R_DESC= Enable frei0r support
.include <bsd.port.options.mk>
@@ -135,7 +141,7 @@ post-patch:
/flags/s|-Wl,-Bsymbolic||g ; \
/flags/s|--tag=disable-static||g'
@${REINPLACE_CMD} -e 's|-$$(VERSION)||g' ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} 's|/bin/touch|/usr/bin/touch|g' \
+ @${REINPLACE_CMD} 's|/bin/touch|/usr/bin/touch|g' \
${WRKSRC}/smogrify \
${WRKSRC}/src/callbacks.c \
${WRKSRC}/src/saveplay.c \
diff --git a/multimedia/lives/distinfo b/multimedia/lives/distinfo
index c0b87eb1cffe..a6599288b0bc 100644
--- a/multimedia/lives/distinfo
+++ b/multimedia/lives/distinfo
@@ -1,2 +1,2 @@
-SHA256 (LiVES-1.6.3.tar.bz2) = eab661d85d538ea5a21224b437d7c3d85ad930998210dda2644c9c381124f92a
-SIZE (LiVES-1.6.3.tar.bz2) = 3492971
+SHA256 (LiVES-1.6.4.tar.bz2) = 3745e831ad495ae47cbbdec08116ae2f23afcfaa5116eb3edbb721bbf2910db2
+SIZE (LiVES-1.6.4.tar.bz2) = 3497570
diff --git a/multimedia/lives/pkg-plist b/multimedia/lives/pkg-plist
index 90afd9d63ed7..b4c878db9ff0 100644
--- a/multimedia/lives/pkg-plist
+++ b/multimedia/lives/pkg-plist
@@ -63,10 +63,14 @@ lib/lives/plugins/effects/realtime/weed/RGBdelay.la
lib/lives/plugins/effects/realtime/weed/RGBdelay.so
lib/lives/plugins/effects/realtime/weed/alien_overlay.la
lib/lives/plugins/effects/realtime/weed/alien_overlay.so
+lib/lives/plugins/effects/realtime/weed/audio_fft.la
+lib/lives/plugins/effects/realtime/weed/audio_fft.so
lib/lives/plugins/effects/realtime/weed/audio_transition.la
lib/lives/plugins/effects/realtime/weed/audio_transition.so
lib/lives/plugins/effects/realtime/weed/audio_volume.la
lib/lives/plugins/effects/realtime/weed/audio_volume.so
+lib/lives/plugins/effects/realtime/weed/beat_detector.la
+lib/lives/plugins/effects/realtime/weed/beat_detector.so
lib/lives/plugins/effects/realtime/weed/blank_frame_detector.la
lib/lives/plugins/effects/realtime/weed/blank_frame_detector.so
lib/lives/plugins/effects/realtime/weed/blurzoom.la
@@ -85,6 +89,8 @@ lib/lives/plugins/effects/realtime/weed/deinterlace.la
lib/lives/plugins/effects/realtime/weed/deinterlace.so
lib/lives/plugins/effects/realtime/weed/edge.la
lib/lives/plugins/effects/realtime/weed/edge.so
+lib/lives/plugins/effects/realtime/weed/farneback_analyser.la
+lib/lives/plugins/effects/realtime/weed/farneback_analyser.so
lib/lives/plugins/effects/realtime/weed/fg_bg_removal.la
lib/lives/plugins/effects/realtime/weed/fg_bg_removal.so
lib/lives/plugins/effects/realtime/weed/fireTV.la
@@ -97,6 +103,8 @@ lib/lives/plugins/effects/realtime/weed/haar_analyser.la
lib/lives/plugins/effects/realtime/weed/haar_analyser.so
lib/lives/plugins/effects/realtime/weed/haip.la
lib/lives/plugins/effects/realtime/weed/haip.so
+lib/lives/plugins/effects/realtime/weed/ladspa.la
+lib/lives/plugins/effects/realtime/weed/ladspa.so
lib/lives/plugins/effects/realtime/weed/layout_blends.la
lib/lives/plugins/effects/realtime/weed/layout_blends.so
lib/lives/plugins/effects/realtime/weed/lifeTV.la