aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2017-11-06 17:28:57 +0800
committerriggs <riggs@FreeBSD.org>2017-11-06 17:28:57 +0800
commit78d7c38b946b11c4d04a6f8764f331bdbf346d2b (patch)
tree199378988a0590d6360c86e5ab780c16ea16f8b3 /multimedia
parent0a912bf3242200b8e300eb4c7469e79ed1d98f9f (diff)
downloadfreebsd-ports-gnome-78d7c38b946b11c4d04a6f8764f331bdbf346d2b.tar.gz
freebsd-ports-gnome-78d7c38b946b11c4d04a6f8764f331bdbf346d2b.tar.zst
freebsd-ports-gnome-78d7c38b946b11c4d04a6f8764f331bdbf346d2b.zip
Retain API compatibility with faac 1.29.9 and later
Details: - See PR 223416
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpeg4ip/Makefile2
-rw-r--r--multimedia/mpeg4ip/files/patch-server_mp4live_audio__faac.cpp22
2 files changed, 23 insertions, 1 deletions
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index 20a49a05ac6f..6c92a3eeef3e 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mpeg4ip
PORTVERSION= 1.6.1
-PORTREVISION= 36
+PORTREVISION= 37
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= LOCAL/ahze
# http://sourceforge.net/forum/forum.php?thread_id=1839453&forum_id=59136
diff --git a/multimedia/mpeg4ip/files/patch-server_mp4live_audio__faac.cpp b/multimedia/mpeg4ip/files/patch-server_mp4live_audio__faac.cpp
new file mode 100644
index 000000000000..6c5a170b5db9
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-server_mp4live_audio__faac.cpp
@@ -0,0 +1,22 @@
+--- server/mp4live/audio_faac.cpp.orig 2007-01-22 17:31:28 UTC
++++ server/mp4live/audio_faac.cpp
+@@ -296,7 +296,7 @@ bool CFaacAudioEncoder::Init(void)
+
+ debug_message("version = %d", m_faacConfig->version);
+ debug_message("name = %s", m_faacConfig->name);
+- debug_message("allowMidside = %d", m_faacConfig->allowMidside);
++ //debug_message("allowMidside = %d", m_faacConfig->allowMidside);
+ debug_message("useLfe = %d", m_faacConfig->useLfe);
+ debug_message("useTns = %d", m_faacConfig->useTns);
+ debug_message("bitRate = %lu", m_faacConfig->bitRate);
+@@ -308,7 +308,9 @@ bool CFaacAudioEncoder::Init(void)
+
+ m_faacConfig->mpegVersion = MPEG4;
+ m_faacConfig->aacObjectType = LOW;
+- m_faacConfig->allowMidside = false;
++ //Do not set allowMidside for API compatibility with faac,
++ //see https://github.com/knik0/faac/issues/8 for details
++ //m_faacConfig->allowMidside = false;
+ m_faacConfig->useLfe = false;
+ m_faacConfig->useTns = false;
+ m_faacConfig->inputFormat = FAAC_INPUT_16BIT;