aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2012-10-03 04:47:41 +0800
committernox <nox@FreeBSD.org>2012-10-03 04:47:41 +0800
commit83f6bf2ced21f1f23638b58e72ebd6835b203e2f (patch)
tree02997d2db48282cb10b652deb94aedf3a052e2e6 /multimedia
parent3cf8772f5813195e7edce30d91ae828bb2c6ccd9 (diff)
downloadfreebsd-ports-gnome-83f6bf2ced21f1f23638b58e72ebd6835b203e2f.tar.gz
freebsd-ports-gnome-83f6bf2ced21f1f23638b58e72ebd6835b203e2f.tar.zst
freebsd-ports-gnome-83f6bf2ced21f1f23638b58e72ebd6835b203e2f.zip
- Fix default options when not PACKAGE_BUILDING. [1]
- Fix CMAKE_ARGS usage when VORBIS is disabled. [2] - Strip Makefile headers. - Remove a few more shilb major versions from LIB_DEPENDS. - Bump PORTREVISIONs. PR: ports/171478 [1] Submitted by: dumbbell [1] PR: ports/172036 [2] Submitted by: KATO Tsuguru <tkato432@yahoo.com> [2]
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/avidemux2-plugins/Makefile8
-rw-r--r--multimedia/avidemux2/Makefile6
-rw-r--r--multimedia/avidemux2/Makefile.common30
3 files changed, 18 insertions, 26 deletions
diff --git a/multimedia/avidemux2-plugins/Makefile b/multimedia/avidemux2-plugins/Makefile
index b3d94c8afc73..15b4ee722028 100644
--- a/multimedia/avidemux2-plugins/Makefile
+++ b/multimedia/avidemux2-plugins/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: avidemux2
-# Date created: 16 April 2003
-# Whom: Anish Mistry
-# with help from mean
+# Created by: Anish Mistry (with help from mean)
# $FreeBSD$
-#
PORTNAME= avidemux2
PORTVERSION= ${AVIDEMUX2_VERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia
PKGNAMESUFFIX= -plugins
diff --git a/multimedia/avidemux2/Makefile b/multimedia/avidemux2/Makefile
index 47a5b7dd39a1..88055fc35546 100644
--- a/multimedia/avidemux2/Makefile
+++ b/multimedia/avidemux2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: avidemux2
-# Date created: 16 April 2003
-# Whom: Anish Mistry
-# with help from mean
+# Created by: Anish Mistry (with help from mean)
# $FreeBSD$
-#
PORTNAME= avidemux2
PORTVERSION= ${AVIDEMUX2_VERSION}
diff --git a/multimedia/avidemux2/Makefile.common b/multimedia/avidemux2/Makefile.common
index b68830005fc2..b24af8724605 100644
--- a/multimedia/avidemux2/Makefile.common
+++ b/multimedia/avidemux2/Makefile.common
@@ -2,7 +2,7 @@
#
AVIDEMUX2_VERSION= 2.5.6
-PORTREVISION= 4
+PORTREVISION= 5
MASTER_SITES= BERLIOS \
SF/avidemux/avidemux/${PORTVERSION}
DISTNAME= avidemux_${PORTVERSION}
@@ -41,7 +41,7 @@ OPTIONS_DEFINE= GTK2 QT4 FREETYPE FONTCONFIG OSS ESOUND JACK PULSEAUDIO XVIDEO F
OPTIONS_DEFAULT= GTK2 FREETYPE FONTCONFIG OSS XVIDEO VPX XVID SDL FAAD VORBIS
.if !defined(PACKAGE_BUILDING)
-OPTIONS_DEFAULT= LAME FAAC AMR
+OPTIONS_DEFAULT+= LAME FAAC AMR
.endif
.include <bsd.port.pre.mk>
@@ -101,7 +101,7 @@ PLIST_SUB+= JACK="@comment "
.endif
.if ${PORT_OPTIONS:MPULSEAUDIO}
-LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
+LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
PLIST_SUB+= PULSE=""
.else
CMAKE_ARGS+= -DPULSEAUDIOSIMPLE:BOOL=OFF
@@ -109,7 +109,7 @@ PLIST_SUB+= PULSE="@comment "
.endif
.if ${PORT_OPTIONS:MFREETYPE}
-LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
PLIST_SUB+= FREETYPE=""
.else
CMAKE_ARGS+= -DFREETYPE2:BOOL=OFF
@@ -117,19 +117,19 @@ PLIST_SUB+= FREETYPE="@comment "
.endif
.if ${PORT_OPTIONS:MFONTCONFIG}
-LIB_DEPENDS+= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS+= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
.else
CMAKE_ARGS+= -DFONTCONFIG:BOOL=OFF
.endif
.if ${PORT_OPTIONS:MXVIDEO}
-LIB_DEPENDS+= Xv.1:${PORTSDIR}/x11/libXv
+LIB_DEPENDS+= Xv:${PORTSDIR}/x11/libXv
.else
CMAKE_ARGS+= -DXVIDEO:BOOL=OFF
.endif
.if ${PORT_OPTIONS:MFAAC}
-LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
+LIB_DEPENDS+= faac:${PORTSDIR}/audio/faac
PLIST_SUB+= FAAC=""
.else
CMAKE_ARGS+= -DFAAC:BOOL=OFF
@@ -137,7 +137,7 @@ PLIST_SUB+= FAAC="@comment "
.endif
.if ${PORT_OPTIONS:MLAME}
-LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
+LIB_DEPENDS+= mp3lame:${PORTSDIR}/audio/lame
PLIST_SUB+= LAME=""
.else
CMAKE_ARGS+= -DLAME:BOOL=OFF
@@ -145,7 +145,7 @@ PLIST_SUB+= LAME="@comment "
.endif
.if ${PORT_OPTIONS:MFAAD}
-LIB_DEPENDS+= faad.2:${PORTSDIR}/audio/faad
+LIB_DEPENDS+= faad:${PORTSDIR}/audio/faad
PLIST_SUB+= FAAD=""
.else
CMAKE_ARGS+= -DFAAD:BOOL=OFF -DNeAAC:BOOL=OFF
@@ -153,7 +153,7 @@ PLIST_SUB+= FAAD="@comment "
.endif
.if ${PORT_OPTIONS:MX264}
-LIB_DEPENDS+= x264.125:${PORTSDIR}/multimedia/x264
+LIB_DEPENDS+= x264:${PORTSDIR}/multimedia/x264
PLIST_SUB+= X264=""
.else
CMAKE_ARGS+= -DX264:BOOL=OFF
@@ -161,13 +161,13 @@ PLIST_SUB+= X264="@comment "
.endif
.if ${PORT_OPTIONS:MVPX}
-LIB_DEPENDS+= vpx.1:${PORTSDIR}/multimedia/libvpx
+LIB_DEPENDS+= vpx:${PORTSDIR}/multimedia/libvpx
.else
CMAKE_ARGS+= -DVPXDEC:BOOL=OFF
.endif
.if ${PORT_OPTIONS:MXVID}
-LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
+LIB_DEPENDS+= xvidcore:${PORTSDIR}/multimedia/xvid
PLIST_SUB+= XVID=""
.else
CMAKE_ARGS+= -DXVID:BOOL=OFF
@@ -183,15 +183,15 @@ PLIST_SUB+= SDL="@comment "
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
PLIST_SUB+= VORBIS=""
.else
-CMAKE_ARGS+= -DVORBIS:BOOL=OFF
+CMAKE_ARGS+= -DLIBVORBIS:BOOL=OFF -DVORBIS:BOOL=OFF
PLIST_SUB+= VORBIS="@comment "
.endif
.if ${PORT_OPTIONS:MAMR}
-LIB_DEPENDS+= opencore-amrnb.0:${PORTSDIR}/audio/opencore-amr
+LIB_DEPENDS+= opencore-amrnb:${PORTSDIR}/audio/opencore-amr
PLIST_SUB+= AMRNB=""
PLIST_SUB+= AMRWB=""
.else