aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2014-09-24 08:06:07 +0800
committeravilla <avilla@FreeBSD.org>2014-09-24 08:06:07 +0800
commit8a11e15bdd93a6a14e3f4750f94312c0145926e1 (patch)
tree19c9fc758b4748edda616fefeda9cf15ca504c6d /multimedia
parentbf68aa8627f7475c99057d68c1aca281e67dff1e (diff)
downloadfreebsd-ports-gnome-8a11e15bdd93a6a14e3f4750f94312c0145926e1.tar.gz
freebsd-ports-gnome-8a11e15bdd93a6a14e3f4750f94312c0145926e1.tar.zst
freebsd-ports-gnome-8a11e15bdd93a6a14e3f4750f94312c0145926e1.zip
Imagine you captured a nice video with your camcorder, compact camera
or even cell phone while skiing, cycling or whatever sports, and the video is basically just jiggled. Modern cameras come along with hardware stabilization, however this does not work if you have really strong vibrations - rather the contrary, sometimes this mechanisms start to oscillate. Vid.Stab is your friend in this matter. It is designed to stabilize even strongly jiggled clips. WWW: http://public.hronopik.de/vid.stab/
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/vid.stab/Makefile25
-rw-r--r--multimedia/vid.stab/distinfo2
-rw-r--r--multimedia/vid.stab/pkg-descr9
-rw-r--r--multimedia/vid.stab/pkg-plist19
5 files changed, 56 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 307fbd4edf64..cf773614f767 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -385,6 +385,7 @@
SUBDIR += vdr-plugin-xvdr
SUBDIR += vdr-plugins
SUBDIR += vic
+ SUBDIR += vid.stab
SUBDIR += vlc
SUBDIR += vstream-client
SUBDIR += vtkmpeg2encode
diff --git a/multimedia/vid.stab/Makefile b/multimedia/vid.stab/Makefile
new file mode 100644
index 000000000000..58b230b92a9e
--- /dev/null
+++ b/multimedia/vid.stab/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= vid.stab
+PORTVERSION= 0.98.2
+CATEGORIES= multimedia
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= Video stabilization library
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+USE_GITHUB= yes
+GH_ACCOUNT= georgmartius
+GH_TAGNAME= release-0.98b
+GH_COMMIT= 3b35b4d
+
+USES= cmake
+USE_LDCONFIG= yes
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's,lib$${LIB_SUFFIX}/pkgconfig,libdata/pkgconfig,' \
+ ${WRKSRC}/CMakeModules/create_pkgconfig_file.cmake
+
+.include <bsd.port.mk>
diff --git a/multimedia/vid.stab/distinfo b/multimedia/vid.stab/distinfo
new file mode 100644
index 000000000000..ee125da37e2c
--- /dev/null
+++ b/multimedia/vid.stab/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vid.stab-0.98.2.tar.gz) = 638d18f756545385fd48bd85ab890eaf3910fdd6c6d00cb399be7bc346274cb7
+SIZE (vid.stab-0.98.2.tar.gz) = 73590
diff --git a/multimedia/vid.stab/pkg-descr b/multimedia/vid.stab/pkg-descr
new file mode 100644
index 000000000000..9ff7c6409f52
--- /dev/null
+++ b/multimedia/vid.stab/pkg-descr
@@ -0,0 +1,9 @@
+Imagine you captured a nice video with your camcorder, compact camera
+or even cell phone while skiing, cycling or whatever sports, and the
+video is basically just jiggled. Modern cameras come along with
+hardware stabilization, however this does not work if you have really
+strong vibrations - rather the contrary, sometimes this mechanisms
+start to oscillate. Vid.Stab is your friend in this matter. It is
+designed to stabilize even strongly jiggled clips.
+
+WWW: http://public.hronopik.de/vid.stab/
diff --git a/multimedia/vid.stab/pkg-plist b/multimedia/vid.stab/pkg-plist
new file mode 100644
index 000000000000..90cefc4efbe5
--- /dev/null
+++ b/multimedia/vid.stab/pkg-plist
@@ -0,0 +1,19 @@
+include/vid.stab/boxblur.h
+include/vid.stab/frameinfo.h
+include/vid.stab/libvidstab.h
+include/vid.stab/localmotion2transform.h
+include/vid.stab/motiondetect.h
+include/vid.stab/motiondetect_internal.h
+include/vid.stab/motiondetect_opt.h
+include/vid.stab/serialize.h
+include/vid.stab/transform.h
+include/vid.stab/transform_internal.h
+include/vid.stab/transformfixedpoint.h
+include/vid.stab/transformfloat.h
+include/vid.stab/transformtype.h
+include/vid.stab/transformtype_operations.h
+include/vid.stab/vidstabdefines.h
+include/vid.stab/vsvector.h
+lib/libvidstab.so
+lib/libvidstab.so.0.9
+libdata/pkgconfig/vidstab.pc