aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2013-02-23 02:47:13 +0800
committerjkim <jkim@FreeBSD.org>2013-02-23 02:47:13 +0800
commit8ffd676f0f14f13f769269c255d4bb6c263382d1 (patch)
tree1fc3c9b9eb776bc07b2476c401737ccb59c210ea /multimedia
parentdf4f640318266e2db4084ea392ad3b6fbb2d2482 (diff)
downloadfreebsd-ports-gnome-8ffd676f0f14f13f769269c255d4bb6c263382d1.tar.gz
freebsd-ports-gnome-8ffd676f0f14f13f769269c255d4bb6c263382d1.tar.zst
freebsd-ports-gnome-8ffd676f0f14f13f769269c255d4bb6c263382d1.zip
Update to 1.0.7.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gnome-mplayer/Makefile78
-rw-r--r--multimedia/gnome-mplayer/distinfo4
-rw-r--r--multimedia/gnome-mplayer/pkg-plist78
3 files changed, 92 insertions, 68 deletions
diff --git a/multimedia/gnome-mplayer/Makefile b/multimedia/gnome-mplayer/Makefile
index ea032ab3dc0e..2920562b4f68 100644
--- a/multimedia/gnome-mplayer/Makefile
+++ b/multimedia/gnome-mplayer/Makefile
@@ -2,33 +2,31 @@
# $FreeBSD$
PORTNAME= gnome-mplayer
-PORTVERSION= 1.0.0
-PORTREVISION= 3
+PORTVERSION= 1.0.7
CATEGORIES= multimedia gnome
MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME frontend for MPlayer
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ gmtk:${PORTSDIR}/multimedia/gmtk
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
-OPTIONS_DEFINE= GIO GCONF NOTIFY GPOD BRAINZ3 NAUPLUG PANSCAN DOCS
+OPTIONS_DEFINE= ALSA BRAINZ3 DOCS GIO GPOD GTK3 NAUPLUG NLS NOTIFY PULSEAUDIO
+BRAINZ3_DESC= Add support for libmusicbrainz
GIO_DESC= Use GIO for file I/O
GPOD_DESC= Add support for libgpod
-BRAINZ3_DESC= Add support for libmusicbrainz
NAUPLUG_DESC= Enable Nautilus plugin
-PANSCAN_DESC= Enable panscan functionality
MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
-USE_GNOME= glib20 gtk20
+USE_GNOME= glib20
+USE_XORG= x11 xscrnsaver
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --without-alsa
MAN1= ${PORTNAME}.1
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README \
@@ -36,41 +34,41 @@ PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README \
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGIO}
-CONFIGURE_ARGS+= --with-gio
+.if ${PORT_OPTIONS:MALSA}
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
+RUN_DEPENDS+= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
+CONFIGURE_ARGS+= --with-alsa
.else
-CONFIGURE_ARGS+= --without-gio
+CONFIGURE_ARGS+= --without-alsa
.endif
-.if ${PORT_OPTIONS:MGCONF}
-USE_GNOME+= gconf2
-CONFIGURE_ARGS+= --with-gconf
-GCONF_SCHEMAS= ${PORTNAME}.schemas
+.if ${PORT_OPTIONS:MBRAINZ3}
+LIB_DEPENDS+= musicbrainz3:${PORTSDIR}/audio/libmusicbrainz3 \
+ curl:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --with-libmusicbrainz3
.else
-CONFIGURE_ARGS+= --without-gconf --disable-schemas-install
+CONFIGURE_ARGS+= --without-libmusicbrainz3
.endif
-.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
-RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
-CONFIGURE_ARGS+= --with-libnotify
+.if ${PORT_OPTIONS:MGIO}
+CONFIGURE_ARGS+= --with-gio
.else
-CONFIGURE_ARGS+= --without-libnotify
+CONFIGURE_ARGS+= --without-gio
.endif
.if ${PORT_OPTIONS:MGPOD}
-LIB_DEPENDS+= gpod.7:${PORTSDIR}/audio/libgpod
+LIB_DEPENDS+= gpod:${PORTSDIR}/audio/libgpod
CONFIGURE_ARGS+= --with-libgpod
.else
CONFIGURE_ARGS+= --without-libgpod
.endif
-.if ${PORT_OPTIONS:MBRAINZ3}
-LIB_DEPENDS+= musicbrainz3.6:${PORTSDIR}/audio/libmusicbrainz3 \
- curl.6:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --with-libmusicbrainz3
+.if ${PORT_OPTIONS:MGTK3}
+USE_GNOME+= gtk30
+CONFIGURE_ARGS+= --enable-gtk3
.else
-CONFIGURE_ARGS+= --without-libmusicbrainz3
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+= --disable-gtk3
.endif
.if ${PORT_OPTIONS:MNAUPLUG}
@@ -82,10 +80,28 @@ PLIST_SUB+= PLUGIN="@comment "
CONFIGURE_ARGS+= --enable-nautilus=no
.endif
-.if ${PORT_OPTIONS:MPANSCAN}
-CONFIGURE_ARGS+= --enable-panscan
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MNOTIFY}
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
+CONFIGURE_ARGS+= --with-libnotify
+.else
+CONFIGURE_ARGS+= --without-libnotify
+.endif
+
+.if ${PORT_OPTIONS:MPULSEAUDIO}
+LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
+CONFIGURE_ARGS+= --with-pulseaudio
.else
-CONFIGURE_ARGS+= --enable-panscan=no
+CONFIGURE_ARGS+= --without-pulseaudio
.endif
post-patch:
diff --git a/multimedia/gnome-mplayer/distinfo b/multimedia/gnome-mplayer/distinfo
index 854b62a103d1..8406e49d1ef2 100644
--- a/multimedia/gnome-mplayer/distinfo
+++ b/multimedia/gnome-mplayer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome-mplayer-1.0.0.tar.gz) = 4694a4f8409039cef7206eb072952721262dbec372669373b732e617dd5ee530
-SIZE (gnome-mplayer-1.0.0.tar.gz) = 903789
+SHA256 (gnome-mplayer-1.0.7.tar.gz) = 1750c544f4cc2bcdfcf94173d6f28443b40c1a3a310e7367e5686887da0791d0
+SIZE (gnome-mplayer-1.0.7.tar.gz) = 1039861
diff --git a/multimedia/gnome-mplayer/pkg-plist b/multimedia/gnome-mplayer/pkg-plist
index fda91ebafd35..bc9d7b9f38da 100644
--- a/multimedia/gnome-mplayer/pkg-plist
+++ b/multimedia/gnome-mplayer/pkg-plist
@@ -7,41 +7,49 @@ share/icons/hicolor/24x24/apps/gnome-mplayer.png
share/icons/hicolor/32x32/apps/gnome-mplayer.png
share/icons/hicolor/48x48/apps/gnome-mplayer.png
share/icons/hicolor/scalable/apps/gnome-mplayer.svg
-share/locale/ar/LC_MESSAGES/gnome-mplayer.mo
-share/locale/bg/LC_MESSAGES/gnome-mplayer.mo
-share/locale/ca/LC_MESSAGES/gnome-mplayer.mo
-share/locale/cs/LC_MESSAGES/gnome-mplayer.mo
-share/locale/da/LC_MESSAGES/gnome-mplayer.mo
-share/locale/de/LC_MESSAGES/gnome-mplayer.mo
-share/locale/el/LC_MESSAGES/gnome-mplayer.mo
-share/locale/en/LC_MESSAGES/gnome-mplayer.mo
-share/locale/en_GB/LC_MESSAGES/gnome-mplayer.mo
-share/locale/es/LC_MESSAGES/gnome-mplayer.mo
-share/locale/et/LC_MESSAGES/gnome-mplayer.mo
-share/locale/eu/LC_MESSAGES/gnome-mplayer.mo
-share/locale/fi/LC_MESSAGES/gnome-mplayer.mo
-share/locale/fo/LC_MESSAGES/gnome-mplayer.mo
-share/locale/fr/LC_MESSAGES/gnome-mplayer.mo
-share/locale/gl/LC_MESSAGES/gnome-mplayer.mo
-share/locale/he/LC_MESSAGES/gnome-mplayer.mo
-share/locale/hu/LC_MESSAGES/gnome-mplayer.mo
-share/locale/it/LC_MESSAGES/gnome-mplayer.mo
-share/locale/ja/LC_MESSAGES/gnome-mplayer.mo
-share/locale/ko/LC_MESSAGES/gnome-mplayer.mo
-share/locale/lt/LC_MESSAGES/gnome-mplayer.mo
-share/locale/nl/LC_MESSAGES/gnome-mplayer.mo
-share/locale/pl/LC_MESSAGES/gnome-mplayer.mo
-share/locale/pt/LC_MESSAGES/gnome-mplayer.mo
-share/locale/pt_BR/LC_MESSAGES/gnome-mplayer.mo
-share/locale/ro/LC_MESSAGES/gnome-mplayer.mo
-share/locale/ru/LC_MESSAGES/gnome-mplayer.mo
-share/locale/sr/LC_MESSAGES/gnome-mplayer.mo
-share/locale/sr@latin/LC_MESSAGES/gnome-mplayer.mo
-share/locale/sv/LC_MESSAGES/gnome-mplayer.mo
-share/locale/tr/LC_MESSAGES/gnome-mplayer.mo
-share/locale/zh_CN/LC_MESSAGES/gnome-mplayer.mo
-share/locale/zh_HK/LC_MESSAGES/gnome-mplayer.mo
-share/locale/zh_TW/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/el/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/et/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/fo/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/fy/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/he/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/id/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/si/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/th/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/gnome-mplayer.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/gnome-mplayer.mo
%%PLUGIN%%lib/nautilus/extensions-2.0/libgnome-mplayer-properties-page.so
@dirrmtry share/gnome-control-center/default-apps
@dirrmtry share/gnome-control-center