aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2005-10-08 20:47:10 +0800
committerkwm <kwm@FreeBSD.org>2005-10-08 20:47:10 +0800
commit961c68bf2fffd817517a96bafb7b2dbe421cb1a0 (patch)
treeed0e47475c359135cb2e6d04cd04dae35892a500 /multimedia
parent495aed688924b4069054df8df25d5c74f838ce4f (diff)
downloadfreebsd-ports-gnome-961c68bf2fffd817517a96bafb7b2dbe421cb1a0.tar.gz
freebsd-ports-gnome-961c68bf2fffd817517a96bafb7b2dbe421cb1a0.tar.zst
freebsd-ports-gnome-961c68bf2fffd817517a96bafb7b2dbe421cb1a0.zip
Add gstreamer-pitfdll plugin.
This plugin allows gstreamer to load dll's. With with plugin you can now play your wmv version 9 files, avi's with intel codec and (some) quicktime movies.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/gstreamer-pitfdll/Makefile44
-rw-r--r--multimedia/gstreamer-pitfdll/distinfo2
-rw-r--r--multimedia/gstreamer-pitfdll/pkg-descr8
-rw-r--r--multimedia/gstreamer-pitfdll/pkg-plist3
5 files changed, 58 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 4a8c87aa4a94..487847a5b1b8 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -52,6 +52,7 @@
SUBDIR += gstreamer-plugins-mpeg2dec
SUBDIR += gstreamer-plugins-mpeg2enc
SUBDIR += gstreamer-plugins-mplex
+ SUBDIR += gstreamer-pitfdll
SUBDIR += gstreamer-plugins-theora
SUBDIR += gstreamer-plugins-x264
SUBDIR += gstreamer-plugins-xvid
diff --git a/multimedia/gstreamer-pitfdll/Makefile b/multimedia/gstreamer-pitfdll/Makefile
new file mode 100644
index 000000000000..07495af6ffc6
--- /dev/null
+++ b/multimedia/gstreamer-pitfdll/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: gstreamer plugins pitfdll
+# Date created: 08 Oct 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gstreamer-pitfdll
+PORTVERSION= 0.8.1
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= pitfdll-${PORTVERSION}
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= GStreamer DLL loader plugin
+
+RUN_DEPENDS= ${LOCALBASE}/lib/win32/wmv8ds32.ax:${PORTSDIR}/multimedia/win32-codecs
+
+USE_X_PREFIX= yes
+ONLY_FOR_ARCHS= i386
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER=15
+USE_GNOME= gnometarget
+USE_REINPLACE= yes
+USE_GSTREAMER= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB= VERSION="${GST_VERSION}"
+
+GST_VERSION= 0.8
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/lib/win32|${LOCALBASE}/lib/win32|g' \
+ ${WRKSRC}/ext/pitfdll/Makefile.in \
+ ${WRKSRC}/gst-libs/ext/loader/wine/Makefile.in
+
+post-install:
+# register plugins
+ -@${X11BASE}/bin/gst-register-${GST_VERSION} \
+ --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer-pitfdll/distinfo b/multimedia/gstreamer-pitfdll/distinfo
new file mode 100644
index 000000000000..25c619fe40d9
--- /dev/null
+++ b/multimedia/gstreamer-pitfdll/distinfo
@@ -0,0 +1,2 @@
+MD5 (pitfdll-0.8.1.tar.bz2) = 77604fa624fc550ae7661ebf2b2949fa
+SIZE (pitfdll-0.8.1.tar.bz2) = 427624
diff --git a/multimedia/gstreamer-pitfdll/pkg-descr b/multimedia/gstreamer-pitfdll/pkg-descr
new file mode 100644
index 000000000000..f08c0e996a24
--- /dev/null
+++ b/multimedia/gstreamer-pitfdll/pkg-descr
@@ -0,0 +1,8 @@
+Binary loader plugins for Gstreamer.
+Can load dll and qtx as a playback plugin.
+
+Works reasonbly with wmv 9, intel and qdm2.
+
+consider this software beta qualitiy.
+
+WWW: http://sourceforge.net/projects/pitfdll/
diff --git a/multimedia/gstreamer-pitfdll/pkg-plist b/multimedia/gstreamer-pitfdll/pkg-plist
new file mode 100644
index 000000000000..dcbf0c9a912c
--- /dev/null
+++ b/multimedia/gstreamer-pitfdll/pkg-plist
@@ -0,0 +1,3 @@
+lib/gstreamer-%%VERSION%%/libpitfdll.so
+@exec %%X11BASE%%/bin/gst-register-0.8 --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
+@unexec %%X11BASE%%/bin/gst-register-0.8 --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true