aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-30 02:44:04 +0800
committerpawel <pawel@FreeBSD.org>2012-11-30 02:44:04 +0800
commit9fdac65a94c84fd1281ce6f886cc23b582bf501d (patch)
tree99a03a148ecd90ca80cdc94ec880ea47c755e533 /multimedia
parent6e4fc9eda287c11061f7dd0526546150d38485dc (diff)
downloadfreebsd-ports-gnome-9fdac65a94c84fd1281ce6f886cc23b582bf501d.tar.gz
freebsd-ports-gnome-9fdac65a94c84fd1281ce6f886cc23b582bf501d.tar.zst
freebsd-ports-gnome-9fdac65a94c84fd1281ce6f886cc23b582bf501d.zip
libCEC allows you in combination with the right hardware to control your
device with your TV remote control utilising your existing HDMI cabling. This library is an enabling platform for the CEC bus in HDMI, it allows developers to interact with other HDMI devices without having to worry about the communication overhead, handshaking, and the various ways of sending a message for each vendor. WWW: http://libcec.pulse-eight.com PR: ports/172781 Submitted by: Manuel Creach <manuel.creach@icloud.com> Feature safe: yes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/libcec/Makefile36
-rw-r--r--multimedia/libcec/distinfo2
-rw-r--r--multimedia/libcec/pkg-descr8
-rw-r--r--multimedia/libcec/pkg-plist12
5 files changed, 59 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 0fb4350e5290..ea5145660fb0 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -145,6 +145,7 @@
SUBDIR += libaacs
SUBDIR += libass
SUBDIR += libbluray
+ SUBDIR += libcec
SUBDIR += libdc1394
SUBDIR += libdca
SUBDIR += libdv
diff --git a/multimedia/libcec/Makefile b/multimedia/libcec/Makefile
new file mode 100644
index 000000000000..c153ec67b345
--- /dev/null
+++ b/multimedia/libcec/Makefile
@@ -0,0 +1,36 @@
+# Created by: Manuel Creach <manuel.creach@icloud.com>
+# $FreeBSD$
+
+PORTNAME= libcec
+PORTVERSION= 2.0.2
+CATEGORIES= multimedia
+MASTER_SITES= https://github.com/Pulse-Eight/libcec/zipball/libcec-2.0.2/
+
+MAINTAINER= manuel.creach@icloud.com
+COMMENT= Library that allows you to use the Pulse-Eight's HDMI-CEC Adapter
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+FETCH_ARGS= -Fpr
+
+USE_GMAKE= yes
+USE_AUTORECONF= yes
+USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
+ACLOCAL_ARGS= -I.
+AUTOMAKE_ARGS= --add-missing
+USE_PKGCONFIG= build
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+CFLAGS+= -D_FILE_OFFSET_BITS=64
+
+WRKSRC= ${WRKDIR}/Pulse-Eight-libcec-a9ac151
+
+post-patch:
+ ${REINPLACE_CMD} 's|-Werror||' \
+ ${WRKSRC}/configure.ac
+ ${REINPLACE_CMD} 's|$$(libdir)/\(pkgconfig\)|$$(prefix)/libdata/\1|' \
+ ${WRKSRC}/src/lib/Makefile.am
+
+.include <bsd.port.mk>
diff --git a/multimedia/libcec/distinfo b/multimedia/libcec/distinfo
new file mode 100644
index 000000000000..35b2bab2091c
--- /dev/null
+++ b/multimedia/libcec/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcec-2.0.2.tar.gz) = c816077055de5d897c7701794d572dc974392740f7ccb62396f018b1ec7309a3
+SIZE (libcec-2.0.2.tar.gz) = 1246833
diff --git a/multimedia/libcec/pkg-descr b/multimedia/libcec/pkg-descr
new file mode 100644
index 000000000000..20107be2ea21
--- /dev/null
+++ b/multimedia/libcec/pkg-descr
@@ -0,0 +1,8 @@
+libCEC allows you in combination with the right hardware to control your
+device with your TV remote control utilising your existing HDMI cabling.
+This library is an enabling platform for the CEC bus in HDMI, it allows
+developers to interact with other HDMI devices without having to worry
+about the communication overhead, handshaking, and the various ways of
+sending a message for each vendor.
+
+WWW: http://libcec.pulse-eight.com
diff --git a/multimedia/libcec/pkg-plist b/multimedia/libcec/pkg-plist
new file mode 100644
index 000000000000..2688dc91a03d
--- /dev/null
+++ b/multimedia/libcec/pkg-plist
@@ -0,0 +1,12 @@
+lib/libcec.so
+lib/libcec.so.2
+lib/libcec.la
+lib/libcec.a
+include/libcec/cec.h
+include/libcec/cecc.h
+include/libcec/cectypes.h
+include/libcec/cecloader.h
+bin/cec-config
+bin/cec-client
+libdata/pkgconfig/libcec.pc
+@dirrm include/libcec