aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-01-04 01:00:16 +0800
committerpawel <pawel@FreeBSD.org>2015-01-04 01:00:16 +0800
commita21e228f82747b99b471a1ed606ebb1dba231cfa (patch)
tree0350b3da934925730d8401771272128233095335 /multimedia
parenta1859b84ad14be78241d30416894c1e7518e256b (diff)
downloadfreebsd-ports-gnome-a21e228f82747b99b471a1ed606ebb1dba231cfa.tar.gz
freebsd-ports-gnome-a21e228f82747b99b471a1ed606ebb1dba231cfa.tar.zst
freebsd-ports-gnome-a21e228f82747b99b471a1ed606ebb1dba231cfa.zip
- Update to version 2.2.7
- Use gtk3 for gui ChangeLog: Add support for audio triggered generators. Add support for projectM (milkdrop) generators. Improvements to openGL playback plugin. Add permanent inputs in jack and pulse audio when handling external audio. Fix bug in chroma_blend transition. Further code cleanup. Fix text width for "show VJ keys" window. Remove unnecessary deinterlacing from threaded player. Added OSC commands /clip/selection/rte_apply, /clip/undo and /clip/redo. Add libvisual plugins to correct submenu (regression). Minor fixes for the rfx builder window. Minor fixes for merge in clip editor.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/lives/Makefile18
-rw-r--r--multimedia/lives/distinfo4
-rw-r--r--multimedia/lives/pkg-plist3
3 files changed, 13 insertions, 12 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 990dbd34b5e3..49df70878369 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= lives
-PORTVERSION= 2.2.6
-PORTREVISION= 3
+PORTVERSION= 2.2.7
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
@@ -18,6 +17,7 @@ LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib \
libjack.so:${PORTSDIR}/audio/jack \
libpulse.so:${PORTSDIR}/audio/pulseaudio \
liboil-0.3.so:${PORTSDIR}/devel/liboil \
+ libprojectM.so:${PORTSDIR}/graphics/libprojectm \
libvisual-0.4.so:${PORTSDIR}/graphics/libvisual04 \
libopencv_calib3d.so:${PORTSDIR}/graphics/opencv \
libfftw3.so:${PORTSDIR}/math/fftw3 \
@@ -47,10 +47,10 @@ SHEBANG_FILES= build-lives-rfx-plugin build-lives-rfx-plugin-multi \
GNU_CONFIGURE= yes
USE_CSTD= gnu89
USE_GHOSTSCRIPT_RUN= yes
-USE_GNOME= gtk20
+USE_GNOME= gtk30
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-ldvgrab --disable-gtk3
+CONFIGURE_ARGS= --disable-ldvgrab
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include -fPIC
@@ -100,17 +100,17 @@ post-patch:
@${REINPLACE_CMD} '/cp -rf/ s|data/|data|g; /cp -rf/ s|icons/|icons|g' \
${WRKSRC}/lives-plugins/weed-plugins/cairo/Makefile.in \
${WRKSRC}/lives-plugins/weed-plugins/Makefile.in
+ @${REINPLACE_CMD} '/selectRandom/d' \
+ ${WRKSRC}/lives-plugins/weed-plugins/projectM.cpp
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
- cd ${STAGEDIR}${PREFIX}/bin && ${RM} lives && ${LN} -s lives-exe lives
+ (cd ${STAGEDIR}${PREFIX}/bin && ${RM} lives && ${LN} -s lives-exe lives)
.if ${PORT_OPTIONS:MDOXYGEN}
- @cd ${STAGEDIR}${PREFIX} && \
- ${FIND} ${DOCSDIR:S|${PREFIX}/||}/html ! -type d >> ${TMPPLIST} && \
- ${FIND} ${DOCSDIR:S|${PREFIX}/||} -type d | ${SORT} -r | \
- ${SED} 's|^|@dirrm |' >> ${TMPPLIST}
+ @(cd ${STAGEDIR}${PREFIX} && ${FIND} ${DOCSDIR:S|${PREFIX}/||}/html \
+ ! -type d >> ${TMPPLIST})
.endif
.include <bsd.port.mk>
diff --git a/multimedia/lives/distinfo b/multimedia/lives/distinfo
index 5d25d9e01dd2..3f3615c540ad 100644
--- a/multimedia/lives/distinfo
+++ b/multimedia/lives/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lives-2.2.6.tar.bz2) = 2aaa58a7cb578492fb1a89659668658ddfdf72c510309c71d56896ad9b4c44a0
-SIZE (lives-2.2.6.tar.bz2) = 3587838
+SHA256 (lives-2.2.7.tar.bz2) = 6d02c0f4b9a353488156b9f7c07f1a7d88fda496059e1391e4e5bd4eb1dc9470
+SIZE (lives-2.2.7.tar.bz2) = 3609897
diff --git a/multimedia/lives/pkg-plist b/multimedia/lives/pkg-plist
index 34d151ccaa0a..d5c918a4fdf4 100644
--- a/multimedia/lives/pkg-plist
+++ b/multimedia/lives/pkg-plist
@@ -96,6 +96,7 @@ lib/lives/plugins/effects/realtime/weed/onedTV.so
lib/lives/plugins/effects/realtime/weed/palette_test.so
lib/lives/plugins/effects/realtime/weed/plasma.so
lib/lives/plugins/effects/realtime/weed/posterise.so
+lib/lives/plugins/effects/realtime/weed/projectM.so
lib/lives/plugins/effects/realtime/weed/puretext.so
lib/lives/plugins/effects/realtime/weed/randomiser.so
lib/lives/plugins/effects/realtime/weed/revTV.so
@@ -191,7 +192,7 @@ lib/lives/plugins/playback/video/vloopback.so
lib/lives/plugins/playback/video/vloopback2.so
lib/lives/plugins/playback/video/yuv4mpeg_stream.so
libdata/pkgconfig/libweed-compat.pc
-libdata/pkgconfig/libweed-plugin-utils.pc
+libdata/pkgconfig/libweed-plugin.pc
libdata/pkgconfig/libweed-utils.pc
libdata/pkgconfig/libweed.pc
libdata/pkgconfig/libweed_slice.pc