aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-07-20 12:15:24 +0800
committerjbeich <jbeich@FreeBSD.org>2017-07-20 12:15:24 +0800
commita7449a8a073b21ee557b0661fbb8bd7d00a367ff (patch)
treead5b655f325665c260042bc8f56ea5490e063ee4 /multimedia
parentd55bcc7c2c220b29888d67b61eeb8897a965cdef (diff)
downloadfreebsd-ports-gnome-a7449a8a073b21ee557b0661fbb8bd7d00a367ff.tar.gz
freebsd-ports-gnome-a7449a8a073b21ee557b0661fbb8bd7d00a367ff.tar.zst
freebsd-ports-gnome-a7449a8a073b21ee557b0661fbb8bd7d00a367ff.zip
multimedia/gnome-mpv: add new port
MFH: 2017Q3 (trivial port, popular according to repology.org) GNOME MPV is a simple GTK+ frontend for mpv. GNOME MPV interacts with mpv via the client API exported by libmpv, allowing access to mpv's powerful playback capabilities. https://gnome-mpv.github.io/
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/gnome-mpv/Makefile24
-rw-r--r--multimedia/gnome-mpv/distinfo3
-rw-r--r--multimedia/gnome-mpv/pkg-descr5
-rw-r--r--multimedia/gnome-mpv/pkg-plist21
5 files changed, 54 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 05a55158b778..9e644f687351 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -81,6 +81,7 @@
SUBDIR += gmp-api
SUBDIR += gmtk
SUBDIR += gnome-mplayer
+ SUBDIR += gnome-mpv
SUBDIR += gnome-subtitles
SUBDIR += gpac-libgpac
SUBDIR += gpac-mp4box
diff --git a/multimedia/gnome-mpv/Makefile b/multimedia/gnome-mpv/Makefile
new file mode 100644
index 000000000000..24e281ea5065
--- /dev/null
+++ b/multimedia/gnome-mpv/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= gnome-mpv
+PORTVERSION= 0.12
+CATEGORIES= multimedia
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${PORTVERSION}/
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Simple GTK+ frontend for mpv
+
+LICENSE= GPLv3+
+
+LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
+ libmpv.so:multimedia/mpv
+
+USES= desktop-file-utils gettext-tools gmake pkgconfig tar:xz
+USE_GNOME= cairo gtk30
+GNU_CONFIGURE= yes
+GLIB_SCHEMAS= io.github.GnomeMpv.gschema.xml \
+ org.gnome-mpv.gschema.xml
+INSTALLS_ICONS= yes
+LDFLAGS+= -Wl,--as-needed # gdkpixbuf2
+
+.include <bsd.port.mk>
diff --git a/multimedia/gnome-mpv/distinfo b/multimedia/gnome-mpv/distinfo
new file mode 100644
index 000000000000..4e0161080151
--- /dev/null
+++ b/multimedia/gnome-mpv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1497264613
+SHA256 (gnome-mpv-0.12.tar.xz) = 6c121261a1ea7e8065379c5355c2b2061eb4abbff0c8121ada211d4777fa9635
+SIZE (gnome-mpv-0.12.tar.xz) = 284576
diff --git a/multimedia/gnome-mpv/pkg-descr b/multimedia/gnome-mpv/pkg-descr
new file mode 100644
index 000000000000..838b71193348
--- /dev/null
+++ b/multimedia/gnome-mpv/pkg-descr
@@ -0,0 +1,5 @@
+GNOME MPV is a simple GTK+ frontend for mpv. GNOME MPV interacts with
+mpv via the client API exported by libmpv, allowing access to mpv's
+powerful playback capabilities.
+
+WWW: https://gnome-mpv.github.io/
diff --git a/multimedia/gnome-mpv/pkg-plist b/multimedia/gnome-mpv/pkg-plist
new file mode 100644
index 000000000000..66e34468fd28
--- /dev/null
+++ b/multimedia/gnome-mpv/pkg-plist
@@ -0,0 +1,21 @@
+bin/gnome-mpv
+share/appdata/io.github.GnomeMpv.appdata.xml
+share/applications/io.github.GnomeMpv.desktop
+share/icons/hicolor/scalable/apps/gnome-mpv.svg
+share/icons/hicolor/symbolic/apps/gnome-mpv-symbolic.svg
+share/locale/ca/LC_MESSAGES/gnome-mpv.mo
+share/locale/cs/LC_MESSAGES/gnome-mpv.mo
+share/locale/de_DE/LC_MESSAGES/gnome-mpv.mo
+share/locale/fr/LC_MESSAGES/gnome-mpv.mo
+share/locale/hu/LC_MESSAGES/gnome-mpv.mo
+share/locale/it/LC_MESSAGES/gnome-mpv.mo
+share/locale/ja/LC_MESSAGES/gnome-mpv.mo
+share/locale/nl/LC_MESSAGES/gnome-mpv.mo
+share/locale/pl/LC_MESSAGES/gnome-mpv.mo
+share/locale/pt_PT/LC_MESSAGES/gnome-mpv.mo
+share/locale/ro/LC_MESSAGES/gnome-mpv.mo
+share/locale/ru/LC_MESSAGES/gnome-mpv.mo
+share/locale/sr_RS/LC_MESSAGES/gnome-mpv.mo
+share/locale/sr_RS@latin/LC_MESSAGES/gnome-mpv.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-mpv.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-mpv.mo