aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-05-30 04:37:38 +0800
committerpawel <pawel@FreeBSD.org>2012-05-30 04:37:38 +0800
commitaaf0168995bfd6d9122f7f91001c606008153797 (patch)
treeecec48f6a8249f898d85e6dc957fea323e7e4add /multimedia
parent4ca80fd831705670eafd2f34ffbd7a3e45a010a6 (diff)
downloadfreebsd-ports-gnome-aaf0168995bfd6d9122f7f91001c606008153797.tar.gz
freebsd-ports-gnome-aaf0168995bfd6d9122f7f91001c606008153797.tar.zst
freebsd-ports-gnome-aaf0168995bfd6d9122f7f91001c606008153797.zip
smtube is a youtube browser for smplayer. You can browse, search, download
and play youtube videos. The videos are currently played in smplayer but in the future it may be added the possibility to use other players. WWW: http://smplayer.sourceforge.net/
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/smtube/Makefile43
-rw-r--r--multimedia/smtube/distinfo2
-rw-r--r--multimedia/smtube/pkg-descr5
-rw-r--r--multimedia/smtube/pkg-plist18
5 files changed, 69 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 84de18c6f733..bf997e9572cf 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -298,6 +298,7 @@
SUBDIR += smplayer
SUBDIR += smplayer-themes
SUBDIR += sms1xxx-kmod
+ SUBDIR += smtube
SUBDIR += spigot
SUBDIR += spook
SUBDIR += streamanalyze
diff --git a/multimedia/smtube/Makefile b/multimedia/smtube/Makefile
new file mode 100644
index 000000000000..893c391076bb
--- /dev/null
+++ b/multimedia/smtube/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: smtube
+# Date created: 2012-05-17
+# Whom: Pawel Pekala <pawel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smtube
+PORTVERSION= 1.1
+CATEGORIES= multimedia
+MASTER_SITES= SF/smplayer/SMTube/${PORTVERSION}/
+
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= SMPlayer YouTube browser
+
+RUN_DEPENDS= ${LOCALBASE}/bin/smplayer:${PORTSDIR}/multimedia/smplayer
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= linguist_build moc_build qmake_build rcc_build uic_build \
+ corelib gui network xml
+INSTALLS_ICONS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|qmake|${QMAKE}|g' \
+ -e 's|lrelease|${QT_PREFIX}/bin/lrelease-qt4|g' \
+ -e 's|PREFIX=/usr/local|PREFIX=${PREFIX}|g' \
+ -e 's|$$(PREFIX)/share/smtube|${DATADIR}|g' \
+ ${WRKSRC}/Makefile
+
+.if !defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|$$(PREFIX)/share/doc/smtube|${DOCSDIR}|' \
+ ${WRKSRC}/Makefile
+PORTDOCS= *
+.else
+ @${REINPLACE_CMD} -e '/DOC_PATH/d' ${WRKSRC}/Makefile
+.endif
+
+do-build:
+ cd ${WRKSRC} && ${MAKE}
+
+.include <bsd.port.mk>
diff --git a/multimedia/smtube/distinfo b/multimedia/smtube/distinfo
new file mode 100644
index 000000000000..5043e1efa94e
--- /dev/null
+++ b/multimedia/smtube/distinfo
@@ -0,0 +1,2 @@
+SHA256 (smtube-1.1.tar.bz2) = a86e6f75bf1609f28cd9ec88820a95a380a88ff978a1b15f30121e045cf05b99
+SIZE (smtube-1.1.tar.bz2) = 296345
diff --git a/multimedia/smtube/pkg-descr b/multimedia/smtube/pkg-descr
new file mode 100644
index 000000000000..017e570bd6c7
--- /dev/null
+++ b/multimedia/smtube/pkg-descr
@@ -0,0 +1,5 @@
+smtube is a youtube browser for smplayer. You can browse, search, download
+and play youtube videos. The videos are currently played in smplayer but
+in the future it may be added the possibility to use other players.
+
+WWW: http://smplayer.sourceforge.net/
diff --git a/multimedia/smtube/pkg-plist b/multimedia/smtube/pkg-plist
new file mode 100644
index 000000000000..56b49fca8bbc
--- /dev/null
+++ b/multimedia/smtube/pkg-plist
@@ -0,0 +1,18 @@
+bin/smtube
+%%DATADIR%%/translations/smtube_en.qm
+%%DATADIR%%/translations/smtube_es.qm
+%%DATADIR%%/translations/smtube_eu.qm
+%%DATADIR%%/translations/smtube_ja.qm
+%%DATADIR%%/translations/smtube_lt.qm
+%%DATADIR%%/translations/smtube_pt.qm
+%%DATADIR%%/translations/smtube_ru_RU.qm
+%%DATADIR%%/translations/smtube_zh_CN.qm
+share/icons/hicolor/256x256/apps/smtube.png
+share/icons/hicolor/128x128/apps/smtube.png
+share/icons/hicolor/64x64/apps/smtube.png
+share/icons/hicolor/48x48/apps/smtube.png
+share/icons/hicolor/32x32/apps/smtube.png
+share/icons/hicolor/16x16/apps/smtube.png
+share/applications/smtube.desktop
+@dirrm %%DATADIR%%/translations
+@dirrm %%DATADIR%%