aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-12-14 02:49:26 +0800
committerriggs <riggs@FreeBSD.org>2014-12-14 02:49:26 +0800
commitc5baf6ca8e701f3b44fa4a3f29275d1fc77eee1a (patch)
tree01dfe539a1ce241b6dc70da96fef66bbd992e79b /multimedia
parent90efde8f73f8acb04609b264436d85eecfd33448 (diff)
downloadfreebsd-ports-gnome-c5baf6ca8e701f3b44fa4a3f29275d1fc77eee1a.tar.gz
freebsd-ports-gnome-c5baf6ca8e701f3b44fa4a3f29275d1fc77eee1a.tar.zst
freebsd-ports-gnome-c5baf6ca8e701f3b44fa4a3f29275d1fc77eee1a.zip
- Fix buffering in OSS backend
- Fix QT4 GUI layout issue While one it: - Use INSTALLS_ICONS PR: 193807 Submitted by: hselasky@FreeBSD.org
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile4
-rw-r--r--multimedia/vlc/files/patch-modules-audio_output-oss.c (renamed from multimedia/vlc/files/patch-c1622c2c6e0e15a38fef723086ca8bf75a75b46b-2.1.5)21
-rw-r--r--multimedia/vlc/files/patch-modules-gui-qt4-components-simple_preferences.cpp12
3 files changed, 29 insertions, 8 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 35bf869bb42f..a3e395a25c09 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vlc
DISTVERSION= 2.1.5
-PORTREVISION= 12
+PORTREVISION= 13
PORTEPOCH= 4
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
@@ -29,6 +29,8 @@ USE_GNOME= libxml2
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+INSTALLS_ICONS= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-avcodec --enable-avformat --enable-dvbpsi \
--enable-fontconfig --enable-freetype --enable-libgcrypt \
diff --git a/multimedia/vlc/files/patch-c1622c2c6e0e15a38fef723086ca8bf75a75b46b-2.1.5 b/multimedia/vlc/files/patch-modules-audio_output-oss.c
index f3cff00fb26b..7c896ede269a 100644
--- a/multimedia/vlc/files/patch-c1622c2c6e0e15a38fef723086ca8bf75a75b46b-2.1.5
+++ b/multimedia/vlc/files/patch-modules-audio_output-oss.c
@@ -1,9 +1,5 @@
-Backported from:
-
- http://git.videolan.org/gitweb.cgi/vlc.git/?a=commit;h=c1622c2c6e0e15a38fef723086ca8bf75a75b46b
-
---- modules/audio_output/oss.c.orig
-+++ modules/audio_output/oss.c
+--- modules/audio_output/oss.c.orig 2014-02-27 14:31:53.000000000 +0100
++++ modules/audio_output/oss.c 2014-09-21 13:19:37.000000000 +0200
@@ -37,6 +37,7 @@
#else
# include <sys/soundcard.h>
@@ -12,7 +8,7 @@ Backported from:
#ifndef SNDCTL_DSP_HALT
# define SNDCTL_DSP_HALT SNDCTL_DSP_RESET
-@@ -209,6 +210,22 @@ static int Start (audio_output_t *aout,
+@@ -209,6 +210,22 @@
}
aout_FormatPrepare (fmt);
@@ -35,3 +31,14 @@ Backported from:
sys->fd = fd;
VolumeSync (aout);
sys->starting = true;
+@@ -230,8 +247,8 @@
+ return -1;
+ }
+
+- *pts = (delay * CLOCK_FREQ * sys->format.i_frame_length)
+- / (sys->format.i_rate * sys->format.i_bytes_per_frame);
++ *pts = (delay * CLOCK_FREQ)
++ / (sys->format.i_rate * sys->format.i_bytes_per_frame);
+ return 0;
+ }
+
diff --git a/multimedia/vlc/files/patch-modules-gui-qt4-components-simple_preferences.cpp b/multimedia/vlc/files/patch-modules-gui-qt4-components-simple_preferences.cpp
new file mode 100644
index 000000000000..8becff050057
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules-gui-qt4-components-simple_preferences.cpp
@@ -0,0 +1,12 @@
+--- modules/gui/qt4/components/simple_preferences.cpp.orig 2014-12-09 10:47:08.000000000 +0100
++++ modules/gui/qt4/components/simple_preferences.cpp 2014-12-09 10:48:34.000000000 +0100
+@@ -419,7 +419,8 @@
+ QLineEdit * name ## Device = new QLineEdit; \
+ name ## Label->setBuddy( name ## Device ); \
+ QPushButton * name ## Browse = new QPushButton( qtr( "Browse..." ) ); \
+- outputAudioLayout->addWidget( name ## Device, outputAudioLayout->rowCount() - 1, 0, 1, -1, Qt::AlignLeft );
++ outputAudioLayout->addWidget( name ## Device, outputAudioLayout->rowCount() - 1, 0, 1, -1, Qt::AlignLeft ); \
++ outputAudioLayout->addWidget( name ## Browse, outputAudioLayout->rowCount() - 1, 1, 1, -1, Qt::AlignLeft );
+
+ /* Build if necessary */
+ QGridLayout * outputAudioLayout = qobject_cast<QGridLayout *>(ui.outputAudioBox->layout());